CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Number 05 not of correct type

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 22, 2004, 04:12
Default I am tyring to change the end
  #1
Michael Wessels (Wessels)
Guest
 
Posts: n/a
I am tyring to change the endTime in controlDict of the tutorial 'cavity'. I got this message
'Number 0,5 not of correct type'

I am able to change parameters with an integral value.

What is the solultion of this probelm ?

I am running OpenFOAM on a Pentium4-Linux-PC.

Best regards

Michael
  Reply With Quote

Old   December 22, 2004, 04:33
Default Try writing 0.5 with a dot in
  #2
Hrvoje Jasak (Hjasak)
Guest
 
Posts: n/a
Try writing 0.5 with a dot instead of comma
  Reply With Quote

Old   December 22, 2004, 04:40
Default I have tried it. But it doesn
  #3
Michael Wessels (Wessels)
Guest
 
Posts: n/a
I have tried it. But it doesn't work.

Michael
  Reply With Quote

Old   December 22, 2004, 04:47
Default I have tried it. But it doesn
  #4
Michael Wessels (Wessels)
Guest
 
Posts: n/a
I have tried it. But it doesn't work.

Michael
  Reply With Quote

Old   December 22, 2004, 05:34
Default I happens because you have a
  #5
Joern Beilke (Beilke)
Guest
 
Posts: n/a
I happens because you have a german installation and java thinks, that the germans always use the "," instead of the "."

Just put the line

export LANG=en_EN

at the beginning of the

~/OpenFOAM/OpenFOAM-1.0/.OpenFOAM-1.0/bashrc
  Reply With Quote

Old   January 12, 2005, 14:22
Default Thank you for making FOAM ope
  #6
Duderino (Duderino)
Guest
 
Posts: n/a
Thank you for making FOAM open source.

I've got the same problem as Michael.
I am using OpenFOAM-1.0.2 on Linux (Mandrake 10)

The hint of Joern:
#Just put the line
#export LANG=en_EN
#at the beginning of the
#~/OpenFOAM/OpenFOAM-1.0.2/.OpenFOAM-1.0.2/bashrc
didn't solve the problem so far.

Thank you

duderino
  Reply With Quote

Old   October 30, 2006, 04:14
Default Same Problem here. Using Ub
  #7
New Member
 
Matthias Hoerl
Join Date: Mar 2009
Posts: 8
Rep Power: 8
hoerl is on a distinguished road
Same Problem here.

Using Ubuntu 6.10 and OpenFOAM 1.3 it shows me the exception "Number 0,5 not of correct type" this message also appears if i type "0.5"

yes the ubuntu install was made in german.

is there an fix for this ?!

mfg matthias
hoerl is offline   Reply With Quote

Old   October 30, 2006, 04:24
Default Didn't it work with the soluti
  #8
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Didn't it work with the solution provided by Joern Beilke few posts above?
If it doesn't, then I suggest to skip FoamX and edit directly your controlDict file.

Dragos
dmoroian is offline   Reply With Quote

Old   October 30, 2006, 04:47
Default skipping FoamX would be the on
  #9
New Member
 
Matthias Hoerl
Join Date: Mar 2009
Posts: 8
Rep Power: 8
hoerl is on a distinguished road
skipping FoamX would be the only way - thx for answering so fast ...
hoerl is offline   Reply With Quote

Old   October 30, 2006, 05:22
Default Matthias: The answer to you
  #10
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Matthias:

The answer to your question might be this:
http://openfoamwiki.net/index.php/Main_FAQ#Why_doesn.27t_FoamX_allow_me_to_enter _numbers.3F
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   October 30, 2006, 14:10
Default Hi, I happened to come acro
  #11
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hi,
I happened to come across this discussion, and maybe I can be of a little help here....:-)

I installed OpenFOAM 1.3 on Fedora Core 6 yesterday for a friend who uses a German interface. As noted by you all, when you run FoamX, Java adopts the regional setting from the Operating system to display the numbers, and you end up with...0,5 instead of 0.5.

This is what I did, and it works like a charm...

I opened the FoamX bash script:

cd $WM_PROJECT_DIR/bin/
<editor> FoamX

Once the file opens, after the comments, just before the lines:

# Set default JDK path.
jdkhome="/usr/java/jdk1.4"

I added the following:

# Set Language to English
oldLang=`echo $LANG`
export LANG=en_EN

And, at the end of the script file, right at the bottom, I added:

# Reset Language to original
export LANG=$oldLang

This is basically what the link which Bernhard Gschaider provided suggests too.

Have a nice day!

Philippose
philippose is offline   Reply With Quote

Old   October 30, 2006, 15:42
Default ok thanx to both of you ..
  #12
New Member
 
Matthias Hoerl
Join Date: Mar 2009
Posts: 8
Rep Power: 8
hoerl is on a distinguished road
ok thanx to both of you ..

as you said philippose - this works like a charm
thanks for sharing
hoerl is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Run type type determination grtabor OpenFOAM Native Meshers: blockMesh 4 February 23, 2007 07:05
renolds number-flow type naveen CFX 1 November 12, 2006 16:52
renolds number-flow type naveen CFX 0 November 10, 2006 10:48
How to hold the cell type number Petr Nekolny CD-adapco 2 December 3, 2004 04:25
Meshing by specify a type and number of node Jackie CFX 5 April 13, 2003 16:54


All times are GMT -4. The time now is 21:03.