CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Libstdcso6 cannot handle TLS data (http://www.cfd-online.com/Forums/openfoam-installation/57618-libstdcso6-cannot-handle-tls-data.html)

barryw September 6, 2006 14:38

Hi All I am trying to get O
 
Hi All

I am trying to get OpenFOAM-1.3 working, I have installed as per the instructions.
But as soon as I try and run FoamX, I get the following error:

nsd: error while loading shared libraries: libstc++.so.6: cannot handle TLS data

I am running slackware 10.1

Thanks, Barry

hjasak September 6, 2006 18:03

By the looks of thihgs, you ar
 
By the looks of thihgs, you are having trouble either with the version of corba you're picking up or with the compiler. Try doing

ldd 'which icoFoam"

and

which nsd

and see what libraries are being picked up. Mine looks like this:

wooster*103-> ldd /home/hjasak/OpenFOAM/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam
linux-gate.so.1 => (0xffffe000)
libfiniteVolume.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libfiniteVolume.so (0x4001d000)
libOpenFOAM.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libOpenFOAM.so (0x4076f000)
libstdc++.so.6 => /home/hjasak/OpenFOAM/linux/gcc-4.1.1/lib/libstdc++.so.6 (0x40a36000)
libm.so.6 => /lib/libm.so.6 (0x40b48000)
libgcc_s.so.1 => /home/hjasak/OpenFOAM/linux/gcc-4.1.1/lib/libgcc_s.so.1 (0x40b6d000)
libpthread.so.0 => /lib/libpthread.so.0 (0x40b78000)
libc.so.6 => /lib/libc.so.6 (0x40b8c000)
libPstream.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/lam-7.1.1/libPstream.so (0x40cac000)
libtriSurface.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libtriSurface.so (0x40cb4000)
libmeshTools.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libmeshTools.so (0x40d23000)
libfoamUser.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libfoamUser.so (0x40e73000)
libz.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/libz.so (0x40e75000)
/lib/ld-linux.so.2 (0x40000000)
libmpi.so.0 => /home/hjasak/OpenFOAM/OpenFOAM-1.3/src/lam-7.1.1/platforms/linuxGcc4DPOpt/lib/li bmpi.so.0 (0x40e88000)
liblam.so.0 => /home/hjasak/OpenFOAM/OpenFOAM-1.3/src/lam-7.1.1/platforms/linuxGcc4DPOpt/lib/li blam.so.0 (0x40efd000)
libutil.so.1 => /lib/libutil.so.1 (0x40f50000)
liblagrangian.so => /home/hjasak/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/liblagrangian.so (0x40f54000)
libdl.so.2 => /lib/libdl.so.2 (0x40f57000)

You will probably be picking up some system libraries instead.

Hrv

barryw September 7, 2006 02:02

Hi Hrv Thanks for the Reply
 
Hi Hrv

Thanks for the Reply

Here is the output from

barry@kilimanjaro:~$ ldd /home/barry/OpenFOAM/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam
/home/barry/OpenFOAM/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam: error while loading shared libraries: libstdc++.so.6: cannot handle TLS data
ls op

barry@kilimanjaro:~$ ldd OpenFOAM/OpenFOAM-1.3/src/mico-2.3.11/platforms/linuxGcc4DPOpt/bin/nsd
OpenFOAM/OpenFOAM-1.3/src/mico-2.3.11/platforms/linuxGcc4DPOpt/bin/nsd: error while loading shared libraries: libstdc++.so.6: cannot handle TLS data

?

Barry


All times are GMT -4. The time now is 01:33.