CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Installation of 13

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 17, 2006, 08:53
Default Hi. I'm upgrading OpenFOAM on
  #1
Senior Member
 
Gavin Tabor
Join Date: Mar 2009
Posts: 181
Rep Power: 8
grtabor is on a distinguished road
Hi. I'm upgrading OpenFOAM on my own machine. Followed the usual routine of downloading and installing, then tried to run blockMesh on the cavity case from the tutorials. Error as follows:

lutoslawski<39> blockMesh . cavity
blockMesh: /lib/tls/libc.so.6: version `GLIBC_2.3.4' not found (required by blockMesh)

I've checked through my .cshrc file several times, and can't understand what is going wrong here (particularly as I've already successfully upgraded my PhD student's machines). I'm probably doing something very stupid, but I can't see what. Any suggestions?

Gavin
grtabor is offline   Reply With Quote

Old   May 17, 2006, 08:59
Default What OS + version are you runn
  #2
New Member
 
Rolf Hansen
Join Date: Mar 2009
Posts: 10
Rep Power: 8
rogn is on a distinguished road
What OS + version are you running ?

Rolf
rogn is offline   Reply With Quote

Old   May 17, 2006, 09:11
Default ... and what OS + version is y
  #3
New Member
 
Rolf Hansen
Join Date: Mar 2009
Posts: 10
Rep Power: 8
rogn is on a distinguished road
... and what OS + version is your student running ?
rogn is offline   Reply With Quote

Old   May 17, 2006, 09:19
Default I'm on RedHat 9 (.0, I think)
  #4
Senior Member
 
Gavin Tabor
Join Date: Mar 2009
Posts: 181
Rep Power: 8
grtabor is on a distinguished road
I'm on RedHat 9 (.0, I think) - he may be on RedHat 8, being a slightly older machine.

Gavin
grtabor is offline   Reply With Quote

Old   May 17, 2006, 09:53
Default The problem is that a fully up
  #5
New Member
 
Rolf Hansen
Join Date: Mar 2009
Posts: 10
Rep Power: 8
rogn is on a distinguished road
The problem is that a fully updated RedHat 9 only reaches glibc version 2.3.2-something and that the OpenFOAM-1.3 binaries have been created on a machine with newer glibc version. I had the same problem on our cluster. I read that updating glibc is VERY MESSY and could destroy your OS so that even simple commands like ls and cp does not work anymore. I therefore searched the forum and found a post by Bernhard Gsnaider that helped me:

"... What I did was: remove the executable-binaries (not the .o-s and not the .so-s) and perform a wmake in the applications directory. That should only relink the applications (and then everything should be fine)"

This worked for me even though I had to do some manual recompiling with for example foamFlex++, but it can be done.

Alternatively update to RedHat fedora core 3. I am running FC3 on my personal PC, and I have no problems running OpenFOAM-1.3.

I would certaintly recommend you to update your OS since this is the quickest thing to do. Also RedHat 9 is obsolete with no active updates etc.

Regards
Rolf
rogn is offline   Reply With Quote

Old   May 17, 2006, 11:16
Default You can also recompile the who
  #6
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 330
Rep Power: 13
mbeaudoin will become famous soon enough
You can also recompile the whole thing from source, instead of using the pre-compiled binary version, or upgrading your OS.

Check out this document on the OpenFOAM Wiki:

http://openfoamwiki.net/index.php/Howto_compile_O penFOAM

Martin
mbeaudoin is offline   Reply With Quote

Old   May 18, 2006, 04:13
Default Hi, Thanks for the advice! I
  #7
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
Hi,
Thanks for the advice!
I had the same problem and your suggested solution seems to work just fine. Just did rm * under OpenFoam1.3/applications/bin and then executed the Allwmake script in the applications directory. After this the applications seem to work (now I just have to find out why FoamX is complaining over a missing nameservice (ns.ref file missing...).

Regards
David
segersson is offline   Reply With Quote

Old   May 18, 2006, 07:35
Default Hi again, After a second chec
  #8
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
Hi again,
After a second check it does not seem to be totally correct after all. The foamFlex seems to need recompiling in my case as well. Doing a wclean and then wmake in itīs directory does not however produce a binary (even though it doesnīt return any error messages...). Rolf, I would appreciate if you could more exactly tell me what you did when it comes to manual recompilation of foamFlex (and maybe other parts...)?

Regards
David
segersson is offline   Reply With Quote

Old   May 18, 2006, 09:24
Default Maybe something related to you
  #9
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 330
Rep Power: 13
mbeaudoin will become famous soon enough
Maybe something related to your local version of bison, which is needed to generate a valid version of the files parse.c and skel.c. for your local system.

Try this:

cd $WM_PROJECT_DIR/applications/utilities/miscellaneous/foamFlex

make clean
wclean
make
wmake


Martin
mbeaudoin is offline   Reply With Quote

Old   May 18, 2006, 10:06
Default It seems like the only problem
  #10
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
It seems like the only problem was that the foamFlex++ binary was not written to applications/bin but to a file OpenFoam.out in the foamFlex directory. All I had to do was to change the name to foamFlex++ and move it to applications/bin, then everything worked (at least I can compile fluentMeshToFoam which did not work before).

Thanks anyway for the advice
David
segersson is offline   Reply With Quote

Old   May 18, 2006, 10:21
Default Found the problem: a typo
  #11
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 330
Rep Power: 13
mbeaudoin will become famous soon enough
Found the problem:

a typo in the file $WM_PROJECT_DIR/applications/utilities/miscellaneous/foamFlex/Make/files:

The last line of the file should be

EXE = $(FOAM_APPBIN)/foamFlex++

Martin
mbeaudoin is offline   Reply With Quote

Old   May 18, 2006, 10:31
Default Same typo in: $WM_PROJECT_D
  #12
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 330
Rep Power: 13
mbeaudoin will become famous soon enough
Same typo in:

$WM_PROJECT_DIR/applications/test/Field/Make/files
$WM_PROJECT_DIR/applications/test/alloc/Make/files
$WM_PROJECT_DIR/applications/test/maxMem/Make/files
$WM_PROJECT_DIR/applications/utilities/miscellaneous/foamFlex/Make/files

Martin
mbeaudoin is offline   Reply With Quote

Old   May 18, 2006, 11:00
Default These are not OpenFOAM apps, t
  #13
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
These are not OpenFOAM apps, these are standalone apps so do not need to link in libOpenFOAM etc.

See $WM_DIR/Makefile for how it hangs together.
mattijs is offline   Reply With Quote

Old   August 24, 2006, 12:02
Default Hi all, I am installing Ope
  #14
New Member
 
Santiago Laín
Join Date: Mar 2009
Location: Cali , Valle, Colombia
Posts: 1
Rep Power: 0
slain is on a distinguished road
Hi all,

I am installing OpenFOAM v 1.3 on a RedHat 8 with binaries. Although the installation seemed to be fine when I try the first example in the tutorial

blockMesh . cavity

I got the message that

can not handle libstdc++.so.6 with TLS data.

Has anybody any idea what does it mean? and how to solve the problem?

Thanks a lot!!!

P.S. the same message appears when I try to run another application as dnsFoam for instance.
slain is offline   Reply With Quote

Old   August 24, 2006, 12:43
Default Search for 'TLS' on this forum
  #15
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Search for 'TLS' on this forum.
mattijs is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMD 64 bit installation maka OpenFOAM Installation 7 January 11, 2009 11:42
Regarding installation vidyaprakash CD-adapco 0 December 22, 2006 00:03
installation mohammad FLUENT 0 May 4, 2003 10:15
NT 4.0 installation peter.liang CD-adapco 2 July 4, 2001 12:52
HP-UX installation new here FLUENT 1 October 26, 2000 21:54


All times are GMT -4. The time now is 22:08.