CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Sshd amp libelfso0 on gentoo box (http://www.cfd-online.com/Forums/openfoam-installation/57639-sshd-amp-libelfso0-gentoo-box.html)

alfreed June 15, 2006 08:38

Hi, I'm in the process of i
 
Hi,

I'm in the process of installing OpenFoam 1.3 on my Gentoo box.
I installed the following files:
* *OpenFoam-1.3.General.gtgz
* *OpenFoam-1.3.linuxGcc4DPOpt.gtgz
and under the subdirectory 'linux', the unzipped the three third-party packages.

I then updated my .bashrc file, as specified in the README, and
compiled the OpenFOAM source code via Allwmake.

No errors up to this point.

When I run foamInstallationTest I get one fatal error that I do not
understand:

Checking networking...
-------------------------------------------------------------------------------
Action * * * * * * * * * Result * * * * * * * * * * * * * * * * * * * Crit
-------------------------------------------------------------------------------
Pinging_celeborn * * * * Successful * * * * * * * * * * * * * * * * * yes
Pinging_localHost * * * *Successful * * * * * * * * * * * * * * * * * yes
Test_rsh: * * * * * * * *No_telnet_running:_cannot_check* * * * * * * yes
Test_ssh: * * * * * * * *No_telnet_running:_cannot_check* * * * * * * yes
FATAL ERROR: No remote shell available.
* * * * * * *Foam1.3 enviroment requires either ssh and/or rsh.
* * * * * * *Contact your system administrator.

I don't understand this because my sshd is running! *My Gentoo box
is a stand-alone machine - I have no ssh server to connect to.

Ignoring this for the moment, I thought about running the tutorials
and ran into another error:

al@celeborn ~/OpenFOAM/OpenFOAM-1.3/bin $ FoamX
Starting NameServer with inet:celeborn:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared
object file: No such file or directory

My linux kernel is built to handle elf, but when I run whereis libelf.so.0
this file is not found on my system. *

Any pointers are most welcomed.

Thanks,

Al

alexice June 15, 2006 09:40

to get the foamInstallationTes
 
to get the foamInstallationTest to be okay you have to emerge a telnet client, do:

emerge -av netkit-telnetd

and to get rid of the libelf.so.O stuff you should do

emerge -av libelf

to get a libelf on your gentoo.

Hope that helps, worked for my gentoo box,

Alex

alfreed June 15, 2006 10:05

Alex, Thanks, that fixed bo
 
Alex,

Thanks, that fixed both issues.

Al


All times are GMT -4. The time now is 06:08.