CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Sshd amp libelfso0 on gentoo box

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 15, 2006, 08:38
Default Hi, I'm in the process of i
  #1
New Member
 
Alan Freed
Join Date: Mar 2009
Location: Cleveland, Ohio, USA
Posts: 2
Rep Power: 0
alfreed is on a distinguished road
Hi,

I'm in the process of installing OpenFoam 1.3 on my Gentoo box.
I installed the following files:
* *OpenFoam-1.3.General.gtgz
* *OpenFoam-1.3.linuxGcc4DPOpt.gtgz
and under the subdirectory 'linux', the unzipped the three third-party packages.

I then updated my .bashrc file, as specified in the README, and
compiled the OpenFOAM source code via Allwmake.

No errors up to this point.

When I run foamInstallationTest I get one fatal error that I do not
understand:

Checking networking...
-------------------------------------------------------------------------------
Action * * * * * * * * * Result * * * * * * * * * * * * * * * * * * * Crit
-------------------------------------------------------------------------------
Pinging_celeborn * * * * Successful * * * * * * * * * * * * * * * * * yes
Pinging_localHost * * * *Successful * * * * * * * * * * * * * * * * * yes
Test_rsh: * * * * * * * *No_telnet_running:_cannot_check* * * * * * * yes
Test_ssh: * * * * * * * *No_telnet_running:_cannot_check* * * * * * * yes
FATAL ERROR: No remote shell available.
* * * * * * *Foam1.3 enviroment requires either ssh and/or rsh.
* * * * * * *Contact your system administrator.

I don't understand this because my sshd is running! *My Gentoo box
is a stand-alone machine - I have no ssh server to connect to.

Ignoring this for the moment, I thought about running the tutorials
and ran into another error:

al@celeborn ~/OpenFOAM/OpenFOAM-1.3/bin $ FoamX
Starting NameServer with inet:celeborn:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared
object file: No such file or directory

My linux kernel is built to handle elf, but when I run whereis libelf.so.0
this file is not found on my system. *

Any pointers are most welcomed.

Thanks,

Al
alfreed is offline   Reply With Quote

Old   June 15, 2006, 09:40
Default to get the foamInstallationTes
  #2
New Member
 
Alexander Jarosch
Join Date: Mar 2009
Location: Iceland
Posts: 6
Rep Power: 8
alexice is on a distinguished road
to get the foamInstallationTest to be okay you have to emerge a telnet client, do:

emerge -av netkit-telnetd

and to get rid of the libelf.so.O stuff you should do

emerge -av libelf

to get a libelf on your gentoo.

Hope that helps, worked for my gentoo box,

Alex
alexice is offline   Reply With Quote

Old   June 15, 2006, 10:05
Default Alex, Thanks, that fixed bo
  #3
New Member
 
Alan Freed
Join Date: Mar 2009
Location: Cleveland, Ohio, USA
Posts: 2
Rep Power: 0
alfreed is on a distinguished road
Alex,

Thanks, that fixed both issues.

Al
alfreed is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo ebuild for OpenFOAM141 deepblue17 OpenFOAM Installation 3 July 29, 2010 09:27
FoamX libelfso0 nunoinlux OpenFOAM Bugs 6 September 11, 2007 20:13
Canbt fix libelfso0 proble clo OpenFOAM Installation 3 January 10, 2007 05:17
FoamX libelfso0 mockealm OpenFOAM Installation 6 June 29, 2006 15:37
Building on Sparc64 running gentoo parra OpenFOAM Installation 0 May 5, 2006 15:17


All times are GMT -4. The time now is 19:37.