CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM on OSF1 V51 tru64 (http://www.cfd-online.com/Forums/openfoam-installation/57652-openfoam-osf1-v51-tru64.html)

andras April 26, 2006 06:45

Hi all! I have been trying to
 
Hi all!
I have been trying to compile OpenFOAM-1.2 on OSF1 V5.1 (tru64). This is the error i run into and i get stuck there:


$ src
$ ./Allwmake

--
[...]
make: *** No rule to make target `fields/fvPatchFields/derivedFvPatchFields/symmetry/symmetryFvPatchFields.dep', needed by `Make/tru64GccOpt/dependencies'. Stop.
libso
Make/tru64GccOpt/includeDeps:293: fields/fvPatchFields/derivedFvPatchFields/symmetry/symmetryFvPatchFields.dep: No such file or directory
Make/tru64GccOpt/includeDeps:294: fields/fvPatchFields/derivedFvPatchFields/cyclic/cyclicFvPatchFields.dep: No such file or directory
Make/tru64GccOpt/includeDeps:295: fields/fvPatchFields/derivedFvPatchFields/wedge/wedgeFvPatchFields.dep: No such file or directory
[...]
--
and so on...


my environment:

$ uname -mvrs
OSF1 V5.1 1885 alpha

$ which gcc c++ flex bison make ld gmake
$HOME/OpenFOAM/tru64/gcc-4.0.1/bin/gcc
$HOME/OpenFOAM/tru64/gcc-4.0.1/bin/c++
$HOME/bin/flex
/usr/local/bin/bison
$HOME/bin/make
/usr/bin/ld
$HOME/bin/gmake


and the versions:

$ gcc -v
Using built-in specs.
Target: alphaev6-dec-osf5.1a
Configured with: gcc-4.0.1/configure --prefix=$HOME : (reconfigured) gcc-4.0.1/configure --prefix=$HOME/OpenFOAM/tru64/gcc-4.0.1/ : (reconfigured) gcc-4.0.1/configure --prefix=$HOME/OpenFOAM/tru64/gcc-4.0.1/ --exec-prefix=$HOME/OpenFOAM/tru64/gcc-4.0.1/ --enable-languages=c,c++ --enable-shared --disable-multilib
Thread model: posix
gcc version 4.0.1

$ make --version
GNU Make 3.80

$ bison -V
bison (GNU Bison) 2.1



I have used the rules-files posted by Francois Beaubert on Wednesday, September 14, 2005 and put them in $HOME/OpenFOAM/OpenFOAM-1.2/wmake/rules/tru64Gcc

I added -fpermissive to the c++FLAGS and in "general" i set LD = ld -oldstyle_liblookup .


The shell i use is bash.

Any help is appreciated.


andras.


All times are GMT -4. The time now is 22:02.