CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   GLIBC libcso6 (http://www.cfd-online.com/Forums/openfoam-installation/57661-glibc-libcso6.html)

fred April 12, 2006 09:46

Dear Users, I have installe
 
Dear Users,

I have installed OpenFOAM 1.3 binaries, have sourced the cshrc file, and before I have installed gcc v4, in the linux directory ...
The env parameters seem to be ok, and the test is ok too.
Running the first test (blockMesh . cavity), I got the error message :

__________________________________________________
blockMesh: /lib/tls/libc.so.6: version `GLIBC_2.3.4' not found (required by blockMesh)
__________________________________________________

How to overcome on this message and to run and lear OpenFOAM ?

Best regards,

Frédéric

liu April 12, 2006 10:51

Recompile from source instead
 
Recompile from source instead of using binary.

gschaider April 12, 2006 11:11

I have seen a similar error me
 
I have seen a similar error message when I tried to run the binary distribution on a Fedora Core 1 (you didn't say what distribution your machine was)

If you try recompiling it on a Fedora Machine you might run into the demangle.h problem described in the "SUSE 9.1 Porting"-thread.

What I did was: remove the executable-binaries (not the .o-s and not the .so-s) and perform a wmake in the applications directory. That should only relink the applications (and then everything should be fine)


All times are GMT -4. The time now is 20:23.