CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Ssh problem for LAMMPI

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 11, 2006, 13:13
Default Hi, I have run the damBreakFi
  #1
New Member
 
auvi
Join Date: Mar 2009
Posts: 5
Rep Power: 7
parallelauvi is on a distinguished road
Hi,
I have run the damBreakFine case of the supplied tutorials but when i try to run it parallelly i get ERRORs ..
i have setup the other machine(for a 2 pc LAN) for ssh (using ssh-keygen and stuff) which requires no passwords when i login using the ssh client. i can run regular programs like "ls" like this:
"ssh foam19 ls" normally
and can't run like this:
"ssh foam19 tkill"

but when i login using ssh to foam19 i can invoke "tkill" and related LAM-MPI commands. the path for LAM-MPI is in the .bashrc file.

foam19 is the other machine.

Any help?

please.

Auvi
parallelauvi is offline   Reply With Quote

Old   April 11, 2006, 13:46
Default Not familiar with .bashrc but
  #2
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 15
mattijs is on a distinguished road
Not familiar with .bashrc but maybe just 'ssh' executes different different start-up files ( ~/.bash.login etc.)

ssh starts up 'login shell' according to the man page.

If you're really stuck add a 'set -x' to your dot files and work through the mass of output.
mattijs is offline   Reply With Quote

Old   April 12, 2006, 01:14
Default okay i solved the problem by e
  #3
New Member
 
auvi
Join Date: Mar 2009
Posts: 5
Rep Power: 7
parallelauvi is on a distinguished road
okay i solved the problem by editing the global
/etc/bash.bashrc file adding the
. ($HOME ... ) line to the top
now the "ssh foam19 tkill" works
and lamboot -v <machines> runs without any errors

thanks Mattijis Jenssens

Auvi
parallelauvi is offline   Reply With Quote

Old   April 12, 2006, 01:28
Default sorry for the typo Thanks Ma
  #4
New Member
 
auvi
Join Date: Mar 2009
Posts: 5
Rep Power: 7
parallelauvi is on a distinguished road
sorry for the typo
Thanks Mattijs Janssens
i was in a hurry.

auvi
parallelauvi is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in Modelling Heat Transfer Problem Deepak R FLUENT 1 December 6, 2007 09:37
Problem in Tutorial problem of fluent Phanindra FLUENT 5 April 17, 2007 09:57
problem in solving "wave generation" problem san FLUENT 2 April 3, 2006 23:37
LAMMPI troubles mer OpenFOAM Installation 4 September 13, 2005 05:41
Lammpi library hsing OpenFOAM Installation 1 September 1, 2005 22:53


All times are GMT -4. The time now is 02:23.