CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

FOAM installation error gcc amp g

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 24, 2006, 11:53
Default Hi everybody, I am new user.
  #1
New Member
 
A. Hanks
Join Date: Mar 2009
Posts: 5
Rep Power: 8
hanks is on a distinguished road
Hi everybody,
I am new user. sorry for this long messager, but when i tried to install foam i got the mesaage below. i know the problem with C compiler but i dont know what to do. should i install new compiler or what?
..

SOURCE=adler32.c ; gcc -m32 -Dlinux -Wall -O3 -I/home/user/OpenFOAM/OpenFOAM
-1.2/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -c $SOURCE -o Make/linuxGcc
4Opt/adler32.o
/bin/sh: gcc: command not found
make: *** [Make/linuxGcc4Opt/adler32.o] Error 127
make: Nothing to be done for `allFiles'.
make: `lnInclude/uptodate' is up to date.
make: `Make/linuxGcc4Opt/dependencies' is up to date.
libso
SOURCE_DIR=.
SOURCE=libfoamUser.C ; g++ -m32 -Dlinux -Wall -W -Wno-unused-parameter -Wold-st
yle-cast -O3 -ffast-math -DNoRepository -ftemplate-depth-30 -I/home/user/Open
FOAM/OpenFOAM-1.2/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -pthread -c $S
OURCE -o Make/linuxGcc4Opt/libfoamUser.o
/bin/sh: g++: command not found
make: *** [Make/linuxGcc4Opt/libfoamUser.o] Error 127
gmake: *** No rule to make target `distclean'. Stop.

================================================== ==========================
== Configuring LAM version 7.1.1
================================================== ==========================

*** Initialization, setup
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
configure: builddir: /home/user/OpenFOAM/OpenFOAM-1.2/src/lam-7.1.1
configure: srcdir: /home/user/OpenFOAM/OpenFOAM-1.2/src/lam-7.1.1
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
installing to directory "/home/user/OpenFOAM/OpenFOAM-1.2/src/lam-7.1.1/platfor
ms/linuxGcc4Opt"

*** C compiler and preprocessor
checking if want debugging output support... no
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
gmake: *** No targets specified and no makefile found. Stop.
gmake: *** No rule to make target `install'. Stop.
gmake: *** No rule to make target `distclean'. Stop.
make: Nothing to be done for `allFiles'.
make: `Make/linuxGcc4Opt/dependencies' is up to date.
exe
SOURCE_DIR=.
SOURCE=foamSkel.c ; gcc -m32 -Dlinux -Wall -O3 -I/home/user/OpenFOAM/OpenFOA
M-1.2/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -c $SOURCE -o Make/linuxGc
c4Opt/foamSkel.o
/bin/sh: gcc: command not found
make: *** [Make/linuxGcc4Opt/foamSkel.o] Error 127
make: Nothing to be done for `allFiles'.
make: `lnInclude/uptodate' is up to date.
make: `Make/linuxGcc4Opt/dependencies' is up to date.
libso
SOURCE_DIR=.
SOURCE=Pstream.C ; g++ -m32 -Dlinux -Wall -W -Wno-unused-parameter -Wold-style- cast -O3 -ffast-math -DNoRepository -ftemplate-depth-30 -I/home/akram/OpenFOAM /OpenFOAM-1.2/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -pthread -c $SOURC E -o Make/linuxGcc4Opt/Pstream.o
/bin/sh: g++: command not found
make: *** [Make/linuxGcc4Opt/Pstream.o] Error 127
make: Nothing to be done for `allFiles'.
make: `lnInclude/uptodate' is up to date.
make: `Make/linuxGcc4Opt/dependencies' is up to date.
libso
SOURCE_DIR=.
SOURCE=OPwrite.C ; g++ -m32 -Dlinux -Wall -W -Wno-unused-parameter -Wold-style- cast -O3 -ffast-math -DNoRepository -ftemplate-depth-30 -I/home/user/OpenFOAM /OpenFOAM-1.2/src/lam-7.1.1/platforms/linuxGcc4Opt/include -I/home/user/OpenFOA M/OpenFOAM-1.2/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -pthread -c $SOUR CE -o Make/linuxGcc4Opt/OPwrite.o
/bin/sh: g++: command not found
make: *** [Make/linuxGcc4Opt/OPwrite.o] Error 127
make: Nothing to be done for `allFiles'.
make: `lnInclude/uptodate' is up to date.
make: `Make/linuxGcc4Opt/dependencies' is up to date.
libso
hanks is offline   Reply With Quote

Old   January 24, 2006, 12:14
Default by the way my OS is Linux Suse
  #2
New Member
 
A. Hanks
Join Date: Mar 2009
Posts: 5
Rep Power: 8
hanks is on a distinguished road
by the way my OS is Linux Suse 10 and the processor is AMD Athlon (tm) XP 1500+
hanks is offline   Reply With Quote

Old   January 24, 2006, 12:35
Default I guess you should install gcc
  #3
Senior Member
 
Francesco Del Citto
Join Date: Mar 2009
Location: Zürich Area, Switzerland
Posts: 215
Rep Power: 9
fra76 is on a distinguished road
I guess you should install gcc 4.0.1 (or 4.0.2). It's requiered while compiling from source.
You can find all the stuff you need here http://www.opencfd.co.uk/openfoam/linuxAMD64.html
The question is, why compiling from source, when you already have the binary pack?
Francesco
fra76 is offline   Reply With Quote

Old   January 24, 2006, 12:49
Default Hi thanks, I am new user of
  #4
New Member
 
A. Hanks
Join Date: Mar 2009
Posts: 5
Rep Power: 8
hanks is on a distinguished road
Hi thanks,
I am new user of linux too. i downlaoded all from http://www.opencfd.co.uk/openfoam/linuxAMD64.html.
and when i tried to install i got the error.
for the binary pack i dont know how to install openfoam using binary pack. need some help
hanks is offline   Reply With Quote

Old   January 24, 2006, 15:43
Default Download all those files and p
  #5
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
Download all those files and put them in exactly that directory structure (http://www.opencfd.co.uk/openfoam/linuxAMD64.html)

Unpack all so
tar xzf OpenFOAM-1.2.General.gtgz
tar xzf OpenFOAM-1.2.linuxAMD64Gcc4Opt.gtgz
..

You should end up with a directory structure like:

OpenFOAM/
OpenFOAM-1.2/
linuxAMD64/
gcc-4.0.1/
paraview-2.2.0/
j2sdk1.4.2_05/

then source the startup file:

. ~/OpenFOAM/OpenFOAM-1.3/.bashrc
mattijs is offline   Reply With Quote

Old   January 26, 2006, 10:56
Default Dear Mattija, i did that. i h
  #6
New Member
 
A. Hanks
Join Date: Mar 2009
Posts: 5
Rep Power: 8
hanks is on a distinguished road
Dear Mattija,
i did that. i have 2 folders inside OpenFOAM folder OpenFOAM-1.2 & linuxAMD64. i did all as in the website, but it seems during tht installation OpenFOAM reads the gcc complier and java from /usr/local/bin/gcc instead of /home/user/OpenFOAM/linux/gcc-4.0.1/bin/gcc
read the installation message down please.
also i wonder why the installation test reads linux and not linuxAMD64. if you ask me, which version i downloaded i will say it is from here http://www.opencfd.co.uk/openfoam/li...tml#linuxAMD64
---------------------------------------------
gcc 4.0.2
WARNING: Conflicting installations:
foam settings: /home/user/OpenFOAM/linux/gcc-4.0.1/bin/gcc
current path : /usr/local/bin/gcc
CRITICAL ERROR

java 1.4.2_06
WARNING: Conflicting installations:
foam settings: /home/user/OpenFOAM/linux/j2sdk1.4.2_05/bin/java
current path : /usr/bin/java

gzip 1.3.5 /usr/bin/gzip
tar 1.3.5 /bin/tar
----------------------------------------------
hope you or somebody else can find me the soluation.
reagrds
hanks is offline   Reply With Quote

Old   January 26, 2006, 11:00
Default If you check your PATH environ
  #7
Super Moderator
 
niklas's Avatar
 
Niklas Nordin
Join Date: Mar 2009
Location: Stockholm, Sweden
Posts: 693
Rep Power: 19
niklas will become famous soon enough
If you check your PATH environment variable you will probably be able to deduce yourself what is going on.

N
niklas is offline   Reply With Quote

Old   January 26, 2006, 11:12
Default Dear Niklas, i am not that ex
  #8
New Member
 
A. Hanks
Join Date: Mar 2009
Posts: 5
Rep Power: 8
hanks is on a distinguished road
Dear Niklas,
i am not that experter in linux, can you please tell me where to check and modify if possible my PATH environment.
regards
hanks is offline   Reply With Quote

Old   January 26, 2006, 11:18
Default Then I would say that the prob
  #9
Super Moderator
 
niklas's Avatar
 
Niklas Nordin
Join Date: Mar 2009
Location: Stockholm, Sweden
Posts: 693
Rep Power: 19
niklas will become famous soon enough
Then I would say that the problem is your Linux skills.
if you write
echo $PATH
you will see in which directories your setup is looking
for your executables.
Do you find the OpenFOAM directories there and are they after/before the /usr/bin path.
Only YOU can setup your system and if you dont speak *nix it will be very difficult help you.

N
niklas is offline   Reply With Quote

Old   January 26, 2006, 15:14
Default add export WM_64=1 to y
  #10
Super Moderator
 
Mattijs Janssens
Join Date: Mar 2009
Posts: 1,416
Rep Power: 16
mattijs is on a distinguished road
add

export WM_64=1

to your .bashrc. This will force it to pick up your 64 bit installation.

Or install the 32 bit version.
mattijs is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
FOAM installation compiler issues gareth__it_power OpenFOAM Installation 7 February 9, 2009 15:12
FOAM FATAL IO ERROR msrinath80 OpenFOAM Running, Solving & CFD 4 July 30, 2008 10:06
FOAM FATAL ERROR derath OpenFOAM Pre-Processing 1 June 10, 2006 14:20
Installation of Open foam 12 ds2taieb OpenFOAM Installation 1 January 16, 2006 00:46
FOAM FATAL IO ERROR sita OpenFOAM Running, Solving & CFD 2 August 23, 2005 04:37


All times are GMT -4. The time now is 01:53.