CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Installation test fails (http://www.cfd-online.com/Forums/openfoam-installation/57700-installation-test-fails.html)

henkw December 1, 2005 08:32

Hello, Having installed ver
 
Hello,

Having installed version 1.2 of OpenFoam I get the following error when running foamInstallationTest:


FATAL ERROR: /home/OpenFOAM/.OpenFOAM-1.1/cshrc does not appear to be sourced from:
/home/OpenFOAM/.cshrc

I made the changes to the bashrc file, and also tried csh.

Especially the .OpenFOAM-1.1 seems strange to me.

How can I solve this?

Thanks,

Henk Witte

azt December 1, 2005 08:39

Henk I had the same problem
 
Henk

I had the same problem, apparently it's a bug. The tutorials run and it appears to work ok. Have a look in the bugs section of the discussion.

allan

henkw December 2, 2005 10:40

Ok, I will ignore this message
 
Ok, I will ignore this message. However, I do have some other problems related to the installation (but I hoped they were due to a problem with the path specification):

gcc 3.4.2
WARNING: Conflicting installations:
foam settings: /home/OpenFOAM/OpenFOAM//gcc-4.0.1/bin/gcc
current path : /usr/local/bin/gcc
CRITICAL ERROR
java *** not installed ***

gzip 1.3.3 /bin/gzip
tar 1.3.3 /bin/tar
icoFoam *** not installed ***
CRITICAL ERROR

Help would be appreciated!

Henk

mattijs December 2, 2005 11:25

You want to make sure you pick
 
You want to make sure you pick up the OpenFOAM//gcc-4.0.1/bin/gcc instead of the system one. Did you download and install it from the download site? Also you need to install the java from the download site.

If it still does not work add a 'set -x' at the beginning of .../OpenFOAM-1.2/.bashrc and see what is happening.

henkw December 2, 2005 12:01

Well, I get a lot more output
 
Well, I get a lot more output in general but not during the installation test. I did install the gcc-4.0.1 and java from the installation site into the linux subdirectory. The installation is:

/home/OpenFOAM/OpenFOAM/OpenFOAM-1.2/
/home/OpenFOAM/OpenFOAM/linux/gcc-4.0.1
/home/OpenFOAM/OpenFOAM/linux/j2sdk1.4.2_05
/home/OpenFOAM/OpenFOAM/linux/paraview-2.2.0

this is the output of the test:

Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/OpenFOAM/OpenFOAM/OpenFOAM-1.2 yes yes yes

$FOAM_USER_APPBIN ...penFOAM-1.2/applications/bin/Gcc4Opt yes yes no
$FOAM_APPBIN ...penFOAM-1.2/applications/bin/Gcc4Opt yes yes yes
$WM_DIR ...OpenFOAM/OpenFOAM/OpenFOAM-1.2/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH /home/OpenFOAM/OpenFOAM//j2sdk1.4.2_05 no no
$MICO_ARCH_PATH ....2/src/mico-2.3.11/platforms/Gcc4Opt no yes
$LAM_ARCH_PATH ...-1.2/src/lam-7.1.1/platforms/Gcc4Opt yes yes yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...AM/OpenFOAM/OpenFOAM-1.2/lib/Gcc4Opt yes yes yes
$FOAM_USER_LIBBIN ...AM/OpenFOAM/OpenFOAM-1.2/lib/Gcc4Opt yes yes no
$LAM_ARCH_PATH ...-1.2/src/lam-7.1.1/platforms/Gcc4Opt yes yes yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 3.4.2
WARNING: Conflicting installations:
foam settings: /home/OpenFOAM/OpenFOAM//gcc-4.0.1/bin/gcc
current path : /usr/local/bin/gcc
CRITICAL ERROR

java *** not installed ***

gzip 1.3.3 /bin/gzip
tar 1.3.3 /bin/tar
icoFoam *** not installed ***
CRITICAL ERROR

Henk


All times are GMT -4. The time now is 11:13.