CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Installation on a cluster running a queueing system PBS (http://www.cfd-online.com/Forums/openfoam-installation/57739-installation-cluster-running-queueing-system-pbs.html)

sampaio June 9, 2005 18:51

When I log on the system, the
 
When I log on the system, the environment variables are all correct.

When I issue a which blockMesh, for instance, it returns the correct directory.

But when I submit through the queueing system, I got "command not found" msgs, and when I include "which blockMesh" in the script to be submitted, it returns nothing (no command).

As I am not experienced in clusters (this one is a beowulf) with queues, I am wondering if this is some common and easy problem and if anyone can help me...

Note: I am not allowed to log onto the nodes and run an application from there...

Thanks a lot,
luiz

niklas June 10, 2005 03:07

why not source your .cshrc the
 
why not source your .cshrc the first thing you do inthe script

sampaio June 10, 2005 14:50

I did it. Now, the variables
 
I did it.
Now, the variables are correctly set, but the output still contains errors.

Here is my script:
################################################## #######
echo Running on host `hostname`
echo Time is `date`
echo Directory is `pwd`
echo This job runs on the following processors:
source /home/server/luizebs/OpenFOAM/OpenFOAM-1.1/.OpenFOAM-1.1/cshrc
echo `which blockMesh`
echo `which mpiexec`
blockMesh . GL3 > logblock &
################################################## #######

The logblock file is completely empty...

in my script.eXXXXX log file I got:

################################################## #######
[luizebs@redhot oodles]$ cat script.e45957
$: Command not found.
$: Command not found.
$: Command not found.
$: Command not found.
[luizebs@redhot oodles]$
################################################## #######


while in the script.oXXXXX log I got (should I worry about this warning message?):

################################################## #######
[luizebs@redhot oodles]$ cat script.o45959
Warning: no access to tty (Bad file descriptor).
Thus no job control in this shell.
Running on host n46
Time is Fri Jun 10 10:39:17 PDT 2005
Directory is /home/server/luizebs
This job runs on the following processors:
/home/server/luizebs/OpenFOAM/OpenFOAM-1.1/applications/bin/linuxOpt/blockMesh
/home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/lam-7.1.1/platforms/linuxOpt/bin/ mpiexec
[1] 25710
--------------------------------------
Running PBS epilogue script

Killing processes of user luizebs on the batch nodes
Doing node n46
Done.
[luizebs@redhot oodles]$
################################################## #######

niklas June 11, 2005 11:11

ok, so you are standing in $HO
 
ok, so you are standing in $HOME according to pwd.

is your GL3 directory located in $HOME?

also i would add #!/bin/tcsh (or csh or bash...)
on the first line of the script (might help)

N

sampaio June 13, 2005 21:32

Sorry that was an old log. Eve
 
Sorry that was an old log. Even when I was (correctly) on the .../tutorials/oodles dir, the message was the same. (And I did have #!/bin/bashrc in my script).

I tried to execute blockMesh from the node (avoiding qsub) and it issued these msgs:


[luizebs@n1 oodles]$ blockMesh . GL3
blockMesh: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /home/server/luizebs/OpenFOAM/linux/gcc-3.4.3/lib/libstdc++.so.6)
blockMesh: /lib/i686/libc.so.6: version `GLIBC_2.3.2' not found (required by /home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/lam-7.1.1/platforms/linuxOpt/lib/ libmpi.so.0)
blockMesh: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/lam-7.1.1/platforms/linuxOpt/lib/ liblam.so.0)
blockMesh: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/lam-7.1.1/platforms/linuxOpt/lib/ liblam.so.0)
[luizebs@n1 oodles]$ which gcc
~/OpenFOAM/linux/gcc-3.4.3/bin/gcc
[luizebs@n1 oodles]$


Do you have any clue? Apparently gcc is pointing to the correct location.

Thanks,
Luiz

niklas June 14, 2005 04:56

your linux version on the clus
 
your linux version on the cluster is too old, which version is it?

You need to recompile all of the source on the cluster. Submit the Allwmake script.

N

sampaio June 14, 2005 12:48

2.4.20-30.7 When I recompil
 
2.4.20-30.7

When I recompile (with ./Allwmake from $HOME/OpenFOAM/OpenFOAM-1.1 dir) it still complains about GLIBC_2.3

Here is the output:

SOURCE_DIR=.
SOURCE=foamDebugSwitches.C ; g++ -m32 -Dlinux -Wall -W -Wno-unused-parameter -O3 -ffast-math -DNoRepository -ftemplate-depth-30 -I/home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -pthread -c $SOURCE -o Make/linuxOpt/foamDebugSwitches.o
g++: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by g++)
make: *** [Make/linuxOpt/foamDebugSwitches.o] Error 1
+ wmake foamInfoExec
Making dependency list for source file foamInfoExec.C

SOURCE_DIR=.
SOURCE=foamInfoExec.C ; g++ -m32 -Dlinux -Wall -W -Wno-unused-parameter -O3 -ffast-math -DNoRepository -ftemplate-depth-30 -I/home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/OpenFOAM/lnInclude -IlnInclude -I. -fPIC -pthread -c $SOURCE -o Make/linuxOpt/foamInfoExec.o
g++: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by g++)
make: *** [Make/linuxOpt/foamInfoExec.o] Error 1
[luizebs@n22 OpenFOAM-1.1]$

Thanks again,
luiz

mattijs June 14, 2005 14:40

Sounds like you first need to
 
Sounds like you first need to compile gcc for your os version.

Information on how to do that should be somewhere on the site.
(we do:
./configure --prefix=/usr/tmp/gcc-3.4.3 --enable-languages=c,c++ --enable-shared --enable-__cxa_atexit --disable-checking --with-system-zlib)

niklas June 15, 2005 03:58

Yes and you will need to recom
 
Yes and you will need to recompile everything else too.

But now your in a tight spot, how will you do the post-processing?

I think you need to have two binary-versions on for the old cluster and one for the new workstation.

N

sampaio June 17, 2005 01:11

I tried to compile gcc and Foa
 
I tried to compile gcc and Foam (with Allwmake), but it still complains about GLIBC-2.3.2.

Apparently gcc was installed with no problem, but ./Allwmake outputs a lot of messages like this:

/home/server/luizebs/OpenFOAM/OpenFOAM-1.1/src/lam-7.1.1/platforms/linuxOpt/lib/ liblam.so.0: undefined reference to `pthread_cond_signal@GLIBC_2.3.2'

Should I install this library separetely? (I thought it should come with gcc-3.4.3)

Where should it be?

What I have in /lib dir is:

$ ls /lib/libc*
/lib/libc-2.2.5.so /lib/libcap.so.1.10 /lib/libcrypt-2.2.5.so /lib/libcrypt.so.1
/lib/libcap.so /lib/libcom_err.so.2 /lib/libcrypto.so.0.9.6b /lib/libc.so.6
/lib/libcap.so.1 /lib/libcom_err.so.2.0 /lib/libcrypto.so.2
$

Thanks a lot again,
Luiz

sampaio June 17, 2005 19:12

Also, which version of GLIBC i
 
Also, which version of GLIBC is required by Foam?
I googled about installing GLIBC and got a little scared... So, firstly I would like to be sure it is really the case, rather than anything else that i am missing...

Thanks,
luiz

niklas June 18, 2005 11:04

It looks to me like you have s
 
It looks to me like you have some old libraries hanging around.
Did you remove the OpenFoam installation and install just the sources or did you just try to recompile with the old binaries installed?

The glibc-version is not something foam specific, but machine specific.
What it means is that you have compiled your library on a certain system and then running it on an other system where these libraries are missing/different.

N

sampaio June 20, 2005 17:16

Hi Niklas, I did not remove t
 
Hi Niklas,
I did not remove the OpenFoam installation. I just ran ./Allwmake from top dir.

What exactly should I do?

(which directories should I leave and which ones should I remove before running ./Allwmake?)

If you can provide me more details, since I am not linux expert, I will be very very gratefull...

Thanks a lot again,
luiz


All times are GMT -4. The time now is 14:48.