CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   LibfoamUserso in multiuser configuration (http://www.cfd-online.com/Forums/openfoam-installation/57751-libfoamuserso-multiuser-configuration.html)

panara March 16, 2005 08:35

We are trying to install OpenF
 
We are trying to install OpenFOAM on our cluster in order to be used by all the users.

Everything works fine, the question now is what is the right way to handle the user libraries...

When a user creates is own boundary conditions ,for example, and recompile the foamUser library the file libfoamUser.so is modified.

A user should not have the right to access the lib directory..

Is there any other method to handle this except to give the writing file permission to all the users?

Daniele

henry March 16, 2005 08:46

Users libraries should be comp
 
Users libraries should be compiled into their own library directory. There are a set of FOAM_USER_??? variables within the build system to handle this. So the user should create a copy of the foamUser directory and change the Make/files file in their to create the libfoamUser.so in their own directory:

LIB = $(FOAM_USER_LIBBIN)/libfoamUser

and put a list of all the files they want to build and link into their library into that file as well, e.g.

interpolations = interpolations
surfaceInterpolation = $(interpolations)/surfaceInterpolation
schemes = $(surfaceInterpolation)/schemes

$(schemes)/limiterTest/limiterTestMake.C
turbulenceModels/incompressible/v2f/v2f.C

libfoamUser.C
LIB = $(FOAM_USER_LIBBIN)/libfoamUser

panara March 16, 2005 10:12

Thanks very much, now everithi
 
Thanks very much, now everithing is working fine!!

Just one extra little question, in order to make it work I had to add in my $PATH the $(FOAM_USER_LIBBIN) as well as $(FOAM_USER_APPBIN) path.

Was it the right thing to do? or I am making some other mistake

Daniele

henry March 16, 2005 10:16

That's a bit strange, as long
 
That's a bit strange, as long as you have $FOAM_USER_LIBBIN in your $LD_LIBRARY_PATH it should work fine. This should be done automatically by the OpenFOAM dot-files, could you check and let me know.

panara March 16, 2005 10:36

The reason was that after the
 
The reason was that after the creation of the $FOAM_USER_LIBBIN directory I didn't update the shell variables with the command

. /opt/OpenFOAM/OpenFOAM-1.0.2/.OpenFOAM-1.0.2/bashrc

Now everithing is clear, thanks very much!

henry March 16, 2005 10:55

The creation of those director
 
The creation of those directories, the setting of the corresponding environment variable and the update of $PATH and $LD_LIBRARY_PATH is fully automatic in OpenFOAM-1.1


All times are GMT -4. The time now is 01:04.