CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OF Installation Problem - Gcc Error (http://www.cfd-online.com/Forums/openfoam-installation/63452-installation-problem-gcc-error.html)

Daniel Pilatti April 8, 2009 15:42

OF Installation Problem - Gcc Error
 
Hello!

I am starting using Linux SO, so I have a problem during the installation of OpenFOAM 1.5.

Below are the errors:

Third party software

-------------------------------------------------------------------------------

Software Version Location

-------------------------------------------------------------------------------

WARNING: gcc version does not match gcc supplied with this release of OpenFOAM

Supplied version: 4.3.1

User version :

Minimum required: 4.2.0



gcc
WARNING: Conflicting installations:

OpenFOAM settings : /home/daniel/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc

current path :

CRITICAL ERROR


gzip 1.3.12 /usr/bin/gzip

tar 1.20 /bin/tar

icoFoam

WARNING: Conflicting installations:

OpenFOAM settings : /home/daniel/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/icoFoam

current path :

CRITICAL ERROR


-------------------------------------------------------------------------------



Checking networking...

-------------------------------------------------------------------------------

Action Result Crit

-------------------------------------------------------------------------------

Pinging_localhost Successful yes

Pinging_localHost Successful yes

Test_rsh: Unsuccessful_connection_refused* yes

Test_ssh: Unsuccessful_connection_refused* yes

FATAL ERROR: No remote shell available.

OpenFOAM 1.5 enviroment requires either ssh and/or rsh.

Contact your system administrator.



-------------------------------------------------------------------------------


The system test has evoked 1 fatal error(s).


The foam installation contains 2 critical error(s).



So, please, in this case what can I do?

Daniel Pilatti April 11, 2009 00:40

In Portuguese...

Preciso saber como se instala o Gcc 4.3.1.

Obrigado!

gwierink April 11, 2009 14:32

Hi Daniel,

The error message says you do not have any gcc c++ compiler:

Code:

WARNING: gcc version does not match gcc supplied with this release of OpenFOAM

        Supplied version: 4.3.1                                             

        User version    :                                                   

        Minimum required: 4.2.0

What linux distribution do you use? In Fedora you can install it with

Code:

yum install gcc gcc-c++
Or install gcc with the package manager, Synaptic in Ubuntu.

Regards,

Gijsbert

Daniel Pilatti April 12, 2009 09:17

Thanks the relply Gijsbert!

Unfortunatelly, I am using Mandriva One Linux Ditstribution so the line comands in the most part of the Forum doesn't work in my linux.

Is there a way to install Gcc compiler on Mandriva or I must install Ubuntu Linux?

Att.

Daniel

gwierink April 12, 2009 10:55

Hi Daniel,

You should be able to install gcc on any linux system, although there may be small differences between distributions. Mandriva has a package manager, where you can just type "gcc" and it will install it with dependencies. Via the command line the following command should work (but I must admit I am not very familiar with Mandriva :o):

Code:

urpmi gcc
or maybe like this:

Code:

urpmi gcc gcc-c++
Probably you have to do this in root. Hope this helps.

Regards, Gijsbert

Daniel Pilatti April 14, 2009 10:51

Thanks Gijsbert!

I will try to execute the code that you have wrote.

Case it doesn't work, i will install another distribution of linux!

Att.

Daniel

Daniel Pilatti April 16, 2009 16:04

Well,

The problem whith GCC compiler continuous in my pc. The "foamInstallationTest" don't recognize that the Linux (Ubuntu and Mandriva, in my case) has the GCC compiler activated.

Att.

Daniel

martinr April 16, 2009 16:25

Hi Daniel,
The foamInstallationTest says that OpenFoam is waiting for gcc executable file in the cited path " /home/daniel/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc", Can you see the gcc executable file in the cited path?

Martin

Daniel Pilatti April 17, 2009 00:02

that's it Martin!

Does not exist the directory /home/.../linux/bin/gcc, but exist /home/.../linux64/bin/gcc.
So, in /OpenFOAM/bashrc archive I found the information I have to change.
But I still have 1 Fatal error -> No remote shell available.
And 1 Critical Error -> gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR


Att.

Daniel

martinr April 17, 2009 09:25

Hi Daniel,
Is your machine 64 bits? I ask that because you say that .../linux64/.. folder exists.
Regarding gcc critical error, OF is waiting for gcc executable file in /bin/ folder and you have it at /usr/bin/, I think you should modify the path in /OpenFOAM/OpenFOAM-1.4.1/.bashrc .
The remote shell problem might be due to ssh program. Have you installed it?

Martin.

Daniel Pilatti April 17, 2009 10:50

Martin,

I'm going to proceed the changes that you have proposed.
And answering your question: Yes, my machine is 64bits.
And you are wright...yes, I have to reinstall the remote shell, using synaptic packages.
Thank You.

Att.

Daniel

Daniel Pilatti April 19, 2009 22:07

So,

If help for someone:
I solved the second critical error in my installation:
I have just added a single comand in line 77 of the OF bashrc file:
"export WM_COMPILER_DIR=/usr"
And I solved the remote shell problem, by reinstalling the ssh in the synaptics packages.

Now the foamInstallationTest shows me no error!

Thanks For All!

Att.
Daniel


All times are GMT -4. The time now is 06:23.