CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Installation OF1.5-dev

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 28, 2009, 05:18
Default
  #41
Member
 
Hy Yu
Join Date: Mar 2009
Location: Hessen, Germany
Posts: 34
Rep Power: 8
ttdtud is on a distinguished road
Quote:
Originally Posted by henrik View Post
Hongyi,

that's all fine, but you could avoid 4 if you swap 2 and 3.

Does paraview cooperate with your graphics? Start paraview on it's own and load some example or a STL-geometry.

Henrik
Dear Henrik,
yes, if i use "foamToVTK" and i can see the results using "paraview". I cannot understand why paraFoam does not work.

Hongyi
ttdtud is offline   Reply With Quote

Old   April 29, 2009, 03:34
Default
  #42
Member
 
Mandar
Join Date: Mar 2009
Posts: 39
Rep Power: 8
mixer is on a distinguished road
Hello Jaswinder, thanks a lot for pointing to the right installation files. I have been able to install the dev version and its working fine now. thanks. I will get back to my ggi mixer problem now.

Niel, Thanks to you too for your suggestion.

Reg, Mandar
mixer is offline   Reply With Quote

Old   April 29, 2009, 16:36
Default
  #43
New Member
 
tino boelke
Join Date: Mar 2009
Location: Rostock
Posts: 10
Rep Power: 8
tino_boelke is on a distinguished road
Dear Hongyi,

i have unfortunately the same problem, after compiling

  • ThirdParty
  • OpenFoam-1.5-dev from subversion (latest version)
  • Qt-4.3.5
  • ParaView-3.4.0
  • ParaFoam
without errors, i can run different cases but after pressing "Apply" in paraFoam nothing is displayed. Under "Information" it seems that the files are loaded (data arrays are available and number of cells are shown (cavity case from icoFoam: number of cells:400)). Using foamToVTK und starting paraview, the correct geometry is shown.

Runnung:
Ubuntu 9.04
Nvidia drivers 180 and 173 tried (both the same)
Qt-4.3.5
ParaView-3.4.0

On Ubuntu 8.10, the same configurations worked really fine... so where can be the problem?

Regards

Tino
tino_boelke is offline   Reply With Quote

Old   April 30, 2009, 03:17
Default
  #44
Senior Member
 
Henrik Rusche
Join Date: Mar 2009
Location: Braunschweig, Niedersachsen, Germany
Posts: 275
Rep Power: 9
henrik is on a distinguished road
Dear All,

there is not much I can do to help other than posting my setup.

System --------------

lenovo W500 laptop with Suse 11.1 and latest patches.

galerius*178-> uname -a
Linux galerius 2.6.27.21-0.1-default #1 SMP 2009-03-31 14:50:44 +0200 i686 i686 i386 GNU/Linux

compiler --------------

I am used the system compiler to compile OF.

Qt-libraries --------------

galerius*177-> rpm -qa | egrep libqt4
libqt4-sql-mysql-4.4.3-11.8.1
libqt4-x11-4.4.3-4.8.2
libqt4-sql-4.4.3-4.8.2
libqt4-sql-unixODBC-4.4.3-11.8.1
libqt4-sql-sqlite-4.4.3-4.8.2
libqt4-devel-doc-data-4.4.3-4.8.1
libqt4-qt3support-4.4.3-4.8.2
libqt4-devel-4.4.3-4.8.2
libqt4-devel-doc-4.4.3-4.8.1
libqt4-4.4.3-4.8.2
libqt4-sql-postgresql-4.4.3-11.8.1

Paraview --------------

I unpacked Paraview 3.4.0 into the ThirdParty directory and used the scripts I posted to compile it.
galerius*163-> foamInstallationTest
Executing /home/foam/OpenFOAM/OpenFOAM-1.5-dev/bin/foamInstallationTest:

foamInstallationTest --------------

Checking basic setup...
-------------------------------------------------------------------------------
Shell: tcsh
Host: galerius
OS: Linux version 2.6.27.21-0.1-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/foam/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/foam/OpenFOAM/foam-1.5-dev yes no
$WM_THIRD_PARTY_DIR /home/foam/OpenFOAM/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/foam/OpenFOAM/OpenFOAM-1.5-dev yes yes yes

$FOAM_APPBIN ...5-dev/applications/bin/linuxGccDPOpt yes yes yes
$FOAM_USER_APPBIN ...5-dev/applications/bin/linuxGccDPOpt yes yes no
$WM_DIR ...foam/OpenFOAM/OpenFOAM-1.5-dev/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.5-dev/lib/linuxGccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...nFOAM/foam-1.5-dev/lib/linuxGccDPOpt yes yes no
$MPI_ARCH_PATH .../openmpi-1.3/platforms/linuxGccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../configure
4.3.2
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.20 /bin/tar
icoFoam 1.5-dev ...penFOAM-1.5-dev/applications/bin/linuxGccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_galerius Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the OpenFOAM enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.
henrik is offline   Reply With Quote

Old   May 4, 2009, 11:16
Default paraview
  #45
New Member
 
michel elsner
Join Date: Mar 2009
Location: Germany - Berlin and Leipzig
Posts: 26
Rep Power: 8
holzmichel is on a distinguished road
Send a message via Skype™ to holzmichel
Hello all,

I have installed and compiled OF-1.5-dev without an error. Now I wanted to check the icoFoam case but in my Terminal this message is shown:
/home/michel/OpenFOAM/OpenFOAM-1.5-dev/bin/paraFoam: 103: paraview: not found.

But this is really strange because I compiled paraview, too. Has anybody an idea?

Best Regards

Michél
holzmichel is offline   Reply With Quote

Old   May 4, 2009, 15:09
Default
  #46
New Member
 
tino boelke
Join Date: Mar 2009
Location: Rostock
Posts: 10
Rep Power: 8
tino_boelke is on a distinguished road
@ Holzmichel,

check your $OpenFOAM-DIR/etc/apps/paraview3/bash

for these entries:

Code:
export ParaView_VERSION="3.5-dev"

export ParaView_INST_DIR=$WM_THIRD_PARTY_DIR/ParaView-$ParaView_VERSION
where you have to fit the Path and Version to ParaView.

Last edited by tino_boelke; May 5, 2009 at 04:34.
tino_boelke is offline   Reply With Quote

Old   May 5, 2009, 02:32
Default yes
  #47
New Member
 
michel elsner
Join Date: Mar 2009
Location: Germany - Berlin and Leipzig
Posts: 26
Rep Power: 8
holzmichel is on a distinguished road
Send a message via Skype™ to holzmichel
export ParaView_INST_DIR=$WM_THIRD_PARTY_DIR/ParaView$ParaView_VERSION

Thank you. between ParaView$ParaView was an -
holzmichel is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
CFX11 + Fortran compiler ? Mohan CFX 20 March 30, 2011 18:56
Installation problems indy OpenFOAM Installation 7 April 3, 2009 09:40
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Installation problems shellbell1999 OpenFOAM Installation 9 April 6, 2006 13:29
1 fetal error in OpenFOAM12 installation andycong OpenFOAM Installation 3 February 26, 2006 04:09


All times are GMT -4. The time now is 06:19.