CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problem installing OF 1.5 on Ubuntu 9.05

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   April 27, 2009, 14:59
Default Problem installing OF 1.5 on Ubuntu 9.05
  #1
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Hi,

I am a beginner in LINUX/OpenFOAM. I recently installed a dual boot (Xp, Ubuntu) on my computer. I want to install OpenFOAM 1.5 so I have download and unpack the files in home/cj9998/OpenFOAM directory since I cannot add folder in "home". I am stuck in the third point of the readme file (installation).

Firstly, I run the foamSystemCheck script and all are OK!

I run "echo $SHELL" and the result is : /bin/bash

From this, I have to add the following line to the end of my $home/.bashrc file:
$home/cj9998/OpenFOAM/OpenFOAM-1.5/etc/bashrc

How can I do this? If I open bashrc with "gedit ~/.bashrc, the file open and I can add the previous line at the end. I am not sure that this manner is OK!

After that, I have to update the environment variables by sourcing the $home/.bashrc file by typing in the terminal:
~/.bashrc
The following result is obtained: bash: /home/cj9998/.bashrc: Permission denied

Please, can you help me solving the problem?

Last edited by smart; April 27, 2009 at 15:17.
smart is offline   Reply With Quote

Old   April 27, 2009, 16:14
Default
  #2
Senior Member
 
Alberto Passalacqua
Join Date: Mar 2009
Location: Ames, Iowa, United States
Posts: 1,894
Rep Power: 26
alberto will become famous soon enoughalberto will become famous soon enough
This is the correct line for your ~/.bashrc:

. $HOME/OpenFOAM/OpenFOAM-1.5.x/etc/bashrc

Best,
__________________
Alberto Passalacqua

GeekoCFD - A free distribution based on openSUSE 64 bit with CFD tools, including OpenFOAM. Available as live DVD/USB, hard drive image and virtual image.
OpenQBMM - An open-source implementation of quadrature-based moment methods
alberto is offline   Reply With Quote

Old   April 28, 2009, 16:07
Default capital letter or not?
  #3
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Thank you, but when I open a terminal, I get :
sylvain@Sylvain:~$

My OpenFOAM files are in:
home/Sylvain/OpenFOAM/OpenFOAM-1.5/

HOME or home?

And I cannot have permission when I type:

.$home/.bashrc

How I can have this permission to write the line at the end of the file?

Thank you
smart is offline   Reply With Quote

Old   April 28, 2009, 18:33
Default
  #4
Senior Member
 
Alberto Passalacqua
Join Date: Mar 2009
Location: Ames, Iowa, United States
Posts: 1,894
Rep Power: 26
alberto will become famous soon enoughalberto will become famous soon enough
Open a new terminal, type:

cd /home/Sylvain
gedit .bashrc

Add the following line at the end of the file:

. $HOME/OpenFOAM/OpenFOAM-1.5.x/etc/bashrc

Please, cut and paste it exactly and completely. There is a dot (.) followed by a space and then $HOME...

Best,
__________________
Alberto Passalacqua

GeekoCFD - A free distribution based on openSUSE 64 bit with CFD tools, including OpenFOAM. Available as live DVD/USB, hard drive image and virtual image.
OpenQBMM - An open-source implementation of quadrature-based moment methods
alberto is offline   Reply With Quote

Old   April 28, 2009, 20:03
Default permission denied!
  #5
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Thanks a lot but when I type:
.$HOME/.bashrc

I get:

bash: ./home/sylvain/.bashrc: no file or folderof this type

if I try:
.$sylvain/.bashrc

I get:

bash: ./.bashrc: Permission denied

When I open a new terminal it is write:
sylvain@Sylvain:~$

is it normal and OK?

So I cannot source the environment variables!

Thank a lot for your help.
smart is offline   Reply With Quote

Old   April 28, 2009, 20:57
Default
  #6
Senior Member
 
Alberto Passalacqua
Join Date: Mar 2009
Location: Ames, Iowa, United States
Posts: 1,894
Rep Power: 26
alberto will become famous soon enoughalberto will become famous soon enough
Hi,

the procedure I told you didn't require these steps

You should simply:

  • Open the file ~/.bashrc in an editor. For example, type in a terminal:
    • gedit ~/.bashrc
  • Copy exactly this line at the end of it:
    • . $HOME/OpenFOAM/OpenFOAM-1.5.x/etc/bashrc
The next time you open a terminal, the OpenFOAM configuration settings will be set up.

P.S. UNIX is case sensitive. Sylvain is not silvain in a path.

Best,
__________________
Alberto Passalacqua

GeekoCFD - A free distribution based on openSUSE 64 bit with CFD tools, including OpenFOAM. Available as live DVD/USB, hard drive image and virtual image.
OpenQBMM - An open-source implementation of quadrature-based moment methods
alberto is offline   Reply With Quote

Old   April 28, 2009, 21:12
Default Testing the installation!
  #7
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Thank you for your fast reply!

With your answer, OpenFOAM should be correctly installed. But when I check the installation setup by executing the "foamInstallationTest" script a fatal error occurs:

sylvain@Sylvain:~/OpenFOAM/OpenFOAM-1.5/bin$ ./foamInstallationTest
Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------

FATAL ERROR: OpenFOAM environment not configured.

Please refer to the installation section of the README file:
<OpenFOAM installation dir>/OpenFOAM-1.5/README
to source the OpenFOAM environment.

sylvain@Sylvain:~/OpenFOAM/OpenFOAM-1.5/bin$

How can I install the software correctly? Under windows, we need a executable file (".exe") to install a program. With Linux, what is the way?

I would like to know what is the source of this error? Ubuntu? OpenFOAM installation? The fact that I am connected as user instead of root? Thank you to help me finding the solution.

Have a good night!
smart is offline   Reply With Quote

Old   April 28, 2009, 21:18
Default
  #8
Senior Member
 
Alberto Passalacqua
Join Date: Mar 2009
Location: Ames, Iowa, United States
Posts: 1,894
Rep Power: 26
alberto will become famous soon enoughalberto will become famous soon enough
It is correct to be user and not root. So that's not the problem.

It seems that your local console (bash) configurations are not loaded from the configuration file you introduced in .bashrc. I am not familiar with ubuntu however, so I don't know its details.

For detailed installation instructions of OpenFOAM please refer to its README file.

Best,
__________________
Alberto Passalacqua

GeekoCFD - A free distribution based on openSUSE 64 bit with CFD tools, including OpenFOAM. Available as live DVD/USB, hard drive image and virtual image.
OpenQBMM - An open-source implementation of quadrature-based moment methods
alberto is offline   Reply With Quote

Old   April 29, 2009, 03:08
Default
  #9
New Member
 
Join Date: Mar 2009
Posts: 20
Rep Power: 8
Xabi is on a distinguished road
Hi smart,
I think you need to update the enviroment variables before you test the installation. Type the following:
  • . $HOME/.bashrc
By the way,I am also trying to install OF in ubuntu and i have problems with the next step. Let me know if you succeed.
/Xabi
Xabi is offline   Reply With Quote

Old   April 29, 2009, 08:49
Default unable to source environment variables!
  #10
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Thanks a lot Xabi but when I type:
.$HOME/.bashrc

I get:

bash: ./home/sylvain/.bashrc: no file or folderof this type

if I try:
.$sylvain/.bashrc

I get:

bash: ./.bashrc: Permission denied

When I open a new terminal it is write:
sylvain@Sylvain:~$

is it normal and OK?

So I cannot source the environment variables!

What have you done?

What is your computer configuration and version of Ubuntu?
smart is offline   Reply With Quote

Old   April 29, 2009, 15:43
Default
  #11
New Member
 
tino boelke
Join Date: Mar 2009
Location: Rostock
Posts: 10
Rep Power: 8
tino_boelke is on a distinguished road
You have to type:

. $HOME/.bashrc

with space after the Dot, or just open a new terminal or a new tab in the terminal you are right now (the bashrc is executed in every terminal after opening). Everyone of these operations will load the commands from this file.
tino_boelke is offline   Reply With Quote

Old   June 29, 2009, 15:32
Default I succeed!
  #12
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Hi all,

I finaly get the OpenFOAM-1.5-dev running perfectly. I changed my linux system to Ubuntu 8.04. I experienced problems with paraFoam and paraview under ubuntu 9.04.

I solved the problem by installing paraview 3.4.0 instead of 3.3-cvs. For this, I changed some file (buildParaView3.3-cvs, in OpenFOAM-1.5-dev/bin and in OpenFOAM-1.5-dev/bin/tools and the bashrc in OpenFOAM-1.5-dev/etc/apps to point to the ParaView-3.4.0 folder (OpenFOAM/ThirdParty/ParaView-3.4.0).

I think it should be OK too with the ubuntu 9.04 in which the qmake version 4.3.5 should be installed.

Thank to all!
smart is offline   Reply With Quote

Old   June 30, 2009, 18:08
Default Problems installing OpenFoam on ubuntu 9.04
  #13
Member
 
Ramesh Yapalparvi
Join Date: Jun 2009
Posts: 53
Rep Power: 8
yapalparvi is on a distinguished road
/usr/bin/ld: cannot find -lconversion
collect2: ld returned 1 exit status
make[3]: *** [/home/ramesh/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/star4ToFoam] Error 1
make[2]: *** [star4ToFoam] Error 2
/usr/bin/ld: cannot find -lfiniteVolume
collect2: ld returned 1 exit status
make[3]: *** [/home/ramesh/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/foamMeshToFluent] Error 1
make[2]: *** [foamMeshToFluent] Error 2
/usr/bin/ld: cannot find -lmeshTools
collect2: ld returned 1 exit status
make[3]: *** [/home/ramesh/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/polyDualMesh] Error 1
make[2]: *** [polyDualMesh] Error 2
make[2]: Target `application' not remade because of errors.
make[1]: *** [conversion] Error 2
make[1]: Target `application' not remade because of errors.
make: *** [mesh] Error 2
In file included from chemkinToFoam.C:31:
/home/ramesh/OpenFOAM/OpenFOAM-1.5/src/thermophysicalModels/combustion/lnInclude/chemkinReader.H:50:23: error: FlexLexer.h: No such file or directory
In file included from chemkinToFoam.C:31:
/home/ramesh/OpenFOAM/OpenFOAM-1.5/src/thermophysicalModels/combustion/lnInclude/chemkinReader.H:65: error: expected class-name before { token
make[2]: *** [Make/linuxGccDPOpt/chemkinToFoam.o] Error 1
make[2]: Target `/home/ramesh/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/chemkinToFoam' not remade because of errors.
make[1]: *** [chemkinToFoam] Error 2
make[1]: Target `application' not remade because of errors.
make: *** [thermophysical] Error 2
make: Target `application' not remade because of errors.
+ [ = doc ]



Please let me know how can I fix it. Thanks
yapalparvi is offline   Reply With Quote

Old   July 1, 2009, 12:49
Default
  #14
New Member
 
Edgardo
Join Date: Jul 2009
Posts: 1
Rep Power: 0
zarraceno is on a distinguished road
Quote:
Originally Posted by smart View Post
Hi all,

I finaly get the OpenFOAM-1.5-dev running perfectly. I changed my linux system to Ubuntu 8.04. I experienced problems with paraFoam and paraview under ubuntu 9.04.

I solved the problem by installing paraview 3.4.0 instead of 3.3-cvs. For this, I changed some file (buildParaView3.3-cvs, in OpenFOAM-1.5-dev/bin and in OpenFOAM-1.5-dev/bin/tools and the bashrc in OpenFOAM-1.5-dev/etc/apps to point to the ParaView-3.4.0 folder (OpenFOAM/ThirdParty/ParaView-3.4.0).

I think it should be OK too with the ubuntu 9.04 in which the qmake version 4.3.5 should be installed.

Thank to all!
Hi.. what tipe of machine, do you have ?
zarraceno is offline   Reply With Quote

Old   July 1, 2009, 14:12
Default
  #15
Member
 
Ramesh Yapalparvi
Join Date: Jun 2009
Posts: 53
Rep Power: 8
yapalparvi is on a distinguished road
Quote:
Originally Posted by zarraceno View Post
Hi.. what tipe of machine, do you have ?

I have 64 bit machine running ubuntu 9.04 on it
yapalparvi is offline   Reply With Quote

Old   July 20, 2009, 07:52
Default
  #16
New Member
 
Kavin
Join Date: Jul 2009
Posts: 1
Rep Power: 0
sagkavin is on a distinguished road
I have similar problem the output of ./foamInstallationTest is



FATAL ERROR: No remote shell available.
OpenFOAM 1.5 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 2 critical error(s).
sagkavin is offline   Reply With Quote

Old   July 20, 2009, 09:30
Default
  #17
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
This is a fatal error only if you want to use parallel computing. Otherwise, don't mind about this message. If you want to use this option, you will able to fix this issue latter by installing ssh or rsh.
smart is offline   Reply With Quote

Old   August 9, 2009, 01:22
Default
  #18
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
Hi, Ramesh, I recompile the OpenFoam-1.6, and just meet the same errors like yours:
/usr/bin/ld: cannot find -lconversion
/usr/bin/ld: cannot find -lfiniteVolume
/usr/bin/ld: cannot find -lmeshTools

Would you like to share your experiences fixing this problem with me? Thank you in advance.
Best regards,
Chiven
chiven is offline   Reply With Quote

Old   August 10, 2009, 19:12
Default
  #19
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
The thirdParty software is installed, problems is over.

Good luck.
Chiven
chiven is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
natural convection problem for a CHT problem Se-Hee CFX 2 June 10, 2007 06:29
Adiabatic and Rotating wall (Convection problem) ParodDav CFX 5 April 29, 2007 19:13
problem about installing FOAM linux freshman Main CFD Forum 6 November 4, 2004 11:59
extremely simple problem... can you solve it properly? Mikhail Main CFD Forum 40 September 9, 1999 09:11
Is this problem well posed? Thomas P. Abraham Main CFD Forum 5 September 8, 1999 14:52


All times are GMT -4. The time now is 09:24.