CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

openfoam 1.5-devcrashng after few iterations

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 5, 2009, 19:13
Default openfoam 1.5-devcrashng after few iterations
  #1
Member
 
matteo lombardi
Join Date: Apr 2009
Posts: 61
Rep Power: 8
matteoL is on a distinguished road
Hello,
I downloaded openfoam1.5 from Openfoam site and managed to run succesfully some simple interFoam cases.

Yesterday I decided to install the dev version and compile it froms source, thus i downloaded via svn and installed it.

Compilation went trough succesfully (at least no error reported, some warning but no errors..) and I tought everything was fine.
Unfortunately when running the same case thas was succesfully run with openfoam1.5, in the dev version it explodes very quickly!

right after the first iteration I observe that one cell gets a very high pressure value, which grows more and more in the next iteration and thus leads to non convergence.

once again: with the openfoam1.5 version, the exactly same case used to run smoothly..

Has anyone any idea why this happens?

I thought the dev version was supposed to ahve some more utilities/solver/etc.. but the classical solver (like interfoam) were the same... Am i wrong?

The only thing i may point out is that i used gcc-4.1.2 to compile the dev version because when i tried to use the ggc_4.3.1 in the ThirdParty package i used to get some libstc++.so problems (no idea why.. any ideas?)

Any help would be much appreciated.

thank you very much,
Matteo
matteoL is offline   Reply With Quote

Old   May 6, 2009, 02:31
Default
  #2
Senior Member
 
Henrik Rusche
Join Date: Mar 2009
Location: Braunschweig, Niedersachsen, Germany
Posts: 275
Rep Power: 9
henrik is on a distinguished road
Matteo,

I would like reproduce your problem. Which case is blowing up?

Henrik
henrik is offline   Reply With Quote

Old   May 6, 2009, 04:25
Default
  #3
Member
 
matteo lombardi
Join Date: Apr 2009
Posts: 61
Rep Power: 8
matteoL is on a distinguished road
Hello Henrik, thank you very much for your help.

Here attached there is the case, a simple boat ship geometry run with interFoam (mesh produced with ICEM).

I have problem uploading the file (5,8 M, is it too big?), thus I will send it to you by mail. If anyone else is interested ask me and i will send it to you.

The mesh is not particularly nice, i know, but my focus now is to understand why with 1.5 it works while with 1.5-dev starts diverging right after the first iteration.

thanks,
Matteo
matteoL is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Moving mesh Niklas Wikstrom (Wikstrom) OpenFOAM Running, Solving & CFD 122 June 15, 2014 06:20
How to write k and epsilon before the abnormal end xiuying OpenFOAM Running, Solving & CFD 8 August 27, 2013 15:33
Low Mach number Compressible jet flow using LES ankgupta8um OpenFOAM Running, Solving & CFD 7 January 15, 2011 14:38
Differences between serial and parallel runs carsten OpenFOAM Bugs 11 September 12, 2008 11:16
Unknown error sivakumar OpenFOAM Pre-Processing 9 September 9, 2008 12:53


All times are GMT -4. The time now is 18:14.