CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   How to upgrade OF 1.5 to OF 1.5.x version? (http://www.cfd-online.com/Forums/openfoam-installation/64691-how-upgrade-1-5-1-5-x-version.html)

Marcin May 20, 2009 05:18

How to upgrade OF 1.5 to OF 1.5.x version?
 
Hi everyone!

I would like to upgrade my OF to the 1.5.x version because of some bugs. I'm using KDE 3.1.4 linux version and don't have connection with internet on this computer.

Could someone give me some advices, how to do it step by step?

Regards, Marcin.

olesen May 20, 2009 08:52

Quote:

Originally Posted by Marcin (Post 216696)
I would like to upgrade my OF to the 1.5.x version ... don't have connection with internet on this computer.

You can fetch or clone the git repository on any other computer with internet access and transfer it via USB stick to your other computer.
The only essential part that you actually need is the ".git" directory.
You can, for example,
Code:

# machine 1
tar -cvf /media/USB/OF15x-git.tar OpenFOAM-1.5.x/.git

# machine 2
tar -xvf /media/USB/OF15x-git.tar
cd OpenFOAM-1.5.x

git status    # verify the current status (all the files are missing)
git checkout -f HEAD  # force a checkout of the current head

After that it is the same as the usual compilation process.

For keeping your isolated repository up-to-date, I'd suggest reading up on "git-bundle" - it's a useful way of moving about small changes.

Marcin June 1, 2009 14:32

Hi Mark,

thank You very much for Your reply. Do You know, how can I "fetch or clone the git repository"? The problem is, that I'm using a windows computer at home and a OpenSuse computer at work. I have tried to open the link from the CFD Online homepage, but it dosen't seem to work. I get a message "firefox is not able to open a git protocol". I must also add, that I'm a new linux and OpenFOAM user. Thanks for any help.

Best Regards!

Marcin.

olesen June 2, 2009 03:25

Quote:

Originally Posted by Marcin (Post 217821)
The problem is, that I'm using a windows computer at home and a OpenSuse computer at work.

I don't know how much effort it'd be to use OpenFOAM with windows - I personally try to avoid windows as much as possible.

Quote:

I get a message "firefox is not able to open a git protocol"
If you dig about a bit more, you'll find that there are both git and http protocols for accessing the repositories on repo.or.cz. The git protocol should be more efficient, but I use the http protocol due to corporate firewall issues.

http://repo.or.cz/w/OpenFOAM-1.5.x.git


All times are GMT -4. The time now is 01:27.