CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

CMake error on my 64bit machine

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 28, 2009, 12:48
Default CMake error on my 64bit machine
  #1
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Hello World.

I am really really sorry to ask about this since I have managed to install OpenFOAM about three times before on 32bit machines.
But on my new 64bit machine running Kubuntu 9.04 I'm really stuck.

So far I have managed to install the Qt version 4.3.5 and wanted to compile Paraview 3.3 by running

Code:
buildParaView3.3-cvs
from the /OpenFOAM/ThirdParty directory.

Unfortunately there is this error message

Code:
sega@deepblue:~/OpenFOAM/ThirdParty$ buildParaView3.3-cvs
Building ParaView3.3-cvs
    MPI support    : OFF
    Python support : OFF
    MESA support   : OFF
    Source         : /home/sega/OpenFOAM/ThirdParty/ParaView3.3-cvs
    Target         : /home/sega/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/home/sega/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.

make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.
done
I'm searching the forum for hours but have found nothing so far.
Maybe I'm getting tired or the information is hiding from me.

Could someone help me with this?
Whats wrong?
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 28, 2009, 15:11
Default
  #2
Senior Member
 
Rishi .
Join Date: Mar 2009
Posts: 141
Rep Power: 8
hellorishi is on a distinguished road
Hi Sebastian,

I dont know the exact answer. I would recommend posting the output of few commands.

cmake --version
qmake --version

This way you will be atleast sure you using the suitable versions of both programs.
Rishi

Last edited by hellorishi; May 29, 2009 at 03:24.
hellorishi is offline   Reply With Quote

Old   May 28, 2009, 15:47
Default
  #3
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Sounds promising, as there is an error:

Code:
sega@deepblue:~$ cmake --version
bash: /home/sega/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin/cmake: No such file or directory
But the file is existing

Code:
sega@deepblue:~/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin$ ls
ccmake  cmake  cpack  ctest
Qt seems to be working:

Code:
sega@deepblue:~$ qmake --version
QMake version 2.01a
Using Qt version 4.3.5 in /home/sega/OpenFOAM/ThirdParty/Qt-4.3.5/lib
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 29, 2009, 14:23
Default
  #4
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi Sebastian,

It seems more people have problems with cmake in Kubuntu 9.04. In this thread it is mentioned that you need to install it separately by
Code:
sudo apt-get install cmake
and perhaps need to edit a file called CMakeLists.txt to edit the right file paths etc.

Regards,

Gijsbert
gwierink is offline   Reply With Quote

Old   May 29, 2009, 15:14
Default
  #5
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Quote:
Originally Posted by gwierink View Post
and perhaps need to edit a file called CMakeLists.txt to edit the right file paths etc.
Linux, please don't do this to me.

There are 263 files called CMakeLists.txt on my system.
Which one am I going to edit? And how?

I was not able to extract any valuable information to me out of your suggested thread, sorry. It's about some weather plasmoid software?

Meanwhile I did a
Code:
sudo apt-get remove cmake
and
Code:
sudo apt-get install cmake
but it changed nothing concerning buildParaView3.3-cvs ...
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 29, 2009, 15:36
Default
  #6
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
set WM_64 to true.

Hrv

there seem to be some unknown trick to compile paraFoam on 64 bits systems. I had a similar problem on openSUSE 64 bits, but the answer I got did not solve my problem, it might work for you
here is a link to that thread
Question to OF Developers
Ahmed is offline   Reply With Quote

Old   May 29, 2009, 16:01
Default
  #7
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Quote:
Originally Posted by Ahmed View Post
set WM_64 to true.

Hrv

there seem to be some unknown trick to compile paraFoam on 64 bits systems. I had a similar problem on openSUSE 64 bits, but the answer I got did not solve my problem, it might work for you
here is a link to that thread
Question to OF Developers
Thanks for your response.
I put WM_64='true' to the very end of /OpenFOAM/OpenFOAM-1.5/etc/bashrc

At least it made the buildParaView3.3-cvs go some way.

It went until hitting
Code:
-- Found Qt-Version 4.3.5
CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
OPENGL_INCLUDE_DIR (ADVANCED)

-- Configuring done
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.
done
So there still seems to be some problem with this (damned, sorry for that) cmake.

What does this OPENGL error mean?
I am happy managing this linux stuff without doing some drivers related to my graphic card ...
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 29, 2009, 16:58
Default
  #8
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
Well, I guess my limited Linux knowledge might help you. There are two ways to solve this:
1- search your system and find where the OPENGL is located, then set it manually in the bashrc file
2- find which system file has the system variables defined and edit it (You can post a query on your distro forums and sure there will be some willing to help, at least this is what I did)
You know, I thought non zero definitions means true, but it is not, this week end I will try to do as you did, set the value to 'true' and see what happens, thanks, for your informative answer.
Good Luck
Ahmed is offline   Reply With Quote

Old   May 29, 2009, 17:08
Default
  #9
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Quote:
Originally Posted by Ahmed View Post
1- search your system and find where the OPENGL is located, then set it manually in the bashrc file
What does that mean? How do I search my system for THAT?
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 29, 2009, 21:29
Default
  #10
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
on my openSUSE, I would call YAST -> software management and type the file name in the search window, does that answer help you? of course not. Sorry for that. Take your question to the UBUNTU forums, good Samaritans are everywhere
Ahmed is offline   Reply With Quote

Old   May 29, 2009, 21:34
Default
  #11
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
one more point, OPENGL is a microsoft product, and instead, Linux distros use the MESA graphic library, there must be some softlinks to adjust for that
Ahmed is offline   Reply With Quote

Old   May 30, 2009, 02:36
Default
  #12
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi Sebastian,

You need some OpenGL and X11 libs, at least on Fedora. In (K)Ubuntu I know you also need mesa libs. You can get the whole bunge with

Code:
sudo yum groupinstall x-software-development development-tools
and

Code:
 sudo apt-get mesa-libGL\*-devel freeglut-devel libdrm-devel
Hope this is of more help than my last trial.

Cheers, Gijs
gwierink is offline   Reply With Quote

Old   May 30, 2009, 05:08
Default
  #13
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Hi.

I am afraid no.
Code:
sudo yum groupinstall x-software-development development-tools
is an unknown command to my system.

Code:
sudo apt-get install mesa-libGL\*-devel freeglut-devel libdrm-devel
looks promising althought I had to put the install command in it.

Unfortunately these packages are not found.
Code:
sega@deepblue:~$ sudo apt-get install mesa-libGL\*-devel freeglut-devel libdrm-devel
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut
Lese Status-Informationen ein... Fertig
E: Konnte Paket mesa-libGL*-devel nicht finden
I'm really sorry about that, but I don't know what this is all meaning.
I would not even know what question I should post on the ubuntu forum.
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 30, 2009, 05:46
Talking
  #14
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Is that true?! Looks like I fixed it!

Searching for days I finally found http://jlinx.de/blog/?p=304
and installing the two packages

Code:
freeglut3-dev
libxt-dev
made buildParaView3.3-cvs start.
Hopefully there won't be any other errors...
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 30, 2009, 09:17
Default
  #15
New Member
 
Andreas Rarrek
Join Date: May 2009
Posts: 12
Rep Power: 8
erklaerbaer is on a distinguished road
Hi,

i am also stuck at

Code:
andreas@andreas-desktop:~/OpenFOAM/ThirdParty$ buildParaView3.3-cvs
Building ParaView3.3-cvs
    MPI support    : OFF
    Python support : OFF
    MESA support   : OFF
    Source         : /home/andreas/OpenFOAM/ThirdParty/ParaView3.3-cvs
    Target         : /home/andreas/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/home/andreas/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.

make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.
done
andreas@andreas-desktop:~/OpenFOAM/ThirdParty$
I wrote

Quote:
WM_64='true'
at the end of my bashrc in the OpenFOAM Directory but i get the same error again; did you do something else?

andi
erklaerbaer is offline   Reply With Quote

Old   May 30, 2009, 09:18
Default
  #16
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
Quote:
Originally Posted by sega View Post
Is that true?! Looks like I fixed it!

Searching for days I finally found http://jlinx.de/blog/?p=304
and installing the two packages

Code:
freeglut3-dev
libxt-dev
made buildParaView3.3-cvs start.
Hopefully there won't be any other errors...
The following lines are copied from the on Line documents at www.ubuntu.com

  1. Click System → Administration → Synaptic Package Manager. Enter your password if prompted.
  2. Click Search to search for an application, or click Sections and look through the categories to find one.
  3. Right-click the application that you want to install and select Mark for Installation.
  4. If you are asked if you would like to mark additional changes, click Mark.
  5. Select any other applications that you would like to install.
  6. Click Apply, and then click Apply in the window that appears. The applications that you chose will be downloaded and installed.
I guess you now realize that the basics of system administration has to be known to you.
Good Luck, and let us know the results of your 64 bits installation
Ahmed is offline   Reply With Quote

Old   May 30, 2009, 09:29
Default
  #17
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 11
sega is on a distinguished road
Quote:
Originally Posted by erklaerbaer View Post
did you do something else?
No. It solved the problem with CMake on my system.
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   May 30, 2009, 09:41
Default
  #18
New Member
 
Andreas Rarrek
Join Date: May 2009
Posts: 12
Rep Power: 8
erklaerbaer is on a distinguished road
Quote:
Originally Posted by sega View Post
No. It solved the problem with CMake on my system.
Thats bad, for me

@Ahmed: I already have this packages installed. If i understood sega correctly his first error which is similar to mine disapperaed after setting WM_64 to true which unfortunately does not seem to do the trick for me.

I guess i will have to throw the 32bit Version on VirtualBox and not the 64 one :/
erklaerbaer is offline   Reply With Quote

Old   May 30, 2009, 12:18
Default
  #19
Senior Member
 
Ahmed
Join Date: Mar 2009
Location: NY
Posts: 250
Rep Power: 9
Ahmed is on a distinguished road
Quote:
Originally Posted by erklaerbaer View Post
Thats bad, for me

@Ahmed: I already have this packages installed. If i understood sega correctly his first error which is similar to mine disapperaed after setting WM_64 to true which unfortunately does not seem to do the trick for me.

I guess i will have to throw the 32bit Version on VirtualBox and not the 64 one :/
Before you do that, It is a good idea to use synaptic (or YAST or whatever package manager on your distro) and update cmake and OPENGL (or its available variant on your distro)
Good Luck
Ahmed is offline   Reply With Quote

Old   June 2, 2009, 04:34
Default
  #20
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Quote:
Originally Posted by Ahmed View Post
one more point, OPENGL is a microsoft product, and instead, Linux distros use the MESA graphic library, there must be some softlinks to adjust for that
This is very strange misinformation. OpenGL is by no means a Microsoft product! It was originally developed by sgi. Here's a link to more OpenGL information: http://www.opengl.org/
olesen is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM15 paraFoam bug koen OpenFOAM Bugs 19 June 30, 2009 10:46
64bit machine for CFX Ahlo CFX 1 February 7, 2008 17:30
Library problem on a 64bit machine wrong ELF class ELFCLASS32 jango OpenFOAM Installation 0 June 11, 2007 07:29
Problems installing OpenFoam on a 64bit machine jango OpenFOAM Installation 1 June 4, 2007 14:53
runing Fluent with a 64bit machine Rucy FLUENT 1 November 17, 2005 09:51


All times are GMT -4. The time now is 15:37.