CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   icoFoam: Conflicting installations (

smart June 11, 2009 15:12

icoFoam: Conflicting installations
I am installing OF-1.5-dev on Ubuntu 9.04 and I have one critical error when I run foamInstallationTest:

WARNING: Conflicting installations:
OpenFoam settings: /home/sylvain/OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linuxGccDROpt/icoFoam
Current paht:

When I do Allwmake to install OF, I got a lot of error 1 and error 2:
error 1: cannot find -lfinitevolume or -l... (some other library)
error 2: make[2]: *** (link to the first error I think)

Can anybody help me please! Initially, I had 2 critical error. The other one was because Ubuntu 9.04 use gcc 4.3.3 instead of 4.3.1 as OF do. I corrected this error changing compiler in and settings .csh.

Thank you very much!

akidess June 16, 2009 15:08

Hello Sylvain, there must have been an error before that one, when compiling libfinitevolume. Go to your src directory and execute "wmake libso finiteVolume". See if you can find the error from there.


smart June 29, 2009 15:39

All is ok
Hi all,

I finaly get the OpenFOAM-1.5-dev running perfectly. I changed my linux system to Ubuntu 8.04. I experienced problems with paraFoam and paraview under ubuntu 9.04.

I solved the problem by installing paraview 3.4.0 instead of 3.3-cvs. For this, I changed some file (buildParaView3.3-cvs, in OpenFOAM-1.5-dev/bin and in OpenFOAM-1.5-dev/bin/tools and the bashrc in OpenFOAM-1.5-dev/etc/apps to point to the ParaView-3.4.0 folder (OpenFOAM/ThirdParty/ParaView-3.4.0).

I think it should be OK too with the ubuntu 9.04 in which the qmake version 4.3.5 should be installed.

For me, I used qmake 4.3.4 and gcc 4.3.1.

Thank to all!

All times are GMT -4. The time now is 22:31.