CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

icoFoam: Conflicting installations

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 11, 2009, 15:12
Default icoFoam: Conflicting installations
  #1
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
I am installing OF-1.5-dev on Ubuntu 9.04 and I have one critical error when I run foamInstallationTest:

icoFoam
WARNING: Conflicting installations:
OpenFoam settings: /home/sylvain/OpenFOAM/OpenFOAM-1.5-dev/applications/bin/linuxGccDROpt/icoFoam
Current paht:
CRITICAL ERROR

When I do Allwmake to install OF, I got a lot of error 1 and error 2:
error 1: cannot find -lfinitevolume or -l... (some other library)
error 2: make[2]: *** (link to the first error I think)

Can anybody help me please! Initially, I had 2 critical error. The other one was because Ubuntu 9.04 use gcc 4.3.3 instead of 4.3.1 as OF do. I corrected this error changing compiler in settings.sh and settings .csh.

Thank you very much!
smart is offline   Reply With Quote

Old   June 16, 2009, 15:08
Default
  #2
Senior Member
 
akidess's Avatar
 
Anton Kidess
Join Date: May 2009
Location: Delft, Netherlands
Posts: 919
Rep Power: 17
akidess will become famous soon enough
Hello Sylvain, there must have been an error before that one, when compiling libfinitevolume. Go to your src directory and execute "wmake libso finiteVolume". See if you can find the error from there.

Anton
akidess is offline   Reply With Quote

Old   June 29, 2009, 15:39
Default All is ok
  #3
Member
 
Sylvain Martel
Join Date: Apr 2009
Location: University of Sherbrooke/Quebec/Canada
Posts: 51
Rep Power: 8
smart is on a distinguished road
Hi all,

I finaly get the OpenFOAM-1.5-dev running perfectly. I changed my linux system to Ubuntu 8.04. I experienced problems with paraFoam and paraview under ubuntu 9.04.

I solved the problem by installing paraview 3.4.0 instead of 3.3-cvs. For this, I changed some file (buildParaView3.3-cvs, in OpenFOAM-1.5-dev/bin and in OpenFOAM-1.5-dev/bin/tools and the bashrc in OpenFOAM-1.5-dev/etc/apps to point to the ParaView-3.4.0 folder (OpenFOAM/ThirdParty/ParaView-3.4.0).

I think it should be OK too with the ubuntu 9.04 in which the qmake version 4.3.5 should be installed.

For me, I used qmake 4.3.4 and gcc 4.3.1.

Thank to all!
smart is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Density in icoFoam Densidad en icoFoam manuel OpenFOAM Running, Solving & CFD 8 September 22, 2010 04:10
Critical errors gcc and icoFoam during installation of 15 quartzian OpenFOAM Installation 3 December 12, 2008 13:42
Kubuntu uses dash breaks All scripts in tutorials platopus OpenFOAM Bugs 8 April 15, 2008 07:52
Conflicting installations for gcc fbisetti OpenFOAM Installation 16 October 5, 2007 02:23
1 critical error GCC Conflicting installations atzaru OpenFOAM Installation 6 April 23, 2006 13:50


All times are GMT -4. The time now is 09:14.