CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM Installation Ubuntu 9.04 Problems (http://www.cfd-online.com/Forums/openfoam-installation/66674-openfoam-installation-ubuntu-9-04-problems.html)

Sumontro July 21, 2009 12:33

OpenFOAM Installation Ubuntu 9.04 Problems
 
I am a new user to Linux and I have no Idea what I am doing wrong.
I followed the installation instructions given, sourcing the bashrc file. But this is the output I got.

sumontro@ubuntu:~$ source $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc

Warning in /home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/settings.sh:
Cannot find /home/sumontro/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux installation.
Please install this compiler version or if you wish to use the system compiler,
change the WM_COMPILER_INST setting to 'System' in this file

bash: ./home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc: No such file or directory


I then changed the compiler installation setting to System, but then this is the output I got.

sumontro@ubuntu:~$ source $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc
bash: ./home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc: No such file or directory


I don't know why the computer cannot source the bashrc file. It knows that it is there, because I can locate it through find. I would really appreciate some help on this.

akidess July 21, 2009 13:46

Did you extract both ThirdParty.General.gtgz and ThirdParty.linuxGcc.gtgz in the proper directories? Does /home/sumontro/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux and is it non-empty?

Also try ". $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc" instead of source.

Sumontro July 21, 2009 14:06

I did extract both the ThirdParty.General.gtgz and ThirdParty.linuxGcc.gtgz in the proper directories in $HOME/OpenFOAM and $HOME/OpenFOAM/ThirdParty

$HOME/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux is not empty.

Sumontro July 21, 2009 14:09

The same message still comes when I source with .

sumontro@ubuntu:~$ . $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc
bash: ./home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc: No such file or directory

What do I do?

akidess July 21, 2009 14:19

Hm, I think I see the problem. The proper directory would be "/home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc" without the preceeding dot. Does "echo $HOME" give you "/home/sumontro"? If not, restart the terminal and if the problem is still there, make sure there are no commands in ~/.bashrc that alter $HOME or manually set $HOME to be /home/sumontro.

Sumontro July 21, 2009 14:40

yes, when I do echo $HOME, I get /home/sumontro. What else can I do to fix this?

akidess July 21, 2009 15:01

This is odd. I don't see why it would be trying to use ./home if your $HOME variable is correct. You could try sourcing ~/OpenFOAM/OpenFOAM-1.5/etc/bashrc or /home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc to avoid using the environment variable.

If that doesn't work you might want to try from scratch.

Sumontro July 21, 2009 15:44

ok, I fixed the source problem. It seems I was putting that last line into the wrong bashrc file. However, when I source $HOME/.bashrc, nothing happens. When I run the installation script, it gives me two critical errors,

Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../src/configure
4.3.3
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.20 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/sumontro/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------

How do I fix this?

yapalparvi July 21, 2009 21:40

Hi,


Just follow the same procedure as in given in the readme file. Create a driectory OpenFOAm and download all ur tar flies. make sure you are downloading the correct files for the platform. Extract everything in the same directory. Set your path in /.bashrc and add the same line as given in the readme file. I would recommend you close the terminal and open a new one. Then use . $HOME/.bashrc command to set the paths. then type "which gcc". This should point to the directory where your third party files are included which contains gcc as well. If it doesnt point to the directory then you are doing something wrong and that is why you are getting the error conflicting compilers


All times are GMT -4. The time now is 14:39.