CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM Installation Ubuntu 9.04 Problems

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 21, 2009, 12:33
Default OpenFOAM Installation Ubuntu 9.04 Problems
  #1
New Member
 
Sumontro
Join Date: Jul 2009
Posts: 12
Rep Power: 7
Sumontro is on a distinguished road
I am a new user to Linux and I have no Idea what I am doing wrong.
I followed the installation instructions given, sourcing the bashrc file. But this is the output I got.

sumontro@ubuntu:~$ source $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc

Warning in /home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/settings.sh:
Cannot find /home/sumontro/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux installation.
Please install this compiler version or if you wish to use the system compiler,
change the WM_COMPILER_INST setting to 'System' in this file

bash: ./home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc: No such file or directory


I then changed the compiler installation setting to System, but then this is the output I got.

sumontro@ubuntu:~$ source $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc
bash: ./home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc: No such file or directory


I don't know why the computer cannot source the bashrc file. It knows that it is there, because I can locate it through find. I would really appreciate some help on this.
Sumontro is offline   Reply With Quote

Old   July 21, 2009, 13:46
Default
  #2
Senior Member
 
akidess's Avatar
 
Anton Kidess
Join Date: May 2009
Location: Delft, Netherlands
Posts: 912
Rep Power: 16
akidess will become famous soon enough
Did you extract both ThirdParty.General.gtgz and ThirdParty.linuxGcc.gtgz in the proper directories? Does /home/sumontro/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux and is it non-empty?

Also try ". $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc" instead of source.
akidess is offline   Reply With Quote

Old   July 21, 2009, 14:06
Default
  #3
New Member
 
Sumontro
Join Date: Jul 2009
Posts: 12
Rep Power: 7
Sumontro is on a distinguished road
I did extract both the ThirdParty.General.gtgz and ThirdParty.linuxGcc.gtgz in the proper directories in $HOME/OpenFOAM and $HOME/OpenFOAM/ThirdParty

$HOME/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux is not empty.
Sumontro is offline   Reply With Quote

Old   July 21, 2009, 14:09
Default
  #4
New Member
 
Sumontro
Join Date: Jul 2009
Posts: 12
Rep Power: 7
Sumontro is on a distinguished road
The same message still comes when I source with .

sumontro@ubuntu:~$ . $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc
bash: ./home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc: No such file or directory

What do I do?
Sumontro is offline   Reply With Quote

Old   July 21, 2009, 14:19
Default
  #5
Senior Member
 
akidess's Avatar
 
Anton Kidess
Join Date: May 2009
Location: Delft, Netherlands
Posts: 912
Rep Power: 16
akidess will become famous soon enough
Hm, I think I see the problem. The proper directory would be "/home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc" without the preceeding dot. Does "echo $HOME" give you "/home/sumontro"? If not, restart the terminal and if the problem is still there, make sure there are no commands in ~/.bashrc that alter $HOME or manually set $HOME to be /home/sumontro.
akidess is offline   Reply With Quote

Old   July 21, 2009, 14:40
Default
  #6
New Member
 
Sumontro
Join Date: Jul 2009
Posts: 12
Rep Power: 7
Sumontro is on a distinguished road
yes, when I do echo $HOME, I get /home/sumontro. What else can I do to fix this?
Sumontro is offline   Reply With Quote

Old   July 21, 2009, 15:01
Default
  #7
Senior Member
 
akidess's Avatar
 
Anton Kidess
Join Date: May 2009
Location: Delft, Netherlands
Posts: 912
Rep Power: 16
akidess will become famous soon enough
This is odd. I don't see why it would be trying to use ./home if your $HOME variable is correct. You could try sourcing ~/OpenFOAM/OpenFOAM-1.5/etc/bashrc or /home/sumontro/OpenFOAM/OpenFOAM-1.5/etc/bashrc to avoid using the environment variable.

If that doesn't work you might want to try from scratch.
akidess is offline   Reply With Quote

Old   July 21, 2009, 15:44
Default
  #8
New Member
 
Sumontro
Join Date: Jul 2009
Posts: 12
Rep Power: 7
Sumontro is on a distinguished road
ok, I fixed the source problem. It seems I was putting that last line into the wrong bashrc file. However, when I source $HOME/.bashrc, nothing happens. When I run the installation script, it gives me two critical errors,

Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../src/configure
4.3.3
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.20 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/sumontro/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------

How do I fix this?
Sumontro is offline   Reply With Quote

Old   July 21, 2009, 21:40
Default
  #9
Member
 
Ramesh Yapalparvi
Join Date: Jun 2009
Posts: 49
Rep Power: 7
yapalparvi is on a distinguished road
Hi,


Just follow the same procedure as in given in the readme file. Create a driectory OpenFOAm and download all ur tar flies. make sure you are downloading the correct files for the platform. Extract everything in the same directory. Set your path in /.bashrc and add the same line as given in the readme file. I would recommend you close the terminal and open a new one. Then use . $HOME/.bashrc command to set the paths. then type "which gcc". This should point to the directory where your third party files are included which contains gcc as well. If it doesnt point to the directory then you are doing something wrong and that is why you are getting the error conflicting compilers
yapalparvi is offline   Reply With Quote

Reply

Tags
openfoam 1.5

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Boundary condition problems (OpenFOAM) Milos OpenFOAM Other Meshers: ICEM, Star, Ansys, Pointwise, GridPro, Ansa, ... 12 June 10, 2014 16:35
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43
MPI error on Ubuntu 9.04 denner OpenFOAM Running, Solving & CFD 3 June 13, 2009 13:38
OpenFoam - problems MateuszZb ParaView 8 July 21, 2008 16:16
installation problems on upgrade from win 3.26 to mic CD-adapco 5 June 20, 2007 09:40


All times are GMT -4. The time now is 21:13.