CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problems about installing OpenFoam-1.6

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 9, 2009, 08:14
Smile Problems about installing OpenFoam-1.6
  #1
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
During the installation, when I try to compile the hoard in the ThirdParty-1.6, I meet an error like:

lnInclude/spinlock.h:253:2: error: #error "No spin lock implementation is available for this platform."

I am using ia64 GNU/Linux platform and the GCC 4.3.3.

This error will influence the following recompiling of OpenFoam-1.6, but now I have no idea about it.

Any suggestion is appreciated.

Best regards,
Chiven
chiven is offline   Reply With Quote

Old   August 10, 2009, 00:40
Default
  #2
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
Anyone knows the means of the following commands in ThirdParty-1.6/Allwmake?
set -x
# export WM settings in a form that GNU configure recognizes
[ -n "$WM_CC" ] && export CC="$WM_CC"
[ -n "$WM_CXX" ] && export CXX="$WM_CXX"
[ -n "$WM_CFLAGS" ] && export CFLAGS="$WM_CFLAGS"
[ -n "$WM_CXXFLAGS" ] && export CXXFLAGS="$WM_CXXFLAGS"
[ -n "$WM_LDFLAGS" ] && export LDFLAGS="$WM_LDFLAGS"

In my platform, WM_CC, WM_CXX, WM_CFLAGS, WM_CXXFLAGS, WM_LDFLAGS are undefined variables. And when I try to run ./Allwmake, the terminal prompts "set: Variable name must begin with a letter.".

Thanks in advance.

Best regards,
Chiven
chiven is offline   Reply With Quote

Old   August 10, 2009, 19:10
Default
  #3
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
Done. The installation is finished.
chiven is offline   Reply With Quote

Old   August 28, 2009, 04:39
Default still open questions?
  #4
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Hi chiven,

It would be nice if you share your error solutions with the community!
How did you solve the spinlock problem?

Regards Jens
jens_klostermann is offline   Reply With Quote

Old   August 28, 2009, 05:18
Default
  #5
Senior Member
 
Hrvoje Jasak
Join Date: Mar 2009
Location: London, England
Posts: 1,758
Rep Power: 21
hjasak will become famous soon enough
Hi Jens,

He had to source ~/OpenFOAM/OpenFOAM-1.6.x/etc/cshrc or bashrc for the variables to be set. That fixes it.

Hrv
__________________
Hrvoje Jasak
Providing commercial FOAM/OpenFOAM and CFD Consulting: http://wikki.co.uk
hjasak is offline   Reply With Quote

Old   August 28, 2009, 05:32
Default
  #6
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Hi Hrv,

my problem is little more complicated!
I try to compile OF-1.5-dev (because of missing ggi in OF-1.6.x ?) in ia64 with intelcompiler 10.1. So I changed all my settings in etc/bashrc etc/settings.sh

But with the compilation of the hoard library I run into some problems

lnInclude/spinlock.h(140): warning #858: type qualifier on return type is meaningless
inline static volatile unsigned long MyInterlockedExchange (unsigned long *,unsigned long);
^

lnInclude/spinlock.h(131): error: asm statements not supported in this environment
asm volatile ("" : : : "memory");

and I have no idea how to solve it?

Best regards Jens
jens_klostermann is offline   Reply With Quote

Old   August 28, 2009, 05:37
Default
  #7
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
Hi, Jens, Hoard is not supported on IA64. It does not affect compilation/running in any way. Please continue.
Best regards,
Chiven
chiven is offline   Reply With Quote

Old   August 28, 2009, 05:48
Default
  #8
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Hi chiven,
Thanks for the information I just took it out of ThirdParty/malloc/Allwmake

Will see what the future brings!

Jens
jens_klostermann is offline   Reply With Quote

Old   August 28, 2009, 06:00
Default
  #9
Senior Member
 
Hrvoje Jasak
Join Date: Mar 2009
Location: London, England
Posts: 1,758
Rep Power: 21
hjasak will become famous soon enough
Thank you for sorting this out. I am using Icc 11.1.046 and will have a go at recompiling the whole lot.

The hoard stuff was full of warning messages (ugh!), but compiles OK. Are you using the latest icc?

Hrv
__________________
Hrvoje Jasak
Providing commercial FOAM/OpenFOAM and CFD Consulting: http://wikki.co.uk
hjasak is offline   Reply With Quote

Old   August 28, 2009, 06:15
Default
  #10
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
Hi, Dear Prof. Jasak, I am using the gcc 4.3.3, attached in the Third Party software pack of OpenFOAM Version-1.6.
Yours respectfully,
Chiven
chiven is offline   Reply With Quote

Old   August 28, 2009, 06:41
Default
  #11
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Quote:
Originally Posted by hjasak View Post
Are you using the latest icc?
Hrv
My icc version is 10.1.015.

Jens
jens_klostermann is offline   Reply With Quote

Old   August 28, 2009, 06:49
Default
  #12
Senior Member
 
J. Cai
Join Date: Apr 2009
Posts: 180
Rep Power: 8
chiven is on a distinguished road
My icc version is 10.1 20071116.

best regards,
Chiven
chiven is offline   Reply With Quote

Old   August 29, 2009, 01:31
Default
  #13
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Quote:
Originally Posted by jens_klostermann View Post
Hi chiven,
Thanks for the information I just took it out of ThirdParty/malloc/Allwmake

Will see what the future brings!

Jens
After taking out wmake libso hoard in ThirdParty/malloc/Allwmake the compilation with my old icc version has succeeded. I hope there will be no loss in performance without the hoard?
But I thought hoard helps only in memory allocation for multithreading?! Where is OF using multithreading? Is there an other reason for using hoard?

Jens
jens_klostermann is offline   Reply With Quote

Old   October 27, 2009, 15:14
Default
  #14
New Member
 
Felix Apel
Join Date: Sep 2009
Posts: 15
Rep Power: 7
Don456 is on a distinguished road
Hi,

I'm trying to compile OF 1.6 with Icc 11.1 and having problems.

I get the following error:

/home/flix/OpenFOAM/OpenFOAM-1.6.x/src/OpenFOAM/lnInclude/HashTable.C(459): error: argument list for class template "Foam::Hash" is missing
const HashTable<AnyType, Key, Hash>& rhs
^
Any suggestions?

Greetings Felix
Don456 is offline   Reply With Quote

Old   October 28, 2009, 05:52
Default
  #15
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
Quote:
Originally Posted by Don456 View Post
Hi,

I'm trying to compile OF 1.6 with Icc 11.1 and having problems.

I get the following error:

/home/flix/OpenFOAM/OpenFOAM-1.6.x/src/OpenFOAM/lnInclude/HashTable.C(459): error: argument list for class template "Foam::Hash" is missing
const HashTable<AnyType, Key, Hash>& rhs
^
Any suggestions?

Greetings Felix
Hi,
I'm having the same problem with Icc 10.1.11. Did you find a solution? Is there anyone else who have solved this?

Regards
David
segersson is offline   Reply With Quote

Old   November 1, 2009, 00:15
Default
  #16
Super Moderator
 
Takuya OSHIMA
Join Date: Mar 2009
Location: Niigata City, Japan
Posts: 518
Blog Entries: 1
Rep Power: 11
7islands is on a distinguished road
Hi Felix, David,
Here's what I have suggested as a concept of what should be fixed when I was asked for help abut the compilation error by my colleague.
Code:
namespace X {
  template<class T1, class T2> class A
  { template<class T3> void func(const A<T3, T2>&); };

  template<class T4> class T2 {};
}

// error - current OF code
template<class T1, class T2> template<class T3>
void X::A<T1, T2>::func(const A<T3, T2>&) {}

// ok - suggested fix
template<class T1, class T5> template<class T3>
void X::A<T1, T5>::func(const A<T3, T5>&) {}
I heard from him that this concept worked, but some compiler options had to be tweaked furthermore (a couple of preprocessor symbol definitions were required) in wmake rules in order to get everything compiled.

Takuya
7islands is offline   Reply With Quote

Old   November 1, 2009, 11:11
Default
  #17
Member
 
David Segersson
Join Date: Mar 2009
Posts: 39
Rep Power: 8
segersson is on a distinguished road
Many thanks!
I'll give it a try.

David
segersson is offline   Reply With Quote

Old   November 24, 2009, 04:10
Default
  #18
Senior Member
 
Fabian Schlegel
Join Date: Apr 2009
Location: Dresden, Germany
Posts: 180
Rep Power: 8
fs82 is on a distinguished road
Hello David,

I get the same error but I am not able to find the code lines which Takuya suggested to fix. So how do you solve the problem?

Error:

/work/home6/fschleg/Source/OpenFoam/OpenFOAM-1.6.x/src/OpenFOAM/lnInclude/HashTable.C(459): error: argument list for class template "Foam::Hash" is missing
const HashTable<AnyType, Key, Hash>& rhs
^

/work/home6/fschleg/Source/OpenFoam/OpenFOAM-1.6.x/src/OpenFOAM/lnInclude/HashTable.C(457): error: no instance of overloaded function "Foam::HashTable<T, Key, Hash>::erase" matches the specified type
Foam::label Foam::HashTable<T, Key, Hash>::erase

I try to compaile the OpenFoam 1.6.x version with Icc and a system specific MPI.

thx
Fabian
fs82 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with installing OpenFOAM 1.6 su_junwei OpenFOAM Installation 8 September 10, 2009 12:54
Problems Installing OF 1.6 32 bit bucksfan OpenFOAM Installation 19 August 4, 2009 01:36
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25
OpenFOAM Debian packaging current status problems and TODOs oseen OpenFOAM Installation 9 August 26, 2007 13:50
Problems installing OpenFoam on a 64bit machine jango OpenFOAM Installation 1 June 4, 2007 14:53


All times are GMT -4. The time now is 11:56.