CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Random machine freezes when running several OpenFoam jobs simultaneously (http://www.cfd-online.com/Forums/openfoam-installation/67829-random-machine-freezes-when-running-several-openfoam-jobs-simultaneously.html)

2bias August 27, 2009 12:00

Random machine freezes when running several OpenFoam jobs simultaneously
 
Dear Foamers,

I am experiencing random machine freezes when running several (>6) OpenFoam processes on an 8-kernel computer (two quad-core processors) and I cannot figure out why this is happening. Maybe someone has had the same experience or an idea what might be going on.

A little background:

a) When I start > 6 OpenFOAM processes simultaneously the system completely freezes between 1 and 30 minutes later. This happens both when I run a parallel job or several individual jobs.
("Freeze" means no keyboard entry is accepted and the mouse doesn't move - I cannot even change to the basic shell with "ctrl-alt-F1" and no connection via network is possible.)

b) I am not observing this behavior with any other program (in particular parallel jobs in Mathematica and Comsol run for >12 hours using all 8 system cores without problems)

c) In particular I have been using icoFoam and simpleFoam as well as self compiled variants of these which also solve a scalar equation.

d) The same problem occurs under OpenSUSE 11.0 and the enterprise version SLES10-SP2.

e) I could reproduce the behavior with OpenFoam versions 1.5, 1.6 and also 1.3.

f) The jobs I used are not particularly memory intensive, so no wild swapping is going on.

g) Running only a few jobs works fine...

The computer I am using has two quad-core Intel-Xeon X5570 CPUs and 12 GB of RAM. I have been using the pre-compiled OpenFOAM binaries as downloaded from sourceforge (apart from the two customized solvers).

Any suggestions on how to overcome the problem are greatly appreciated!

Thanks,
Tobias Baier

mhassani July 2, 2010 04:55

I have the same problem, when I edit color map or legends. how I can kill the process when the keyboard does not function. If I wait, does it differ? I have not waited more than 10 min. I don't know if I wait more it gets out of the freeze condition

gschaider July 2, 2010 06:33

Quote:

Originally Posted by mhassani (Post 265405)
I have the same problem, when I edit color map or legends. how I can kill the process when the keyboard does not function. If I wait, does it differ? I have not waited more than 10 min. I don't know if I wait more it gets out of the freeze condition

ssh in from another machine. If that doesn't work you have a serious problem

No idea about the original problem

wyldckat July 2, 2010 06:34

Greetings mhassani,

You're experiencing problems with ParaView, not OpenFOAM in particular.
Quote:

Originally Posted by mhassani
I have the same problem, when I edit color map or legends. how I can kill the process when the keyboard does not function. If I wait, does it differ? I have not waited more than 10 min. I don't know if I wait more it gets out of the freeze condition

That usually happens when ParaView is not built with a valid Qt library version. Try downloading and using the official ParaView build: http://www.paraview.org/paraview/res.../software.html

Best regards,
Bruno

niklas July 2, 2010 06:38

are you running the job over a network disk?

is it the same when you run them under /scratch?
is it the same when your foam installation is under /scratch?

N

2bias July 2, 2010 07:40

Hi mhassani,

I never found out what really was the reason for my system hangups, but in the end concluded that is was most likely a hardware problem and that it was unrelated to OpenFOAM (I also occasionally got hangups when using some other software heavily).

Anyway, I believe you are experiencing the same problem but most likely for some different reason, since in particular you seem to get a hangup while using Paraview. Have you tried using "ctrl-alt-F1" to switch to a basic shell? If that still works, you might be able to abort paraview from there...

Best,
Tobias


All times are GMT -4. The time now is 04:21.