CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM-1.6 install cookbook

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   December 15, 2009, 20:32
Default
  #201
New Member
 
Jon Mita
Join Date: Nov 2009
Posts: 8
Rep Power: 7
mstfl is on a distinguished road
Wolle and Bruno, it was a execute permission problem and is fine now.

Thanks!
Jon
mstfl is offline   Reply With Quote

Old   December 16, 2009, 14:35
Default
  #202
Senior Member
 
akidess's Avatar
 
Anton Kidess
Join Date: May 2009
Location: Delft, Netherlands
Posts: 919
Rep Power: 17
akidess will become famous soon enough
Quote:
Originally Posted by fivos View Post
So what I did is to install OpenMPI again, at a different folder, configured it properly and linked it with my compilers and added it to PATH and the LD_LIBRARY_PATH. Also in order to avoid conflicts with the first OpenMPI installation (made for OpenFOAM) I commented line 105 at bashrc located at .../OpenFOAM/OpenFOAM-1.6.x/etc/.
This setup allows me to compile and run my programs but I can't run OpenFoam solvers in parallel. In order to run in parallel OpenFoam I have to un-comment the aforementioned line in bashrc at .../OpenFOAM/OpenFOAM-1.6.x/etc/.

Is there an easier way to do that (swithcing OpenMPI installations) without needing to comment/un-comment lines in bashrc and the consequent sourcing of bashrc?
Yes, there is. Instead of always including the OpenFOAM .bashrc into your system .bashrc, add the following line:

alias startFoam=". $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc"

Now, when you want to use OpenFOAM, just execute the command "startFoam" and the file will be sourced and the necessary settings should be applied.
akidess is offline   Reply With Quote

Old   December 16, 2009, 17:23
Default
  #203
Senior Member
 
Phoevos
Join Date: Mar 2009
Posts: 102
Rep Power: 8
fivos is on a distinguished road
Thanks akidess it seems to be a good idea.
fivos is offline   Reply With Quote

Old   December 17, 2009, 17:05
Default
  #204
New Member
 
Brian C
Join Date: Dec 2009
Posts: 9
Rep Power: 7
Caltech Brian is on a distinguished road
Quote:
Originally Posted by Wolle View Post
Hi all,

I did as you told me and started all over again. Only modification was the git-source. Still no luck. The same compilation error occurs just from the start on.

By the way: it seems, that the problem is very close to the one described by Achim here:

http://www.cfd-online.com/Forums/ope...tml#post237867

And concerning the answer to Achims posting by akidess: I installed a brand new Xubuntu 9.04 yesterday and checked the RAM by the means of a complete Memtest86 run... no errors occured.

Cheers
Wolle
Wolle,

Did you ever get this fixed? I have the same problem: "internal compiler error" when trying to make wmkdep.

Brian
Caltech Brian is offline   Reply With Quote

Old   December 17, 2009, 17:20
Default
  #205
New Member
 
Brian C
Join Date: Dec 2009
Posts: 9
Rep Power: 7
Caltech Brian is on a distinguished road
Quote:
Originally Posted by af631717 View Post
Hi,

i often used the skript and it always worked well even with Debian 5. But on one computer the following error message comes:

gcc -m32 -Wall -O3 -fPIC dirToString.c -o /home/timo/OpenFOAM/OpenFOAM-1.6.x/wmake/bin/linuxGcc/dirToString
flex wmkdep.l
gcc -m32 -Wall -O3 -fPIC lex.yy.c -o /home/timo/OpenFOAM/OpenFOAM-1.6.x/wmake/bin/linuxGcc/wmkdep
lex.yy.c:1393: warning: ‘yyunput’ defined but not used
lex.yy.c:1436: warning: ‘input’ defined but not used
wmkdep.l: In function ‘yy_scan_bytes’:
wmkdep.l:463: internal compiler error: Ungültiger Maschinenbefehl
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make: *** [/home/timo/OpenFOAM/OpenFOAM-1.6.x/wmake/bin/linuxGcc/wmkdep] Fehler 1
++ '[' -n '' ']'
++ '[' -n '' ']'
++ '[' -n '' ']'
++ '[' -n '' ']'
++ '[' -n '' ']'
++ cd malloc
++ ./Allwmake
+ wmake libso hoard
/bin/sh: /home/timo/OpenFOAM/OpenFOAM-1.6.x/wmake/bin/linuxGcc/wmkdep: Datei oder Verzeichnis nicht gefunden

Any hints?
A.
Was it really your machine's RAM? I get an identical error and so did another user. Did you ever resolve the error?
Caltech Brian is offline   Reply With Quote

Old   December 18, 2009, 03:20
Default
  #206
Member
 
Wolfram Kretzschmar
Join Date: Dec 2009
Posts: 71
Rep Power: 7
Wolle is on a distinguished road
I'm sorry, but no, I haven't solved that issue yet.

As for me, I continue using the binaries until I get the first useful results for my project. If they're showing up, I'm going to get back to building my own version again.

But to answer your question: For OpenFoam I set up a completely new Xubuntu 9.04. As always when I set up a new OS, I checked the RAM with Memtest86+ just a few hours prior to the compiler error occurrence and no RAM errors occured while testing. So I don't think, that it's a memory issue.

At the moment I see 2 possible reasons:
1. I use Xubuntu 9.04 instead of Ubuntu at the moment. Next time I will use Ubuntu 9.10 again. What system are you using and on what machine?
2. Maybe LOCALES settings? In other threads, you can read about scripting issues with LOCALES settings that differ from English. As the compiler error occurs on my and Achims machine (and we're obviously both German speaking), I could imagine this as a possible reason - though it should not be... Maybe the programmers simply didn't care much about that? I have to admit: This is a very very very very vague guess!

Cheers
Wolle
Wolle is offline   Reply With Quote

Old   December 18, 2009, 11:44
Default
  #207
New Member
 
Brian C
Join Date: Dec 2009
Posts: 9
Rep Power: 7
Caltech Brian is on a distinguished road
Wolle,

I am running Ubuntu 9.04 (not Xubuntu). It is a fresh install just for the purpose of running OpenFOAM. My native language (Ubuntu and personal) is English. I am not expecting that to be the problem.

I couldn't find a package to install for Ubuntu using Synaptic. You must have found one for Xubuntu. Where did you find it?

Brian
Caltech Brian is offline   Reply With Quote

Old   December 20, 2009, 09:51
Default
  #208
New Member
 
Join Date: Dec 2009
Posts: 1
Rep Power: 0
al3xand3r is on a distinguished road
I got a problem in my OF installation. Reading all threads I didn't find what I was looking for. The most similar case is described by Aurel in the thread #41. But he had 2 critical errors, I got just his 2nd one. It's the same

First I chose to install from the binary file. I followed the wiki from 1.3 paragraph that should be my case. I really would like to avoid to compile all the files! If possible!
I am using Ubuntu 9.10 on 32bit machine.

After downloading files, unpacking them in my /home/gabriele/OpenFOAM/ directory I got this:

adding this line to the end of my /home/gabriele/.bashrc file
Code:
. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
typing
Code:
. $HOME/.bashrc
in the console and this is the result:
Code:
> . $HOME/.bashrc
>
So far it seems ok.
But when I run the test installation typing:
Code:
gabriele@gabriele-laptop:~/OpenFOAM/OpenFOAM-1.6/bin$ foamInstallationTest
this is the result:
Code:
Executing /home/gabriele/OpenFOAM/OpenFOAM-1.6/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell:              bash
Host:               gabriele-laptop
OS:                 Linux version 2.6.31-16-generic
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid      Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/gabriele/OpenFOAM                  yes       yes
$WM_PROJECT_USER_DIR /home/gabriele/OpenFOAM/gabriele-1.6     no        no
$WM_THIRD_PARTY_DIR  /home/gabriele/OpenFOAM/ThirdParty-1.6   yes       yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR      /home/gabriele/OpenFOAM/OpenFOAM-1.6     yes  yes  yes

$FOAM_APPBIN         ...M-1.6/applications/bin/linuxGccDPOpt  no        yes
$FOAM_SITE_APPBIN    .../OpenFOAM/site/1.6/bin/linuxGccDPOpt  no        no
$FOAM_USER_APPBIN    ...e-1.6/applications/bin/linuxGccDPOpt  no        no
$WM_DIR              ...gabriele/OpenFOAM/OpenFOAM-1.6/wmake  yes  yes  yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN         ...nFOAM/OpenFOAM-1.6/lib/linuxGccDPOpt  no        yes
$FOAM_SITE_LIBBIN    .../OpenFOAM/site/1.6/lib/linuxGccDPOpt  no        no
$FOAM_USER_LIBBIN    ...nFOAM/gabriele-1.6/lib/linuxGccDPOpt  no        no
$MPI_ARCH_PATH       ...penmpi-1.3.3/platforms/linuxGccDPOpt  yes  yes  yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version   Location 
-------------------------------------------------------------------------------
gcc      4.3.3     ...nFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux/bin/gcc
gzip     1.3.12    /bin/gzip                                                
tar      1.22      /bin/tar                                                 
icoFoam           
WARNING:  Conflicting installations:
          OpenFOAM settings        : /home/gabriele/OpenFOAM/OpenFOAM-

1.6/applications/bin/linuxGccDPOpt/icoFoam
          current path             : 
          CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult 
the installation guide for trouble shooting.
So my questions are:

1) What's wrong?
2) What can I do to fix it?
3) Is it necessary to compile the files for my installation? I mean following the 1.2 paragraph
of the wiki? such as in "cookbook"??

Consider me I am not expert in linux but I need to use CFD and this is the best opensource
solution I found out!

Thanks you for your answer.
al3xand3r is offline   Reply With Quote

Old   December 20, 2009, 23:05
Default openfoam installation
  #209
New Member
 
Prashanth
Join Date: Nov 2009
Posts: 6
Rep Power: 7
prashanthreddyh is on a distinguished road
Hi MadsR,

Thank you so much. I downloaded the script and successfully executed it. Subsequently I have tested openfoam installation and it is working great.

Prashanth




QUOTE=MadsR;228850]Hi there.

I am not sure if this helps anyone, but for what it's worth, I thought I'd share how I install OpenFOAM on a fresh Ubuntu 9.04 system in a somewhat fool-proof way...By installing I mean real install with compiling, not "only" downloading of binaries.

I have previously spent quite some time, installing OpenFOAM, so I was trying to simplify and organise the process. I like to bake cakes, so I'll put it in a cookbook way if that's okay with you.

1. you need to have a Ubuntu 9.04 system running (or a similar apt-get enabled distro)
2. you need to be logged in as the user you want to be using OF as (not just using su)
3. you need to be allowed to run the sudo command
4. download my install-script found here
5. read through the script and see if you find anything upsetting (please notify me if you do)
6. either - for the not so faint-hearted - run the script "automatically" by typing . ./installOF OR manually copy-paste each line from the script to your command-line and execute, a bit safer, the installation process step-wise
7. you could bake a cake now, as step 6 probably will take a really long time
8. enjoy OpenFOAM, a cup of coffee and your cake
9. if everything above worked out, you can actually maintain your OpenFOAM install by typing git pull in the OpenFOAM-1.6.x-directory followed by ./Allwmake

The script is "verision 1.0" - please use this at your own risk and don't hold anything against me if your summer-vacation pictures are deleted (actually if this happens I really wonder how my script could have caused that )

Let me know if this is useless, or if it helps you out.

Cheers,
Mads[/QUOTE]
prashanthreddyh is offline   Reply With Quote

Old   December 21, 2009, 02:14
Default
  #210
Member
 
Wolfram Kretzschmar
Join Date: Dec 2009
Posts: 71
Rep Power: 7
Wolle is on a distinguished road
Hi Brian,

Quote:
Originally Posted by Caltech Brian View Post
I couldn't find a package to install for Ubuntu using Synaptic. You must have found one for Xubuntu. Where did you find it?
Have a look here:

http://www.opencfd.co.uk/openfoam/do....html#download

Chose your platform and then download all 4 archives (OF Source pack, OF binary pack (double prec), Third party source, Third party binary). The unpack and follow README file. It's some 10 steps to get this working, not a big thing, really. And don't get confused with the package names... just because it's named "source pack" it doesn't mean, you'll have to compile it!

Cheers
Wolle
Wolle is offline   Reply With Quote

Old   December 21, 2009, 03:14
Default
  #211
New Member
 
ligang wang
Join Date: Dec 2009
Posts: 5
Rep Power: 7
lglq is on a distinguished road
HI, Mads,
I am really a beginner of linux, and have tried the way on the web of OpenFOAM, but I found it doesn't work.
Hope yours can help a me out of my troubles!
Best wishes!
ligang
lglq is offline   Reply With Quote

Old   December 21, 2009, 20:09
Default 2 critical errors
  #212
New Member
 
ligang wang
Join Date: Dec 2009
Posts: 5
Rep Power: 7
lglq is on a distinguished road
HI,madrs,
I just completed the installation using your method, but there are two critical errors reported. This situation is the same with the way on the OF website. So, I dont know why. I followed the tips carefully. Anyway, please help me! Thanks a lot!

ligang


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: ubuntu
OS: Linux version 2.6.31-14-generic
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/lglq/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/lglq/OpenFOAM/lglq-1.6.x no no
$WM_THIRD_PARTY_DIR /home/lglq/OpenFOAM/ThirdParty-1.6.x yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/lglq/OpenFOAM/OpenFOAM-1.6.x yes yes yes

$FOAM_APPBIN ...1.6.x/applications/bin/linuxGccDPOpt yes yes yes
$FOAM_SITE_APPBIN ...penFOAM/site/1.6.x/bin/linuxGccDPOpt no no
$FOAM_USER_APPBIN ...1.6.x/applications/bin/linuxGccDPOpt no no
$WM_DIR /home/lglq/OpenFOAM/OpenFOAM-1.6.x/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.6.x/lib/linuxGccDPOpt yes yes yes
$FOAM_SITE_LIBBIN ...penFOAM/site/1.6.x/lib/linuxGccDPOpt no no
$FOAM_USER_LIBBIN ...penFOAM/lglq-1.6.x/lib/linuxGccDPOpt no no
$MPI_ARCH_PATH ...penmpi-1.3.3/platforms/linuxGccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.3
User version : 4.4.1
Minimum required: 4.3.1

gcc 4.4.1
WARNING: Conflicting installations:
OpenFOAM settings : /home/lglq/OpenFOAM/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.22 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/lglq/OpenFOAM/OpenFOAM-1.6.x/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.
lglq is offline   Reply With Quote

Old   December 21, 2009, 20:36
Default
  #213
New Member
 
ligang wang
Join Date: Dec 2009
Posts: 5
Rep Power: 7
lglq is on a distinguished road
good morning, madsr,
My problem seems different from others, when i run this command

. ~/OpenFOAM/OpenFOAM-1.6.x/etc/bashrc
There comes this warning:
Warning in /home/lglq/OpenFOAM/OpenFOAM-1.6.x/etc/settings.sh:
Cannot find /home/lglq/OpenFOAM/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux installation.
Please install this compiler version or if you wish to use the system compiler,
change the 'compilerInstall' setting to 'System' in this file

So, with the next tips, after allmake, two ctitical errors were reported!
Hope you can help me!
ligang
lglq is offline   Reply With Quote

Old   December 22, 2009, 03:20
Default
  #214
New Member
 
Join Date: Nov 2009
Posts: 4
Rep Power: 7
checkpalm is on a distinguished road
lglq - concerning the first issue - version conflict - change OpenFOAM to System inside ~/OpenFOAM/OpenFOAM-1.6.x/etc/settings.sh ('compilerInstall' setting)
about the second issue - is "flex" installed on your machine?
checkpalm is offline   Reply With Quote

Old   December 22, 2009, 04:03
Default
  #215
Senior Member
 
MadsR's Avatar
 
Mads Reck
Join Date: Aug 2009
Location: Copenhagen, Denmark
Posts: 175
Rep Power: 8
MadsR is on a distinguished road
Hi Ligang.

First, is it Ubuntu 9.04 or 9.10? Is it 64-bit or 32-bit?

Also are the directories present? do an ls ~/OpenFOAM and check if ThirdParty-1.6.x is there and if the link ThirdParty-1.6 has been created. If not remove all and rerun the script.

The "system fix" noted by checkpalm can resolve some errors, but it shouldn't really be necessary. Flex should also be installed by the script.

Are you running a bash shell? (try doing a echo $SHELL)

A last "quick" fix (if you're just waiting around) is to remove the entire OpenFOAM directory and retry (rm -rf ~/OpenFOAM - careful with this command it's "powerful").

Keep on posting your progress!

/Mads
__________________
Online free airfoil-mesher for OpenFOAM here
MadsR is offline   Reply With Quote

Old   December 22, 2009, 07:22
Default
  #216
New Member
 
ligang wang
Join Date: Dec 2009
Posts: 5
Rep Power: 7
lglq is on a distinguished road
Hi, MadsR,
Thanks for your attention!
My OS is xp, but I use VMware to install a linux OS. which is Ubuntu 9.10, 32-bit.
I check the directories and find that OpenFOAM and the link have been created. I am running a bush shell.


ok, I removed the entire OpenFOAM and retry it again. And I will report the result here.
Best wishes!
Ligang
lglq is offline   Reply With Quote

Old   December 22, 2009, 08:13
Default
  #217
New Member
 
ligang wang
Join Date: Dec 2009
Posts: 5
Rep Power: 7
lglq is on a distinguished road
Hi, MadsR,
Thanks for your attention.
I just tried another script below. And it works, so maybe I just learn to use it. http://energy.tf.itb.ac.id/index.php...904?format=pdf
Anyway, really appreciate your help.
Wish you best.
Ligang
lglq is offline   Reply With Quote

Old   December 22, 2009, 08:30
Default
  #218
Senior Member
 
MadsR's Avatar
 
Mads Reck
Join Date: Aug 2009
Location: Copenhagen, Denmark
Posts: 175
Rep Power: 8
MadsR is on a distinguished road
Hi Ligang.

The "script" you refer to "installs" the binary version of OpenFOAM. This has been proposed as a "fix" earlier on in this thread, but it's actually not at all what we're trying to do with our script... ;-)

So, it's not really the same thing - it's installing OpenFOAM as a precompiled binary while we are providing a way of compiling OpenFOAM on your platform.

/Mads
__________________
Online free airfoil-mesher for OpenFOAM here
MadsR is offline   Reply With Quote

Old   December 23, 2009, 11:36
Default Still Struggling with wmkdep Compile on Ubuntu 9.04
  #219
New Member
 
Brian C
Join Date: Dec 2009
Posts: 9
Rep Power: 7
Caltech Brian is on a distinguished road
Hi,

I am still getting an internal compiler error within the first couple lines of the Install Script on Ubuntu 9.04.

> flex wmkdep.l [finishes properly]
> gcc ... lex.yy.c [dies with an internal compiler err]

There seem to be several people with the same problem with no resolution. All of us have fresh installs of Ubuntu. All of us used the MadsR install script, which gets new (?) versions of all OpenFOAM, flex, ...

We are all using the recommended version of gcc.

Any idea where this error is coming from? Do we have environmental variables set wrong? Permissions (unlikely)? One user even suggested language settings (I am in English, he was in German).

Does everybody that compiles successfully get the warning regarding functions that are defined but not used? Is the problem in flex or in the compiler?

Brian


flex wmkdep.l
gcc -m32 -Wall -O3 -fPIC lex.yy.c -o /home/timo/OpenFOAM/OpenFOAM-1.6.x/wmake/bin/linuxGcc/wmkdep
lex.yy.c:1393: warning: ‘yyunput’ defined but not used
lex.yy.c:1436: warning: ‘input’ defined but not used
wmkdep.l: In function ‘yy_scan_bytes’:
wmkdep.l:463: internal compiler error
Caltech Brian is offline   Reply With Quote

Old   December 24, 2009, 10:15
Default
  #220
Senior Member
 
akidess's Avatar
 
Anton Kidess
Join Date: May 2009
Location: Delft, Netherlands
Posts: 919
Rep Power: 17
akidess will become famous soon enough
Brian, I'm not sure if this is something we can help you with, see http://stason.org/TULARC/os/linux-fa...ler-error.html

If you have the time, you could try compiling the newest version of gcc, and then using that binary to compile OpenFOAM and see if the error dissapears. If you just want to use OpenFOAM, I suggest using the binaries instead of compiling from source.
akidess is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
install OpenFoam 1.6 by building source: how? niudie OpenFOAM Installation 13 April 26, 2011 00:48
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43
install openfoam 1.6 on opensuse 11.0 andresbh OpenFOAM Installation 8 September 30, 2009 00:48
Install openFOAM 1.6 on debian 32bit - blockMesh: command not found fossy OpenFOAM Installation 1 August 28, 2009 04:06
Install of OpenFOAM 1.6 Error 1 Error 2 & run tutorial potac OpenFOAM Installation 3 August 27, 2009 09:04


All times are GMT -4. The time now is 14:33.