CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

installation OpenFOAM

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 26, 2009, 10:53
Default installation OpenFOAM
  #1
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi !
please can you help me to install the OpenFOAM in the fedora linux distribution
thank you
lyna is offline   Reply With Quote

Old   October 26, 2009, 13:55
Default
  #2
Senior Member
 
sega's Avatar
 
Sebastian Gatzka
Join Date: Mar 2009
Location: Frankfurt, Germany
Posts: 729
Rep Power: 12
sega is on a distinguished road
What is the problem?
Please be more specific or you won't get any answers.
__________________
Schrödingers wife: "What did you do to the cat? It's half dead!"
sega is offline   Reply With Quote

Old   October 27, 2009, 06:29
Default
  #3
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi
first can I used the fedora distribution instead of the ubuntu or suse distributions
to install OpenFOAM code
thank you
lyna is offline   Reply With Quote

Old   October 28, 2009, 03:57
Default
  #4
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lynda,

Yes it is possible, my OpenFOAM is very happy on Fedora . Here are some basic instructions that worked for me (it is for OpenFOAM-1.5, but works also for 1.6, just the file names are different). Hope that solves your trouble.

Cheers,

Gijsbert
gwierink is offline   Reply With Quote

Old   November 2, 2009, 07:05
Default
  #5
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijsbert
Mon .bashrc is in /root /.bashrc directory.
When I copy the following line:
/ home/OpenFOAM/OpenFOAM-1.6/etc/bashrc
in / root/.bashrc file, I have a problem when I turn on my PC or when I open a new terminal because I find the following error message:
Permission not granted (Permission non accordée)
please help me
lyna is offline   Reply With Quote

Old   November 2, 2009, 07:19
Default
  #6
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lynda,

You need to put the line
Code:
. $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
in $HOME/.bashrc (in case you don't know, "$HOME" is another way to put the path to your user home directory, in my case /home/gijsbert/). This is your user .bashrc, not root's .bashrc . Just open a terminal and type
Code:
gedit .bashrc &
and paste the line above in it (notice the "." at the beginning). Save and close gedit and source the terminal with (notice the "." at the beginning again)
Code:
. $HOME/.bashrc
or just close it and open an new terminal.

Hope this helps.

Regards,

Gijsbert
gwierink is offline   Reply With Quote

Old   November 2, 2009, 07:48
Default
  #7
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijsbert
I did all the steps in your message, I've copied a terminal to see better things

terminal
bash: ./root/OpenFOAM/OpenFOAM-1.6/etc/bashrc: Aucun fichier ou répertoire de ce type
[root@localhost ~]# .$HOME/.bashrc
bash: ./root/.bashrc: Aucun fichier ou répertoire de ce type
[root@localhost ~]# .$HOME/.bashrc
bash: ./root/.bashrc: Aucun fichier ou répertoire de ce type
[root@localhost ~]#



thank you
lyna is offline   Reply With Quote

Old   November 2, 2009, 08:30
Default
  #8
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lynda,

Ok, first of all you need to be in your user account in the terminal, not in root. It seems you are root
Quote:
[root@localhost ~]#
It is better to use your user account (type "exit" to get out of the root account in the terminal). Also, there needs to be a space between "." and "$HOME/....", so not
Quote:
.$HOME/.bashrc
, but
Code:
. $HOME/.bashrc
Let me know how it goes.

Cheers, Gijs
gwierink is offline   Reply With Quote

Old   November 2, 2009, 11:19
Default
  #9
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijsbert

I opened another session and I redid all, but I had the same messages in
the terminal, it may be necessary to copy the OpenFOAM directory in my file LTPMP
is not it?
Here's what I got :

terminal
bash: /home/LTPMP/OpenFOAM/OpenFOAM-1.6/etc/bashrc: Aucun fichier ou répertoire de ce type
[LTPMP@localhost ~]$ . $HOME/.bashrc
bash: /home/LTPMP/OpenFOAM/OpenFOAM-1.6/etc/bashrc: Aucun fichier ou répertoire de ce type
[LTPMP@localhost ~]$

thank you
lyna is offline   Reply With Quote

Old   November 2, 2009, 11:36
Default
  #10
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lynda,

Did you install OF as root? If so, it is probably located in /root/OpenFOAM/. It is better to install OF in your user account. In your case, I'm afraid, you need to reinstall OF in your user account, i.e. do the whole installation procedure as [LTPMP@localhost ~]$. And to keep things tidy I would delete the OpenFOAM directory from root.

Cheers, Gijsbert
gwierink is offline   Reply With Quote

Old   November 9, 2009, 10:56
Default
  #11
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijsbert

I do not have Qt installed, I tried on the two methods listed in your''....................'' yum install or download package qt-x11-opensource-src-4.3.5.tar.gz, but it did not work. I downloaded this package and I followed the instructions through step 3
make when I typed in my terminal I have the following result;

[root@localhost qt-x11-opensource-src-4.3.5]# make
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.

THANK YOU
lyna is offline   Reply With Quote

Old   November 9, 2009, 12:14
Default
  #12
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lyna,

So
Code:
yum groupinstall "X Software Development"
did not work?

Did you do
Code:
./configure
after you unpacked qt?
And then
Code:
gmake
followed by
Code:
gmake install
?

Cheers, Gijs

PS If you need to re-make qt again for some reason you can clean by
Code:
gmake confclean
gwierink is offline   Reply With Quote

Old   November 11, 2009, 10:59
Default
  #13
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijsbert

I installed QT, I tried to run the sample "cavity" I wanted to show the mesh and found the results, I typed "paraFoam" ParaView window opens but I do not knew how to get certified in Figure 6.1 User Guide (p U-160)

thank you
lyna is offline   Reply With Quote

Old   November 12, 2009, 06:00
Default
  #14
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
I am sorry, Lyna, but I do not understand what you mean. Did you solve the problem? If not, what is the issue?
gwierink is offline   Reply With Quote

Old   November 12, 2009, 08:59
Default
  #15
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijibert
yes,I solved the « qt-x11-opensource-src-4.3.5 »problem.
I want to rebuild the paraview ( the next step of the 'qt-x11-opensource-src-4.3.5') unfortunately, I can't run the last step (builparaview) and even (makeparaview)
lyna is offline   Reply With Quote

Old   November 12, 2009, 11:55
Default
  #16
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lynda,

It seems that you are using OpenFOAM-1.6, am I right? If so, you need to do the following:
Code:
cd $WM_THIRD_PARTY_DIR

rm -rf paraview-3.6.1/platforms

makeParaView
as explained in section 7 of the README file. What is the terminal output if you try makeParaView?

It may be that you need to specify the location of Qt and Mesa in lines 37-60 of $HOME/OpenFOAM/ThirdParty-1.6/makeParaView. Mine looks like this:

Code:
# User options:
# ~~~~~~~~~~~~~

# MPI support:
withMPI=false
MPI_MAX_PROCS=32

# Python support:
# note: script will try to determine the appropriate python library.
#       If it fails, specify the path using the PYTHON_LIBRARY variable
withPYTHON=false
PYTHON_LIBRARY=""
# PYTHON_LIBRARY="/usr/lib64/libpython2.6.so.1.0"

# MESA graphics support:
withMESA=false
MESA_INCLUDE="/usr/include/GL"
MESA_LIBRARY="/usr/lib64/libOSMesa.so"

# extra QT gui support (useful for re-using the installation for engrid)
withQTSUPPORT=true

# Set the path to the Qt-4.3.? qmake if the system Qt is other than this version
QMAKE_PATH=""
If you need to know the qmake path, just type
Code:
which qmake
Cheers,

Gijs
gwierink is offline   Reply With Quote

Old   November 16, 2009, 06:49
Default
  #17
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijibert

Yes, you're right. I use OpenFOAM-1.6.
I have problem with the command « makeParaView »; the output terminal don't find this command,
Please, I don't know in what file are the 37 and 60 lines and how to specify Qt and Misa.


Thank you
lyna is offline   Reply With Quote

Old   November 17, 2009, 03:34
Default
  #18
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 10
gwierink is on a distinguished road
Hi Lynda,

First find out where qmake is located by
Code:
which qmake
This will give you the QMAKE_PATH, in my case it is $HOME/tmp/qt-x11-opensource-src-4.3.5/bin/qmake. Then, open the file makeParaView with
Code:
gedit $HOME/OpenFOAM/ThirdParty-1.6/makeParaView &
and check that the openGL libraries (MESA), python, and qmake are the right paths (make changes if needed and save). Mine looks like this (line 37-60):
Code:
# User options:
# ~~~~~~~~~~~~~

# MPI support:
withMPI=false
MPI_MAX_PROCS=32

# Python support:
# note: script will try to determine the appropriate python library.
#       If it fails, specify the path using the PYTHON_LIBRARY variable
withPYTHON=false
PYTHON_LIBRARY=""
# PYTHON_LIBRARY="/usr/lib64/libpython2.6.so.1.0"

# MESA graphics support:
withMESA=false
MESA_INCLUDE="/usr/include/GL"
MESA_LIBRARY="/usr/lib64/libOSMesa.so"

# extra QT gui support (useful for re-using the installation for engrid)
withQTSUPPORT=true

# Set the path to the Qt-4.3.? qmake if the system Qt is other than this version
QMAKE_PATH=""
gwierink is offline   Reply With Quote

Old   November 18, 2009, 04:37
Default
  #19
Member
 
lynda
Join Date: Oct 2009
Posts: 48
Rep Power: 8
lyna is on a distinguished road
Hi Gijibert

after the change the path in to lines (37-60), shows in the following lines :

code ;
************************************************** ***************************************
# MPI support:
withMPI=false
MPI_MAX_PROCS=32

# Python support:
# note: script will try to determine the appropriate python library.
# If it fails, specify the path using the PYTHON_LIBRARY variable
withPYTHON=false
PYTHON_LIBRARY="/usr/lib64/libpython2.5.so.1.0"
# PYTHON_LIBRARY="/usr/lib64/libpython2.6.so.1.0"

# MESA graphics support:
withMESA=false
MESA_INCLUDE="/usr/include/GL"
MESA_LIBRARY="/usr/lib64/libOSMesa.so.6.5.2"

# extra QT gui support (useful for re-using the installation for engrid)
withQTSUPPORT=true

# Set the path to the Qt-4.3? qmake if the system Qt is other than this version
QMAKE_PATH="/tmp/qt-x11-opensource-src-4.3.5/bin/qmake"
************************************************** ************************************************** **

Because, I find the qmake Mesa and libpython libraries paths, the output terminal is ;

************************************************
[root@localhost ~]# find / -name 'libpython*' -print
/usr/lib/libpython2.5.so
/usr/lib/python2.5/config/libpython2.5.a
/usr/lib/python2.5/config/libpython2.5.so
/usr/lib/libpython2.5.so.1.0
/usr/lib64/libpython2.5.so
/usr/lib64/python2.5/config/libpython2.5.a
/usr/lib64/python2.5/config/libpython2.5.so
/usr/lib64/libpython2.5.so.1.0
/usr/lib64/gnome-vfs-2.0/modules/libpythonmethod.so
[root@localhost ~]# find / -name 'libOSMesa.so*' -print
/usr/lib/libOSMesa.so.6.5.2
/usr/lib/libOSMesa.so.6
/usr/lib64/libOSMesa.so.6.5.2
/usr/lib64/libOSMesa.so.6
************************************************** ***********

I want to rebuild the paraview. unfortunately, I can't run "maKeParaview", the output terminal don't find this command,

thank you
lyna is offline   Reply With Quote

Old   November 18, 2009, 10:06
Default
  #20
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,659
Blog Entries: 39
Rep Power: 99
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hello Lynda,

In Linux, to run scripts from a local folder, usually you have to use "./". For your case:
Code:
./makeParaView
I know, it's a bit weird, but that's how it works.

I hope it finally works. Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Critical errors during OpenFoam installation in OpenSuse 11.0 amscosta OpenFOAM 5 May 1, 2009 14:06
OpenFOAM 1.5 installation on OpenSUSE 11.0 bigphil OpenFOAM Installation 16 April 29, 2009 06:28
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 00:56.