CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problem Installing OF 1.6 Ubuntu 9.10 (64 bit) - How to use GCC 4.4.1

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 24, 2010, 11:53
Default Same wmake error in Arch Linux
  #21
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Dear friends,

I am trying to get OpenFOAM-1.6.x to run on my laptop with Arch Linux (32 bit). OpenFOAM compiles, foamInstallationTest is happy, and tutorials run. But when I try to recompile a solver (e.g. icoFoam as myIcoFoam) I get an error:
Code:
linuxGccDPOpt/options:6: *** missing separator.  Stop.
wmake error: file 'Make/linuxGccDPOpt/objectFiles' could not be created
I then added the -P flag in OpenFOAM-1.6.x/wmake/rules/linuxGcc/general, cleaned with
Code:
wcleanLnIncludeAll
rmdepall
wcleanAll
rm -rf `find $WM_THIRD_PARTY_DIR/* -name linuxGccDPOpt* | grep -v openmpi`
but still have the same error. Would anyone have an idea? Am I missing some libs or something? Thanks in advance!
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   August 24, 2010, 16:40
Default
  #22
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Gijsbert,

That's odd... what changes did you make to these files:
Code:
Make/files
Make/options
Can you post their contents here?

It's possible that you removed or added a line in the "options" file and didn't add a "\" to the end of it. The character "\", when is the last character in a line, indicates that the "current line is to be continued on the next one". So, it's possible that when you added a line, you either forgot to add "\" at the end; or maybe you did add, but left a space right after it, which will render the "\" useless...

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   August 25, 2010, 03:10
Default
  #23
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi Bruno,

Thanks for your reply. I also read about this "last character should be an '\'" issue and that should be ok. The problem even occured for copied original solvers. What I did overlook was that, when compilerInstall is set to System, OF looks for gcc in /bin/, not in /usr/bin/. In /bin/ (at least in my machine) there was no gcc, so I made a link
Code:
ln -s /usr/bin/gcc /bin/gcc
In retrospect foamInstallationTest did indicate this, I just overlooked it .

So, now solver recompile and some of my own libs compile, but not all. One was complaining about a UList declaration, which should be ok. It compiles on other systems. Perhaps src did not compile correctly because of the gcc issue. At the moment I am recompiling OF with the soft link to gcc in place, let's see if that fixes it.
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   August 25, 2010, 05:26
Default
  #24
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Right, that (the gcc soft link) fixed it. The compile error of our own class seemed to have been caused by an iterator definition. I changed it and now it works. Strange that it compiled just like that on my Scientific Linux desktop ... Anyways, it works . Thanks for your reply, Bruno!
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   May 11, 2011, 07:18
Default
  #25
New Member
 
lazio
Join Date: Apr 2010
Posts: 22
Rep Power: 7
lrunber is on a distinguished road
Hi,
I would just like to add that Bruno's solution i.e. Adding -P option to first line of $(WM_DIR)/rules/linux64Gcc/general
Also worked for OpenFoam-1.5-dev on Ubuntu 11.04
Thanks
lrunber is offline   Reply With Quote

Old   August 23, 2011, 12:31
Default Problem installing 1.6.x in Fedora 14
  #26
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
Hello,

I am trying to install 1.6.x in my fedora 14, the gcc compiler I have is 4.5.1. In the post #7 Bruno mentioned that 1.6.x builds fine for 4.4.? and above. So, I followed exactly what was suggested in posts #7 and #11, leaving the 32 bit part. But it did not compile properly. Please see the attached log files for Allwmake and foamInstallationTest.

Could somebody please respond. Thinking that 1.6.x will install without giving much trouble, I completely removed 1.7.1 which I have been using for some time. I needed 1.6.x to develop some applications related to conjugateHearFoam (which is not available in 1.7.1) and I don't know how to maintain two versions in the same machine, so I had to remove 1.7.1.

I spent all day yesterday to install 1.6.x and failed in all my attempts. Any help will be highly appreciated as I need this very badly for a conference which I am attending in ten days.

Thank you
Attached Files
File Type: gz installtest.tar.gz (989 Bytes, 0 views)
File Type: gz make.log.tar.gz (10.5 KB, 1 views)

Last edited by vetnav; August 23, 2011 at 15:00.
vetnav is offline   Reply With Quote

Old   August 23, 2011, 16:47
Default
  #27
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Naveen,

I had to track you down from OpenFOAM-1.6.x instllation problem to reply to you

As it turns out, I wasn't able to predict the future, as I later came to know: OpenFOAM 1.6.x, 1.7.0 and 1.7.x are not fully prepared to work with gcc-4.5.x - A few days after the first post on that thread, OpenFOAM 1.7.1 and 1.7.x were ready willing and able to build and work with gcc 4.5.0 and above (at least to 4.6.x, AFAIK so far )

If conjugateHeatFoam is in 1.6.x and not 1.7.1, then it was most likely merged into some other solver... let me see if I can find it for you...
Whoooaa, stop it right there!! OpenFOAM 1.6.x is one thing, OpenFOAM 1.6-ext is a whole other!!! And it's 1.6-ext that has conjugateHeatFoam!

You can get 1.6-ext from here: http://openfoam-extend.git.sourcefor...-ext;a=summary - or better yet, follow the instructions from here: Extend Project Release 1.6-ext - post #25
It should build with gcc 4.5.1 without any problems... or at least I hope so.


As for having both versions available on your system, remove/comment any lines related to OpenFOAM that you have in the file "$HOME/.bashrc" and add these instead:
Code:
alias of171='. $HOME/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc'
alias of16ext='. $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'
Then whenever you start a new terminal window or tab, you can choose which environment you want by running of171 or of16ext. Keep in mind that you cannot change OpenFOAM environments when on the same terminal window or tab; this means that if you want to run solvers from both versions at the same time, you'll need two separate terminal windows/tabs for running each one.

Good luck!
Bruno

Last edited by wyldckat; August 23, 2011 at 16:48. Reason: fixed typo...
wyldckat is offline   Reply With Quote

Old   August 23, 2011, 17:20
Default
  #28
Senior Member
 
Joern Beilke
Join Date: Mar 2009
Location: Dresden
Posts: 185
Rep Power: 9
JBeilke is on a distinguished road
"heatTransfer/chtMultiRegionFoam" in v2.0.x should also do the job.
JBeilke is offline   Reply With Quote

Old   August 23, 2011, 20:37
Default
  #29
Member
 
Naveen
Join Date: Feb 2010
Location: Los Angeles
Posts: 65
Rep Power: 7
vetnav is on a distinguished road
@ Bruno

Thank you very much for all the explanation. What an idiot I am to not differentiate between 1.6.x and 1.6-ext. But nothing is straight I tried to install OpenFOAM-1.6-ext. I downloaded the directory using the command given here

http://www.extend-project.de/home/33...16-ext/article

Untarred the folder and ran the system check. After sourcing the bashrc I went into Thirdparty folder and executed AllMake. Then in the top level directory $WM_PROJECT_DIR I ran Allwmake. After building or compiling for more than two hours it gave me errors . More than 24 hours of my patience yielded then and I stopped the compilation process. Please look at the log file and please tell me how can I resolve this issue and install 1.6-ext. Now its almost two days I was just trying to install OpenFOAM.


@ Joern

Thank you very much for the info. I was not aware of it. I will definitely try installing 2.0.x.
Attached Files
File Type: gz make.log.tar.gz (68.1 KB, 3 views)
vetnav is offline   Reply With Quote

Old   August 24, 2011, 16:24
Default
  #30
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Naveen,

Sadly I've never built OpenFOAM 1.6-ext. Ever since I saw how they build the ThirdParty folder, I've steered clear from trying to building it
Using RPM with OpenFOAM is simply unnatural
But I have installed it by using the ready to use Debian packages for Ubuntu, as explained here: OpenFOAM-dev-1.5 or OpenFOAM-1.6-ext under Ubuntu Lucid 10.04 LTS

Anyway, I did tell you to read post #25 in this thread: Extend Project Release 1.6-ext - there you should find a very good instruction list on how to build 1.6-ext.

Another (veeery long) thread about this subject is this one: Error compiling OpenFOAM-1.6-ext - again, since I'm not familiar with it, I don't know any pointers for it

Good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   September 20, 2011, 20:27
Default
  #31
Member
 
Santiago
Join Date: Dec 2009
Posts: 85
Rep Power: 7
gascortado is on a distinguished road
hi Wyldckat, ]

I have the previously mentioned problem:

gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/applications/solvers/my_pisoFSI$ wmake all
linux64GccDPOpt/options:6: *** missing separator. Stop.

I installed OF-1.6-ext as you suggested using the Synaptic package manager and everything works fine. I also verified that the "general" file that is in the rules folder has the edited line and it does. However, when I want to compile anything i get this error. Any idea of what to do??

Thanks man
gascortado is offline   Reply With Quote

Old   September 21, 2011, 14:43
Default
  #32
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Santiago,

Mmm... Without more information, I'm going to have to assume that it's happening the same I saw the other day:
  1. Check this file as an example: https://github.com/OpenFOAM/OpenFOAM...x64Gcc/general
  2. Notice this line:
    Code:
    cpp -traditional-cpp $(GFLAGS)
    In bold is what's necessary for things to get going.
If it still has problems, then I'm going to need to know:
  • Which Ubuntu version are you using?
  • gcc version:
    Code:
    gcc --version
  • cpp version:
    Code:
    cpp --version
  • Just to be certain, you installed 1.6-ext from the cae-team/ppa package repository?
  • A full output log of the build process, if there is more than what you posted here.
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   September 22, 2011, 18:14
Default
  #33
Member
 
Santiago
Join Date: Dec 2009
Posts: 85
Rep Power: 7
gascortado is on a distinguished road
Hi Wyldckat for your help again...

I checked the file OpenFOAM-1.6.x/wmake/rules/linuxGcc/general and it looks like this:

CPP = cpp $(GFLAGS) -P
LD = ld -melf_i386

PROJECT_LIBS = -l$(WM_PROJECT) -ldl

include $(GENERAL_RULES)/standard

include $(RULES)/X
include $(RULES)/c
include $(RULES)/c++


so that "traditional" stuff is missing. I'm using OF-1.6-ext downloaded using Synaptic manager. I cannot modify the file since it says that I'm not the owner.

I have:

gascortado@me257b:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty



gcc --version
gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2

cpp --version
cpp (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2

  • Just to be certain, you installed 1.6-ext from the cae-team/ppa package repository? YES
  • A full output log of the build process, if there is more than what you posted here.
gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/applications/solvers/my_pisoFSI$ wmake all
inux64GccDPOpt/options:6: *** missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created


that is all it says

Any ideas? Thanks again

Also, as a possible related problem, I am able to compile my solver without problems in my other computer (ubuntu 10.10). I tried coping the executable file to this computer and this is what it says:

gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/run/testCase5$ ./Allrunbash: ./Allrun: Permission denied

./Allrun just calls my solver

I also tried to compile my groovyBC folder and I get the a similar message:

gascortado@me257b:~/groovyBC$ wmake all
linux64GccDPOpt/options:13: *** missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created
gascortado is offline   Reply With Quote

Old   September 23, 2011, 14:22
Default
  #34
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Santiago,

Quote:
Originally Posted by gascortado View Post
I cannot modify the file since it says that I'm not the owner.
Run:
Code:
sudo gedit wmake/rules/linuxGcc/general
It should request your own password for activating super user powers then it should open the file in gedit.
More about sudo: http://en.wikipedia.org/wiki/Sudo

Quote:
Originally Posted by gascortado View Post
gcc --version
gcc (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2

cpp --version
cpp (Ubuntu/Linaro 4.5.2-8ubuntu4) 4.5.2
Yep, I figured as much... the "-traditional-cpp" argument should fix the problem.

Quote:
Originally Posted by gascortado View Post
gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/applications/solvers/my_pisoFSI$ wmake all
inux64GccDPOpt/options:6: *** missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created
OK, all still points to needing the missing "-traditional-cpp"...

Quote:
Originally Posted by gascortado View Post
Also, as a possible related problem, I am able to compile my solver without problems in my other computer (ubuntu 10.10).
Ubuntu 10.10 has gcc 4.4.4 (or 4.4.5, not really sure), which doesn't need the option "-traditional-cpp".

Quote:
Originally Posted by gascortado View Post
I tried coping the executable file to this computer and this is what it says:

gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/run/testCase5$ ./Allrunbash: ./Allrun: Permission denied
Mmmm.... my guess is that during the copying process, it lost the file permissions. Did you zip the files or used tar? Probably zip, so the fix would be:
Code:
chown +x Allrun
This will give the file permissions to execute once again.

Quote:
Originally Posted by gascortado View Post
I also tried to compile my groovyBC folder and I get the a similar message:

gascortado@me257b:~/groovyBC$ wmake all
linux64GccDPOpt/options:13: *** missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created
Yep, same problem... missing "-traditional-cpp".

Best regards,
Bruno

Last edited by wyldckat; September 23, 2011 at 14:23. Reason: Ooops.... it's "-traditional-cpp", not just "-traditional"
wyldckat is offline   Reply With Quote

Old   September 23, 2011, 18:41
Default
  #35
Member
 
Santiago
Join Date: Dec 2009
Posts: 85
Rep Power: 7
gascortado is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
Hi Santiago,



Run:
Code:
sudo gedit wmake/rules/linuxGcc/general
It should request your own password for activating super user powers then it should open the file in gedit.
More about sudo: http://en.wikipedia.org/wiki/Sudo

Yep, I figured as much... the "-traditional-cpp" argument should fix the problem.

OK, all still points to needing the missing "-traditional-cpp"...

Ubuntu 10.10 has gcc 4.4.4 (or 4.4.5, not really sure), which doesn't need the option "-traditional-cpp".


Mmmm.... my guess is that during the copying process, it lost the file permissions. Did you zip the files or used tar? Probably zip, so the fix would be:
Code:
chown +x Allrun
This will give the file permissions to execute once again.


Yep, same problem... missing "-traditional-cpp".

Best regards,
Bruno
Ok, Here is what I get when I execute

gascortado@me257b:~$ sudo gedit wmake/rules/linuxGcc/general

(gedit:25084): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.7G1W1V': No such file or directory

(gedit:25084): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

gedit opens a file "general" at /home/gascortado/wmake/rules/linuxGcc but is blank. The actual general file is located at usr/lib/OpenFOAM-1.6-ext/wmake/rules/linuxGcc

Another thing, I tried

gascortado@me257b:~$ chown +x Allrun

and I got:

chown: invalid user: `+x'


Any ideas man? Thanks yet again

gascortado is offline   Reply With Quote

Old   September 23, 2011, 20:58
Default
  #36
lin
Senior Member
 
Hua Zen
Join Date: Mar 2009
Posts: 114
Rep Power: 8
lin is on a distinguished road
chown --> chmod
lin is offline   Reply With Quote

Old   September 24, 2011, 03:21
Default
  #37
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Santiago and Hua Zen,

Hua Zen is right, it's:
Code:
chmod +x Allrun
Yesterday I was tired and almost burned out, so I didn't check properly what I wrote.

And I only wrote the partial path because I thought you knew where I was pointing at... so the correct full path should be:
Code:
gksu gedit /usr/lib/OpenFOAM-1.6-ext/wmake/rules/linuxGcc/general
And/or for the 64bit version:
Code:
gksu gedit /usr/lib/OpenFOAM-1.6-ext/wmake/rules/linux64Gcc/general
edit: another typo I remembered: it's gksu, not sudo, for running gnome apps as root!!!

Best regards,
Bruno

Last edited by wyldckat; September 24, 2011 at 03:23. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   September 27, 2011, 20:08
Default
  #38
Member
 
Santiago
Join Date: Dec 2009
Posts: 85
Rep Power: 7
gascortado is on a distinguished road
Hi Wyldckat,

I did what you recommended and my files look like this now:

gksu gedit /usr/lib/OpenFOAM-1.6-ext/wmake/rules/linux64Gcc/general

CPP = cpp -traditional-cpp $(GFLAGS)
LD = ld

PROJECT_LIBS = -l$(WM_PROJECT) -liberty -ldl

include $(GENERAL_RULES)/standard

include $(RULES)/X
include $(RULES)/c
include $(RULES)/c++


gksu gedit /usr/lib/OpenFOAM-1.6-ext/wmake/rules/linuxGcc/general

CPP = cpp -traditional-cpp $(GFLAGS) -P
LD = ld -melf_i386

PROJECT_LIBS = -l$(WM_PROJECT) -ldl

include $(GENERAL_RULES)/standard

include $(RULES)/X
include $(RULES)/c
include $(RULES)/c++


However when I try to run wmake as before I get the same error:

gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/applications/solvers/my_pisoFSI$ wmake all
linux64GccDPOpt/options:6: *** missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created

When I close gedit after running
gksu gedit /usr/lib/OpenFOAM-1.6-ext/wmake/rules/linuxGcc/general

or

gksu gedit /usr/lib/OpenFOAM-1.6-ext/wmake/rules/linux64Gcc/general


I get the following messages that I don't know what they mean, take a look:

((gedit:31604): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.AFOH2V': No such file or directory

(gedit:31604): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:31604): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.SREG2V': No such file or directory

(gedit:31604): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

Any ideas??? THanks again
gascortado is offline   Reply With Quote

Old   September 28, 2011, 08:00
Default
  #39
Member
 
Santiago
Join Date: Dec 2009
Posts: 85
Rep Power: 7
gascortado is on a distinguished road
Hi Wyldckat,

I figured out the problem. I erased the folder linuxGccDOpt and re-run wmake all and that did the trick. Now I have other problems:

When I hit


gascortado@me257b:~/OpenFOAM/gascortado-1.6-ext/applications/solvers/my_pisoFSI$ wmake all

g++ -m64 -Dlinux64 -DWM_DP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -I/usr/lib/OpenFOAM-1.6-ext/src/dynamicMesh/dynamicFvMesh/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/dynamicMesh/dynamicMesh/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/meshTools/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/turbulenceModels/incompressible/turbulenceModel -I/usr/lib/OpenFOAM-1.6-ext/src/transportModels -I/usr/lib/OpenFOAM-1.6-ext/src/transportModels/incompressible/singlePhaseTransportModel -I/usr/lib/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -DFACE_DECOMP -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/fields/tetPointFields -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetFemMatrix -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPointMesh -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMesh -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshFaceDecomp -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetFemSolution -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshFaceDecomp/tetPolyBoundaryMesh -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshFaceDecomp/tetPolyPatches/tetPolyPatch -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshCellDecomp -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshCellDecomp/tetPolyBoundaryMesh -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshCellDecomp/tetPolyPatches/tetPolyPatch -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/fields/tetPolyPatchFields/tetPolyPatchField -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/fields/elementFields -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/elementMesh -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/fields/elementPatchFields/elementPatchField -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshFaceDecomp/tetPolyPatches/faceTetPolyPatch -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyMeshCellDecomp/tetPolyPatches/faceTetPolyPatch -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyPatchInterpolation -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyPatchInterpolation/tetPolyPatchInterpolationFaceDecomp -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/tetPolyPatchInterpolation/tetPolyPatchInterpolationCellDecomp -I/usr/lib/OpenFOAM-1.6-ext/src/tetDecompositionFiniteElement/fields/tetPolyPatchFields/basic/fixedValue -I/usr/lib/OpenFOAM-1.6-ext/src/dynamicMesh/meshMotion/tetDecompositionMotionSolver/lnInclude -IlnInclude -I. -I/usr/lib/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC Make/linux64GccDPOpt/tractionDisplacementFvPatchVectorField.o Make/linux64GccDPOpt/my_pisoFsi.o -L/usr/lib/OpenFOAM-1.6-ext/lib \
-ldynamicFvMesh -ltopoChangerFvMesh -ldynamicMesh -lmeshTools -lincompressibleTransportModels -lincompressibleTurbulenceModel -lincompressibleRASModels -lincompressibleLESModels -lfiniteVolume -llduSolvers -lfaceDecompFiniteElement -lfaceDecompositionMotionSolver -lOpenFOAM -liberty -ldl -lm -o /home/gascortado/OpenFOAM/gascortado-1.6-ext/applications/bin/my_pisoFsi
/usr/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status
make: *** [/home/gascortado/OpenFOAM/gascortado-1.6-ext/applications/bin/my_pisoFsi] Error 1


And I'm also trying to compile an older version of groovyBC that I modified and successfully compile on my other computer (Ubuntu 10.10) but not here. THis is what I get:

gastascortado@me257b:~/groovyBC$ wmake libso

SOURCE=PatchValueExpressionDriver.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -IMake/linux64GccDPOpt -DFOAM_DEV -I/usr/lib/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -IlnInclude -I. -I/usr/lib/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/PatchValueExpressionDriver.o
SOURCE=groovyBCPointPatchFields.C ; g++ -m64 -Dlinux64 -DWM_DP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-40 -IMake/linux64GccDPOpt -DFOAM_DEV -I/usr/lib/OpenFOAM-1.6-ext/src/finiteVolume/lnInclude -IlnInclude -I. -I/usr/lib/OpenFOAM-1.6-ext/src/OpenFOAM/lnInclude -I/usr/lib/OpenFOAM-1.6-ext/src/OSspecific/POSIX/lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/groovyBCPointPatchFields.o
In file included from Make/linux64GccDPOpt/location.hh:44:0,
from PatchValueExpressionParser.tab.hh:65,
from PatchValueExpressionDriver.H:59,
from PatchValueExpressionDriver.C:34:
position.hh: In function ‚bool pve:perator==(const pve:osition&, const pve:osition&)‚:
position.hh:136:69: warning: suggest parentheses around ‚&&‚ within ‚||‚
In file included from Make/linux64GccDPOpt/location.hh:44:0,
from PatchValueExpressionParser.tab.hh:65,
from PatchValueExpressionDriver.H:59,
from groovyBCPointPatchField.H:59,
from groovyBCPointPatchFields.H:37,
from groovyBCPointPatchFields.C:34:
position.hh: In function ‚bool pve:perator==(const pve:osition&, const pve:osition&)‚:
position.hh:136:69: warning: suggest parentheses around ‚&&‚ within ‚||‚
PatchValueExpressionDriver.C: In member function ‚void Foam::PatchValueExpressionDriver::writeLines(Foam: :Ostream&) const‚:
PatchValueExpressionDriver.C:384:5: error: ‚Foam::HashTable<Foam::interpolationTable<double>, Foam::word>::const_iterator::const_iterator‚ names the constructor, not the type
PatchValueExpressionDriver.C:384:5: error: expected ‚;‚ before ‚it‚
PatchValueExpressionDriver.C:384:5: error: statement cannot resolve address of overloaded function
PatchValueExpressionDriver.C:384:5: error: ‚it‚ was not declared in this scope
make: *** [Make/linux64GccDPOpt/PatchValueExpressionDriver.o] Error 1
make: *** Waiting for unfinished jobs....
gascortado@me257b:~/groovyBC$


Any ideas? Thanks a lot
gascortado is offline   Reply With Quote

Old   October 1, 2011, 11:50
Default
  #40
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Santiago,

Quote:
Originally Posted by gascortado View Post

((gedit:31604): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.AFOH2V': No such file or directory

(gedit:31604): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory

(gedit:31604): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.SREG2V': No such file or directory

(gedit:31604): Gtk-WARNING **: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory
No need to worry, they are just warnings

Quote:
/usr/bin/ld: cannot find -liberty
Good old missing "libiberty.so" problem. Run:
Code:
sudo apt-get install binutils-dev
As for Groovy, try running:
Code:
wclean all
wmake all
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing OF 1.5 on Ubuntu 9.05 smart OpenFOAM Installation 18 August 10, 2009 19:12
Problem in running fluent 6.3 (64 bit) on ubuntu 8.1 (64 bit) Mir5 FLUENT 3 April 29, 2009 10:32
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
OF Installation Problem - Gcc Error Daniel Pilatti OpenFOAM Installation 11 April 19, 2009 22:07
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 23:11.