CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

update turbDyMFoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 13, 2009, 10:04
Default update turbDyMFoam
  #1
Member
 
antonio segalini
Join Date: Mar 2009
Posts: 75
Rep Power: 7
antonio_ing is on a distinguished road
Hi foamers,

i just have installed openfoam-dev with the debian installation. It worked out quicky and easily. Now i want to run a acse i did 6 months ago with a rotating sliding mesh and the solver turbDyMFoam says that it doesn't find the topo changer mixerFvMesh. This is ok. In the old version i have compiled (it was still OF-dev-1.5) i just had to add the library lengine. Here i tried but there is no application folder with the code of turbDyMFoam. Where can i update my turbDyMFoam solver?
I tried also to download from the powerlab the dev version and compile it, but when i update the bashrc, it get stucked in an error:

cfduser-dev@antonio-desktop:~/OpenFOAM/OpenFOAM-1.5-dev$ . ~/.bashrc
-bash: /home/cfduser-dev/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc: line 188: syntax error near unexpected token `<<<'
-bash: /home/cfduser-dev/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc: line 188: `<<<<<<< .mine'

suggestions?

thanks in advance
antonio_ing is offline   Reply With Quote

Old   November 24, 2009, 15:26
Default
  #2
New Member
 
Julius
Join Date: Mar 2009
Posts: 27
Rep Power: 7
juliuslein is on a distinguished road
Hi together,

I got exactly the same problem on installing OpenFOAM-1.5-dev on Ubuntu 9.10 64bit. Has anyone a solution yet? Are there missing any libraries? I installed all packages I found on the net and it worked perfectly with the older 1.5-dev a few month ago. The packages installed additionally to the original Ubuntu 9.10 64bit are:

- binutils
- binutils-dev
- build-essential
- cmake
- fakeroot
- flex
- g++
- libqt4
- libqt4-dev
- libmpfr-dev
- libmpfr1ldbl
- python2.5
- python2.5-dev

Anyone got an idea what could be the reason for this error?

Thanks in advance, Julius
juliuslein is offline   Reply With Quote

Old   November 29, 2009, 20:34
Default
  #3
New Member
 
Julius
Join Date: Mar 2009
Posts: 27
Rep Power: 7
juliuslein is on a distinguished road
Hi together,

commenting out the following two lines (line no. 188 ff) of my OpenFOAM-1.5-dev/etc/bashrc fixed the error.

#<<<<<<< .mine
...
#>>>>>>> .r1000

I did this after comparing the actual bashrc with an older one where these two lines were nearly the only difference. For me it worked fine. I'm going to describe the compilation errors I had to fix afterwards in another thread.

Good luck
juliuslein is offline   Reply With Quote

Old   November 30, 2009, 10:38
Default
  #4
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,737
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by juliuslein View Post
Hi together,

commenting out the following two lines (line no. 188 ff) of my OpenFOAM-1.5-dev/etc/bashrc fixed the error.

#<<<<<<< .mine
...
#>>>>>>> .r1000

I did this after comparing the actual bashrc with an older one where these two lines were nearly the only difference. For me it worked fine. I'm going to describe the compilation errors I had to fix afterwards in another thread.

Good luck
These lines say that during a svn update there was a conflict that could not be resolved (there were local changes in your bashrc that were not compatible with changes in the repositories svn). Bernhard
gschaider is offline   Reply With Quote

Old   November 30, 2009, 10:52
Default
  #5
New Member
 
Julius
Join Date: Mar 2009
Posts: 27
Rep Power: 7
juliuslein is on a distinguished road
Hi Bernhard,

thanks for your answer. I wasn't doing anything with svn repositories. I just downloaded the zip-files from Hrvoje's website (http://powerlab.fsb.hr/ped/kturbo/openfoam/release/) where these lines are already included in the bashrc. Maybe just another bug / type-o that should be fixed.

Julius
juliuslein is offline   Reply With Quote

Old   December 4, 2009, 01:05
Default
  #6
New Member
 
srikara's Avatar
 
Srikara Mahishi
Join Date: Mar 2009
Location: Bangalore
Posts: 22
Rep Power: 7
srikara is on a distinguished road
Hello Julien,
I had the same problem that antonio had mentioned. I did what you have suggested and got rid of that problem. But now when I run the command foamInstallationTest I get the following error message:

PHP Code:
Executing /home/smahishi/OpenFOAM/OpenFOAM-1.5-dev/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell:              bash
Host
:               system001
OS
:                 Linux version 2.6.22.5-31-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid      Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/smahishi/OpenFOAM                  yes       yes
$WM_PROJECT_USER_DIR 
/home/smahishi/OpenFOAM/smahishi-1.5-dev  yes       no
$WM_THIRD_PARTY_DIR  
/home/smahishi/OpenFOAM/ThirdParty       yes       yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR      /home/smahishi/OpenFOAM/OpenFOAM-1.5-dev  yes  yes  yes

$FOAM_APPBIN         
...dev/applications/bin/linux64GccDPOpt  yes  yes  yes
$FOAM_USER_APPBIN    
...dev/applications/bin/linux64GccDPOpt  yes  yes  no
$WM_DIR              
...ishi/OpenFOAM/OpenFOAM-1.5-dev/wmake  yes  yes  yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN         ...OpenFOAM-1.5-dev/lib/linux64GccDPOpt  yes  yes  yes
$FOAM_USER_LIBBIN    
...smahishi-1.5-dev/lib/linux64GccDPOpt  yes  yes  no
$MPI_ARCH_PATH       
...nmpi-1.3.3/platforms/linux64GccDPOpt  no        yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version   Location
-------------------------------------------------------------------------------
WARNINGgcc version does not match gcc supplied with this release of OpenFOAM
         Supplied version
4.3.1
         User version    
: ../configure
4.2.1
         Minimum required
4.2.0

gcc      
...figure
WARNING
:  Conflicting installations:
          
OpenFOAM settings        : /home/smahishi/OpenFOAM/ThirdParty/gcc-4.3.
1/platforms/linux64/bin/gcc
          current path             
: /usr/bin/gcc
          CRITICAL ERROR

gzip     1.3.12    
/usr/bin/gzip
tar      1.17      
/bin/tar
icoFoam
WARNING
:  Conflicting installations:
          
OpenFOAM settings        : /home/smahishi/OpenFOAM/OpenFOAM-1.5-dev/ap
plications
/bin/linux64GccDPOpt/icoFoam
          current path             
:
          
CRITICAL ERROR

-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action                   Result                                       Crit
-------------------------------------------------------------------------------
Pinging_system001        Successful                                   yes
Pinging_localHost        Successful                                   yes
Test_rsh
:                Not_active*                                  yes
Test_ssh
:                Not_active*                                  yes
FATAL ERROR
No remote shell available.
             
OpenFOAM 1.5-dev enviroment requires either ssh and/or rsh.
             
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide 
for trouble shooting.

done
Could you please let me know what you did afterwards to solve these errors?

Thank you,
Srikara
srikara is offline   Reply With Quote

Old   December 4, 2009, 04:27
Default
  #7
New Member
 
Julius
Join Date: Mar 2009
Posts: 27
Rep Power: 7
juliuslein is on a distinguished road
Hello Srikara,

at the moment I see two errors on your Installation. The first one is the version of your openmpi. You should change the version in your settings.sh. Compare bigPhils comment on that.

Please help: Installing OpenFOAM-1.5-dev on Ubuntu 9.04

The second thing is that you should install ssh. On Ubuntu just install by typing

sudo aptitude install ssh

This will download some packages but the error should not be critical. Now compile the whole project again.

Good Luck
juliuslein is offline   Reply With Quote

Old   December 17, 2009, 03:24
Default
  #8
New Member
 
srikara's Avatar
 
Srikara Mahishi
Join Date: Mar 2009
Location: Bangalore
Posts: 22
Rep Power: 7
srikara is on a distinguished road
Hello Julius,
Thank you very much for the reply and sorry for the late reply.

I solved the first problem by setting the compiler installation to OpenFOAM instead of system in openfoam-1.5-dev/etc/settings.sh.

For the second problem, is there any particular version of ssh that I should download and install? I am using OpenSuse 10.3 and not Ubuntu.

There is nothing inside the folder: OpenFOAM-1.5-dev/applications/binlinux64GccDPOpt folder.

Do you have any idea what the problem could be?

Thank you very much,
Srikara
srikara is offline   Reply With Quote

Old   February 18, 2010, 09:01
Default
  #9
Member
 
Nick Gardiner
Join Date: Apr 2009
Location: Chichester, UK
Posts: 90
Rep Power: 7
NickG is on a distinguished road
Hi Srikara

I'm having the same problem in that I've an empty DOpt folder. I know that I can fill this with binaries from OpenFOAM-1.6 but I think the problem is a linking error as I get lots of
/usr/bin/ld: cannot find -l... error messages.
Sound familiar? Have the objects in the src file have been made? They'll be in various 64GccDPOpt folders in the make files. If so it's the linker ld.
Someone did post something about this problem and the fact that it should not be looking in the
/usr/bin directory but I haven't found how to change that yet

Cheers

Nick
NickG is offline   Reply With Quote

Old   February 18, 2010, 11:24
Default
  #10
Member
 
Nick Gardiner
Join Date: Apr 2009
Location: Chichester, UK
Posts: 90
Rep Power: 7
NickG is on a distinguished road
Hi again Srikara

Have just copied the files in /home/****/OpenFOAM/OpenFOAM-1.5-dev/lib/linux64GccDPOpt/openmpi-1.3.3 to the level above and this solved the linking problem. Now it all seems to be compiling with no errors and OpenFOAM-1.5-dev/applications/bin/linux64GccDPOpt is filling up!

Make sure that you have compiled all the third party and src files without errors first.

Cheers

N
NickG is offline   Reply With Quote

Old   May 4, 2010, 10:18
Default
  #11
Senior Member
 
Join Date: Apr 2010
Posts: 151
Rep Power: 6
flowris is on a distinguished road
Hello,


I tried to comment the lines 188 an 193, as suggested by Julius. When I ran the bashrc file, my terminal responded like this:

System

I must mention that my computer passed the foamSystemCheck.

Any suggestions? Or does anyone know what the answer "System" means?






Quote:
Originally Posted by juliuslein View Post
Hi together,

commenting out the following two lines (line no. 188 ff) of my OpenFOAM-1.5-dev/etc/bashrc fixed the error.

#<<<<<<< .mine
...
#>>>>>>> .r1000

I did this after comparing the actual bashrc with an older one where these two lines were nearly the only difference. For me it worked fine. I'm going to describe the compilation errors I had to fix afterwards in another thread.

Good luck
flowris is offline   Reply With Quote

Old   May 4, 2010, 11:25
Default
  #12
New Member
 
Julius
Join Date: Mar 2009
Posts: 27
Rep Power: 7
juliuslein is on a distinguished road
Hello flowris,

this means that your compiler (gcc) is set to "system". In order to avoid compiling problems you should set it to OpenFOAM. This can be done in the OpenFOAM-1.5-dev/etc/settings.sh (line 111 to 115) and looks like:

# Select compiler installation
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# compilerInstall = OpenFOAM | System
compilerInstall=OpenFOAM
#compilerInstall=System

You can also use the "system compiler" but most likely it is not exactly the same version as the one used by the OpenFOAM developers what can cause a lot of trouble (in my case it did).

Good luck, regards Julius
juliuslein is offline   Reply With Quote

Old   June 2, 2010, 08:16
Default
  #13
Senior Member
 
Join Date: Apr 2010
Posts: 151
Rep Power: 6
flowris is on a distinguished road
Thanks Julius,

Indeed my system compiler is a wrong version.

Remarks:
1. I also had to "steal" the following folders from version 1.6:
  • applications/bin/linux64GccDPOpt
  • lib/linux64GccDPOpt
to the corresponding folders in OpenFOAM-1.5-dev.

2. Unlike NickG in #10 of this thread, I did not (yet) need to move the files in OpenFOAM-1.5-dev/lib/linux64GccDPOpt/openmpi-1.3.3 to the level above

After this, foamInstallationTest and the cavity tutorial ran without errors.
flowris is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dynamic mesh update problem. David FLUENT 3 March 15, 2012 06:02
update the pyhsicaltimestep during a steady-state-run mvoss CFX 4 April 6, 2009 03:08
starCD version update hervé CD-adapco 6 March 3, 2008 19:04
ICEM geometry update Omar CFX 0 July 4, 2007 15:55
time taken to update solution in unsteady flow phil FLUENT 6 May 17, 2004 10:12


All times are GMT -4. The time now is 07:52.