CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

wmake error: file 'Make/linux64Gcc44DPOpt/objectFiles' could not be created

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 20, 2009, 08:02
Default wmake error: file 'Make/linux64Gcc44DPOpt/objectFiles' could not be created
  #1
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Hello everyone,

I cloned the OF-1.6 Git repository and downloaded the Third Party stuff. When I run Allwmake (using gcc-4.4.2 on 64bit Fedora 12) on the 1.6.x directory I get the following errors to do with wmake:

Code:
Note: ignore spurious warnings about missing mpicxx.h headers
+ WM_OPTIONS=linux64Gcc44DPOptOPENMPI
+ wmake libso mpi
'/home/lrm29/OpenFOAM/OpenFOAM-1.6.x/lib/linux64Gcc44DPOpt/openmpi-1.3.3/libPstream.so' is up to date.
+ wmake libo OSspecific/POSIX
'/home/lrm29/OpenFOAM/OpenFOAM-1.6.x/lib/linux64Gcc44DPOpt/libOSspecific.o' is up to date.
+ wmake libso OpenFOAM
linux64Gcc44DPOpt/options:6: *** missing separator.  Stop.
wmake error: file 'Make/linux64Gcc44DPOpt/objectFiles' could not be created
+ wmake libso lagrangian/basic
SOURCE=indexedParticle/indexedParticleCloud.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-40  -IlnInclude -I. -I/home/lrm29/OpenFOAM/OpenFOAM-1.6.x/src/OpenFOAM/lnInclude -I/home/lrm29/OpenFOAM/OpenFOAM-1.6.x/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64Gcc44DPOpt/indexedParticleCloud.o
'/home/lrm29/OpenFOAM/OpenFOAM-1.6.x/lib/linux64Gcc44DPOpt/liblagrangian.so' is up to date.
+ wmake libso triSurface
linux64Gcc44DPOpt/options:6: *** missing separator.  Stop.
wmake error: file 'Make/linux64Gcc44DPOpt/objectFiles' could not be created
The OpenFOAM Make/options looks like:

Code:
EXE_INC = \
    -I$(WM_THIRD_PARTY_DIR)/zlib-1.2.3

LIB_LIBS = \
    $(FOAM_LIBBIN)/libOSspecific.o \
    -L$(FOAM_LIBBIN)/dummy -lPstream \
    -lz
The OpenFOAM linux64GccDPOpt/options file looks like:

Code:
# 1 "options"
# 1 "<built-in>"
# 1 "<command-line>"
# 1 "options"
EXE_INC =
    -I$(WM_THIRD_PARTY_DIR)/zlib-1.2.3

LIB_LIBS =
    $(FOAM_LIBBIN)/libOSspecific.o
    -L$(FOAM_LIBBIN)/dummy -lPstream
    -lz
Does anyone have an idea what this missing separator error with wmake means?

Thanks.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   November 23, 2009, 06:22
Default
  #2
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Update: There is something weird going on with the separators (you might say 'duh', looking at the error messages) that wmake generates in the options file. If I manually correct the options file created in Make/linux64GccDPOpt/, and then run wmake, it compiles fine.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   November 27, 2009, 10:58
Default
  #3
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
SOLVED

It was something to do with 'cpp'. The system 'cpp' with GCC 4.4.2 on Fedora 12 screws up the separators.

Fix:

Edit wmake/rules/linux64Gcc/general so that CPP = ThirdParty-1.6/gcc-4.3.3/platforms/bin/cpp instead of /lib/cpp.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   January 5, 2010, 12:34
Default Odd problem
  #4
New Member
 
Mikko Auvinen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 8
Rep Power: 8
auvinen is on a distinguished road
Quote:
Originally Posted by l_r_mcglashan View Post
SOLVED

It was something to do with 'cpp'. The system 'cpp' with GCC 4.4.2 on Fedora 12 screws up the separators.

Fix:

Edit wmake/rules/linux64Gcc/general so that CPP = ThirdParty-1.6/gcc-4.3.3/platforms/bin/cpp instead of /lib/cpp.
Hi Laurence,

I'm facing exactly the same problem on my Fedora 12: make complains about missing separators with every single linux64GccDPOpt/options file. It seems as if the files have been corrupted in some way -- the TAB characters have gone missing or something. The only way I can make things work is by manipulating the files by hand. I tried your Fix, but I cannot get things to work. Could you please elaborate a little on what you did after you edited the rules file in wmake?

I'm trying to compile 1.6 and 1.5-dev on my new machine and I have the same problem with both.

Gratefully,

- mikko
auvinen is offline   Reply With Quote

Old   January 5, 2010, 13:12
Default
  #5
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Have you done 'wclean' before redoing wmake? wmake searches for the folder Make/linuxGccblahblah and the files in it before executing.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   January 7, 2010, 05:53
Default Solved indeed
  #6
New Member
 
Mikko Auvinen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 8
Rep Power: 8
auvinen is on a distinguished road
Quote:
Originally Posted by l_r_mcglashan View Post
Have you done 'wclean' before redoing wmake? wmake searches for the folder Make/linuxGccblahblah and the files in it before executing.
That's the ticket! Apparently I had not done 'wclean' before running wmake again. Everything works fine now. Thank you very much.

Just to clarify the issue for potential readers, this problem arose with me irrespective of the compiler choice (compilerInstall=System/OpenFOAM) in settings.sh; wmake tries to utilize the system cpp by default.

Good work Laurence!
auvinen is offline   Reply With Quote

Old   January 7, 2010, 09:49
Default
  #7
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Glad it was of use to you! Problems like this are why Fedora is so much fun. . It's a poor workaround really, at least it gets the job done.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   January 13, 2010, 18:18
Default OpenFOAM-1.5-dev: Make/linux64GccDPOpt/objectFiles' could not be created
  #8
New Member
 
Eero Kokkonen
Join Date: Jan 2010
Posts: 2
Rep Power: 0
kokkonee is on a distinguished road
Hello!

I am getting the same error with OpenFOAM-1.5-dev (I need the GGI) on Fedora 12 (64-bit) and Ubuntu 9.10 (32-bit) as mentioned here.

This is the basic form that I have tried:

First got these:
flex
binutils
binutils-dev
cmake
gcc-c++
qt4

1)
Get the OpenFOAM-1.5-dev and Thirdparty files for 1.5-version:
svn co https://openfoam-extend.svn.sourcefo...enFOAM-1.5-dev OpenFOAM-1.5-dev

http://sourceforge.net/projects/foam....gtgz/download
http://sourceforge.net/projects/foam....gtgz/download
tar xzf ThirdParty.General.gtgz
tar xzf ThirdParty.linuxGcc.gtgz

2)
changed:
OpenFOAM-1.5-dev/etc/settings.sh
#compilerInstall=OpenFOAM
compilerInstall=System
to:
compilerInstall=OpenFOAM
#compilerInstall=System

3)
Added $HOME/.bashrc the following line:
source $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc
and sourced (or opened new terminal)

4) Have done
./Allwmake >& log_Allwmake

The log can be found here:
http://www.students.tut.fi/~kokkonee/OpenFOAM/log_Allwmake

In addition I have tried
i) FIX up for Ubuntu 9.10

cd ~/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/lib
mv libstdc++.so.6 libstdc++.so.6.orig
ln -s /usr/lib/libstdc++.so.6.0.13 libstdc++.so.6
mv libgcc_s.so.1 libgcc_s.so.1.orig
ln -s /lib/libgcc_s.so.1

ii) and with Fedora 12
OpenFOAM-1.5-dev SVN 1563 on Fedora 12 (32-bit) - Successful

If someone could please help me with this, I am clearly missing something and I and confused from all the things I have read and tried...

BR.
Eero Kokkonen
eero.kokkonen(at)tut.fi
kokkonee is offline   Reply With Quote

Old   January 14, 2010, 05:12
Default
  #9
New Member
 
Mikko Auvinen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 8
Rep Power: 8
auvinen is on a distinguished road
Eero,

Referring to the Fedora 12 problem, you're looking at a fix to the "missing separator" issue on this thread. I was able compile both 1.5-dev and 1.6 on F12 after I followed Laurence's recipe on changing the cpp used by wmake. ... Just remember to run wclean after you make the change.

- mikko
auvinen is offline   Reply With Quote

Old   January 14, 2010, 05:22
Default
  #10
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Although I would now use the fix of adding the 'P' option to the cpp command discussed in the following thread:

Buiding on Fedora 12
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   January 14, 2010, 05:50
Default
  #11
New Member
 
Mikko Auvinen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 8
Rep Power: 8
auvinen is on a distinguished road
Yes, that's a much nicer fix.Thanks again.
- mikko
auvinen is offline   Reply With Quote

Old   January 17, 2010, 08:28
Default still problems...
  #12
New Member
 
Eero Kokkonen
Join Date: Jan 2010
Posts: 2
Rep Power: 0
kokkonee is on a distinguished road
Hi!

I have tried the -P option suggested in this thread, but it is not working for me (fedora 12, 64-bit).

I started from the beginning (deleted all files) and did the following:

1)
Get the OpenFOAM-1.5-dev and Thirdparty files for 1.5-version:
svn co https://openfoam-extend.svn.sourcefo...enFOAM-1.5-dev OpenFOAM-1.5-dev

http://sourceforge.net/projects/foam....gtgz/download
http://sourceforge.net/projects/foam....gtgz/download
tar xzf ThirdParty.General.gtgz
tar xzf ThirdParty.linuxGcc.gtgz

2)
changed:
OpenFOAM-1.5-dev/etc/settings.sh
#compilerInstall=OpenFOAM
compilerInstall=System
to:
compilerInstall=OpenFOAM
#compilerInstall=System

3)
Added $HOME/.bashrc the following line:
source $HOME/OpenFOAM/OpenFOAM-1.5-dev/etc/bashrc
and sourced (or opened new terminal)

4)
Compiled the Qt-4.3.5 version
and added the following lines to the ~/OpenFOAM/OpenFOAM-1.5/etc/bashrc at the very end

# set QT related variables
QT=~/OpenFOAM/ThirdParty/Qt-4.3.5
export PATH=$QT/bin:$PATH
export LD_LIBRARY_PATH=$QT/lib:$LD_LIBRARY_PATH

Have you guys done this with your Fedora distributions? I read that people have got everything working with this (Trouble with installing OpenFOAM on Ubuntu ). I also tried without this, not working...

5)
I modified the file: OpenFOAM-1.5-dev/wmake/rules/linux64Gcc/general

CPP = /lib/cpp $(GFLAGS) -P
LD = ld -A64

PROJECT_LIBS = -l$(WM_PROJECT) -liberty -ldl
include $(GENERAL_RULES)/standard
include $(RULES)/X
include $(RULES)/c
include $(RULES)/c++
include $(GENERAL_RULES)/cint


Isn't this the correct file in my case (though I also tried the OpenFOAM-1.5-dev/wmake/rules/linuxGcc/general -file)?

6) Did
./Allwmake >& log_Allwmake

Still got these wmake errors:

wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created
make[1]: *** [setFields] Error 1
linux64GccDPOpt/options:6: *** missing separator. Stop.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created
make[1]: *** [mapFields] Error 1
make[1]: Target `application' not remade because of errors.
make: *** [preProcessing] Error 2
make: Target `application' not remade because of errors.
+ '[' '' = doc ']'

I have abandoned trying with Ubuntu 9.10 and managed to compile OpenFOAM-1.5-dev on Fedora 10 but still have issues with paraFOAM (reader for the file cavity.OpenFOAM cannot be found while testing the tutorials)

Have I done something wrong or missing some package, obviously something's not right? Any ideas?

By the way, the 'wclean'-command produces:
wclean error: 'Make' directory does not exist

And have you modified the (extra?) '-' in 'ParaView3.3-cvs' in any way and if you have, what have you done exactly? I am referring to
Installation of OpenFOAM15dev

-Eero
kokkonee is offline   Reply With Quote

Old   January 18, 2010, 05:40
Default
  #13
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
Things here I can maybe help with:

2) I actually used the compiler that came with Fedora 12.

4) Paraview can be difficult to set up. Can you run 'glxgears'? All my problems were related to that not working.

5) Yes, that's the correct file.

6) wclean only works if there is a make directory. If you're trying to compile the whole thing then you need to do a wcleanAll. You need to do that before running Allwmake again.

I haven't actually compiled the -dev version, I may try later.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   March 11, 2010, 13:29
Default
  #14
Member
 
Mihir
Join Date: Mar 2009
Posts: 40
Rep Power: 8
mihir1310 is on a distinguished road
Quote:
Originally Posted by l_r_mcglashan View Post
Update: There is something weird going on with the separators (you might say 'duh', looking at the error messages) that wmake generates in the options file. If I manually correct the options file created in Make/linux64GccDPOpt/, and then run wmake, it compiles fine.
I m having the same trouble compiling a code as I add lagrangian particle classes to it . Since Im running on a cluster I may not have the access to be able to edit the wmake/linux64/general file.
You said you could manually edit the Make/linux64GccDPOpt/options file. here is my options file
Code:
# 1 "options"
# 1 "<built-in>"
# 1 "<command-line>"
# 1 "options"
EXE_INC = -I$(LIB_SRC)/finiteVolume/lnInclude




EXE_LIBS = -lfiniteVolume
Could you elaborate what were those changes ?
mihir1310 is offline   Reply With Quote

Old   March 12, 2010, 06:26
Default
  #15
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
I strongly suggest that you add the -P option to cpp in your wmake rules, or get your system administrator to do so, otherwise you'll have to manually edit every time you use wmake!

It was either the '\' missing from the end of lines, or a tab/carriage return missing at the end of lines.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Old   September 25, 2010, 17:45
Default
  #16
Senior Member
 
lakeat's Avatar
 
Daniel WEI (老魏)
Join Date: Mar 2009
Location: South Bend, IN, USA
Posts: 688
Blog Entries: 9
Rep Power: 12
lakeat is on a distinguished road
Send a message via Skype™ to lakeat
"-P" is a good solution!

-P: Inhibit generation of linemarkers in the output from the preprocessor. This might be useful when running the preprocessor on something that is not C code, and will be sent to a program which might be confused by the linemarkers.
__________________
~
Daniel WEI
-------------
NatHaz Modeling Laboratory
Department of Civil & Environmental Engineering & Earth Sciences
University of Notre Dame, USA
Email || My Personal CFD Blog
lakeat is offline   Reply With Quote

Old   September 26, 2010, 10:24
Default
  #17
Senior Member
 
Laurence R. McGlashan
Join Date: Mar 2009
Posts: 370
Rep Power: 14
l_r_mcglashan will become famous soon enough
It's been added to the 1.7 release.
__________________
Laurence R. McGlashan :: Website
l_r_mcglashan is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems Installing OF 1.6 32 bit bucksfan OpenFOAM Installation 19 August 4, 2009 01:36
OpenFOAM15 installables are incomplete problem with paraFoam tryingof OpenFOAM Bugs 17 December 7, 2008 05:41
Problem of compilation OF 14Allwmake command not found erik_d OpenFOAM Bugs 13 September 13, 2008 21:45
ParaFoam error message joey OpenFOAM Paraview & paraFoam 1 October 2, 2006 13:28
CFX4.3 -build analysis form Chie Min CFX 5 July 12, 2001 23:19


All times are GMT -4. The time now is 04:58.