CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Paraview and Qt installation (http://www.cfd-online.com/Forums/openfoam-installation/72303-paraview-qt-installation.html)

maverick February 1, 2010 22:57

Paraview and Qt installation
 
Hi everbody,
am trying to install open foam 1.6

i have installed open foam without installing Qt
after that i have dowloaded Qt 4.3.5 from link given in open foam site
i have kept the Qt in third party directory untarred it and ran ./qmake and the installation was complete.

Now when i run ./makeParaView -qmake /home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5 (the path where qmake is present) am getting the following error

cannot find qmake either at $QMAKE_PATH or in current $PATH

can somebody guide me on this
thanks

olesen February 2, 2010 03:28

Quote:

Originally Posted by maverick (Post 244510)
Now when i run ./makeParaView -qmake /home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5 (the path where qmake is present) am getting the following error

cannot find qmake either at $QMAKE_PATH or in current $PATH

can somebody guide me on this

Did you try specifying the full path to the qmake executable?
eg,

Code:

./makeParaView -qmake /home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5/qmake

gwierink February 2, 2010 03:35

Hi,

I guess you need to add qmake to your environment variables, i.e. add

Code:

PATH=/home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5:$PATH
export PATH

to .bashrc in your home directory (assuming you have a bash shell). That is, if the executable qmake actually lives in /home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5 of course.

Hope this helps.

maverick February 2, 2010 05:02

Quote:

Originally Posted by olesen (Post 244526)
Did you try specifying the full path to the qmake executable?

[/CODE]

i get the following mesage when i add qmake

specified QMAKE_PATH does not exist on this machine
QMAKE_PATH=home/xxxx/OpenFOAM/ThirdParty-1.6/qmake leaving unspecifed
*** Error: cannot find qmake either at $QMAKE_PATH or in current $PATH


Quote:

Originally Posted by gwierink (Post 244527)
Code:

PATH=/home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5:$PATH
export PATH

to .bashrc in your home directory (assuming you have a bash shell). That is, if the executable qmake actually lives in /home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5 of course.

I have added the code

PATH=/home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5:$PATH
to .bashrc file in home directory and then updated the envirnmental variables by

. $HOME/.bashrc
still the same problem exists

and qmake directory is available in the qt-x11-opensouce-src-4.3.5 directory

also when i try finding whether Qt is installed by usind qmake --version , its not able to detect the version instead i get the packages list

have i installed Qt

am kinda new to linux , donno wat to do.

thanks both of u for reply

olesen February 2, 2010 05:29

Quote:

Originally Posted by maverick (Post 244539)
i get the following mesage when i add qmake

specified QMAKE_PATH does not exist on this machine
QMAKE_PATH=home/xxxx/OpenFOAM/ThirdParty-1.6/qmake leaving unspecifed
*** Error: cannot find qmake either at $QMAKE_PATH or in current $PATH

This message has "home/xxxx/ and not "/home/xxxx/", did you forget the slash?


Quote:

Originally Posted by maverick (Post 244539)
PATH=/home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5:$PATH
to .bashrc file in home directory and then updated the envirnmental variables by

. $HOME/.bashrc
still the same problem exists

and qmake directory is available in the qt-x11-opensouce-src-4.3.5 directory

What? A qmake directory is now available? This is getting really confusing.

First make sure you can actually use qmake. According to your information qmake is found somewhere under the qt-x11-opensource-src-4.3.5 directory which is located somewhere on your system, or perhaps it is a qmake directory (presumably with a qmake executable in it).

Make sure you can actually call qmake. For example,
Code:

/SOME/PATH/THAT/YOU/KNOW/AND/WE/CANNOT/qmake -v
On my system,
Code:

/usr/bin/qmake -v
 
QMake version 2.01a
Using Qt version 4.5.3 in /usr/lib64

Once you have this, you can either add "/SOME/PATH/THAT/YOU/KNOW/AND/WE/CANNOT" to your path, or use makeParaView with
Code:

-qmake /SOME/PATH/THAT/YOU/KNOW/AND/WE/CANNOT/qmake

gwierink February 2, 2010 06:57

Quote:

I have added the code

PATH=/home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5:$PATH
to .bashrc file in home directory and then updated the envirnmental variables by

. $HOME/.bashrc
still the same problem exists
And (besides having the right path), did you add also
Code:

export PATH
after
Code:

PATH=/home/xxxx/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5:$PATH
?

olesen February 2, 2010 07:07

Quote:

Originally Posted by gwierink (Post 244561)
And (besides having the right path), did you add also
Code:

export PATH
after ...

This shouldn't be required since the PATH is normally exported anyhow, which can be verified by the output of 'export' (without any arguments).
Unless something is really weird on the system, you should see "declare -x PATH=....", which shows that PATH is indeed exported.

gwierink February 2, 2010 07:29

Quote:

This shouldn't be required since the PATH is normally exported anyhow, which can be verified by the output of 'export' (without any arguments).
Unless something is really weird on the system, you should see "declare -x PATH=....", which shows that PATH is indeed exported.
Thanks, Mark, didn't know :)

maverick February 2, 2010 09:51

[QUOTE=olesen;244542]This message has "home/xxxx/ and not "/home/xxxx/", did you forget the slash?

I have not forgotten the slash and i have included export PATH


What? A qmake directory is now available? This is getting really confusing.

qmake directory is available in home/usr/OpenFOAM/ThirdParty-1.6/qt-x11-opensource-src-4.3.5 directory.it contains lots of files with .o extension.

i went in the qt-x11 directory where qmake is available and when i typed qmake -v, i get this

* qt3-dev-tools ( You will have to enable component called 'main' )
* qt4-qmake ( You will have to enable component called 'main' )
Try : sudo apt-get install <selected package>
qmake: command not found


should i reinstall qt again, how do i uninstall it, will it solve the problem

gwierink February 3, 2010 03:48

Well, it is becoming a bit unclear to me now what is going on.
First of all, what linux distribution are you using? This is important because you may need to install different packages on which Qt depends (or at least the compilation of Qt). If I were you, I would start installing Qt from scratch. Just make a folder containing the qt-x11-opensource-src-4.3.5.tar.gz file and untar it. Then, configure it ("./configure"), make it ("make" or "gmake", depending on the system), and install it (as root, "make install" or "gmake install", and log out of root again). And last but not least, put the right path in .bashrc.

maverick February 3, 2010 09:45

am using ubuntu 9.10
i will tyr it
thanks a lot

maverick February 3, 2010 09:47

am using ubuntu 9.10
iwill try it
thanks a lot

gwierink February 3, 2010 10:14

Great, there is a quite extensive "cookbook" discussion for installing OF in Ubuntu in this thread. Have a good one!

maverick February 7, 2010 08:29

hi i was able to install paraview
i used the following code

Code:

sudo apt-get install qt4
sudo apt-get install libqt4-dev

and then i installed paraview and pv3foamreader in the way given in readme file

thanks both of u for your help
i hope working in openfoam will be a pleasant experience for me
regards


All times are GMT -4. The time now is 19:06.