CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OF 1.6 installation on SUSE 11.2 (http://www.cfd-online.com/Forums/openfoam-installation/75029-1-6-installation-suse-11-2-a.html)

jonya April 14, 2010 16:53

OF 1.6 installation on SUSE 11.2
 
I have got some experience with Installation OF 1.6 on SUSE 11.2 and wat to share it here.
Also I have OF 1.6 Ubuntu 9.10 installation guide here on Russian for now.
I hope it will be usefull.

Upd http://www.extra.os-cfd.ru/ - now you coul find this guides here.

alberto April 15, 2010 01:02

It looks familiar :D

Anyway thanks for making a PDF out of it.

Best,

jonya April 15, 2010 07:25

Hi, alberto!
Sorry for copy without reference to you. I've corrected the file.
Sincerely,
Eugen Varseev

alberto April 15, 2010 10:15

No problem :)

jonya April 16, 2010 15:13

I updated PDF versions of Guides for OF Ubuntu 9.04 Installation on Russian and English here

vishal May 1, 2010 17:44

Quote:

Originally Posted by jonya (Post 254648)
I have got some experience with Installation OF 1.6 on SUSE 11.2 and wat to share it here.
Also I have OF 1.6 Ubuntu 9.10 installation guide here on Russian for now.
I hope it will be usefull.

following is the reply when i am trying to check my installation. can you please he


vishal@linux-tle1:~/OpenFOAM/OpenFOAM-1.6.x/bin> ./foamInstallationTest
Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------

FATAL ERROR: OpenFOAM environment not configured.

Please refer to the installation section of the README file:

<OpenFOAM installation dir>/OpenFOAM-1.6/README

to source the OpenFOAM environment.

vishal@linux-tle1:~/OpenFOAM/OpenFOAM-1.6.x/bin>

why is it happning even if i edited the bashrc file in etc dir

please let me know.....

alberto May 1, 2010 20:59

You should not modify that file if not to change the compiler (if you want to use the system compiler).

Usually the error you get comes out when you didn't source that bashrc file in your system bashrc (~/.bashrc), as explained in the README file.

Best,

vishal May 2, 2010 04:11

Quote:

Originally Posted by alberto (Post 257151)
You should not modify that file if not to change the compiler (if you want to use the system compiler).

Usually the error you get comes out when you didn't source that bashrc file in your system bashrc (~/.bashrc), as explained in the README file.

Best,

Thanks,

you mean to say i need to put following line in my ~/.bashrc file

. $HOME/OpenFOAM/OpenFOAM-1.6.x/etc/bashrc

but, when i try to open bashrc file i get following error

vishal@linux-tle1:~/OpenFOAM> ~/.bashrc
bash: /home/vishal/.bashrc: Permission denied

i know it some ACCESS ISSUE, but i really don't know how could i get it. i guess then it should work.

can you please help.

jonya May 2, 2010 07:07

Quote:

Originally Posted by vishal (Post 257166)
Thanks,

you mean to say i need to put following line in my ~/.bashrc file

. $HOME/OpenFOAM/OpenFOAM-1.6.x/etc/bashrc

but, when i try to open bashrc file i get following error

vishal@linux-tle1:~/OpenFOAM> ~/.bashrc
bash: /home/vishal/.bashrc: Permission denied

i know it some ACCESS ISSUE, but i really don't know how could i get it. i guess then it should work.

can you please help.

Hi,
Use Sudo command. Like this:
Code:

sudo gedit
And then open bashrc file.
Eugeny

vishal May 2, 2010 11:14

Hi,

following is the erroe i am facing
and i am using system compiler for compilation.

vishal@linux-tle1:~/OpenFOAM/OpenFOAM-1.6.x> sudo kate bashrc
root's password:
kate: cannot connect to X server

what to do now...... ??? :(:confused::confused::confused:

wyldckat May 2, 2010 12:52

Greetings Vishal,

Quote:

Originally Posted by vishal (Post 257166)
you mean to say i need to put following line in my ~/.bashrc file

. $HOME/OpenFOAM/OpenFOAM-1.6.x/etc/bashrc

Yes, so far so good...

Quote:

Originally Posted by vishal (Post 257166)
but, when i try to open bashrc file i get following error

vishal@linux-tle1:~/OpenFOAM> ~/.bashrc
bash: /home/vishal/.bashrc: Permission denied

Ah, because "~/.bashrc" isn't an executable, it's a file with environment definitions. For using it directly, you should follow the same method used with OpenFOAM's bashrc, namely sourcing the file, like this:
Code:

. ~/.bashrc
or this
Code:

source ~/.bashrc
Remember when foamInstallationTest gave you:
Quote:

Originally Posted by vishal (Post 257166)
Please refer to the installation section of the README file:

<OpenFOAM installation dir>/OpenFOAM-1.6/README

to source the OpenFOAM environment.

I also thought at first that the term "source" meant "edit" in this context, but it actually
Quote:

is a way of getting commands to run in your current shell (from: The Source command)
But the best way is to start a new terminal, since it will start with a clean environment and it will (or at least should) source the ~/.bashrc file on it's own.

Best regards,
Bruno

vishal May 2, 2010 17:55

I tried the same but i am still having following problem.

vishal@linux-tle1:~/OpenFOAM> . $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/etc/bashrc: No such file or directory
vishal@linux-tle1:~/OpenFOAM> source ~/.bashrc
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/foamCleanPath: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/foamCleanPath: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/foamCleanPath: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/etc/settings.sh: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/etc/aliases.sh: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/etc/apps/paraview3/bashrc: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/etc/apps/ensight/bashrc: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/foamCleanPath: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/foamCleanPath: No such file or directory
bash: /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/foamCleanPath: No such file or directory
vishal@linux-tle1:~/OpenFOAM>

What am i really suppose to do when they say following in Installation README file

if running bash or ksh (if in doubt type echo $SHELL), source the etc/bashrc file by adding the following line to the end of your $HOME/.bashrc file:
  • . $HOME/OpenFOAM/OpenFOAM-1.6/etc/bashrc
Then update the environment variables by sourcing the $HOME/.bashrc file by typing in the terminal:
  • . $HOME/.bashrc
i am really sorry for sounding so stupid.....

wyldckat May 2, 2010 19:01

Hello Vishal,

This is starting to look very strange indeed... it seems that there is something else missing.

OK, let's take a few steps back:
  • What instruction guide have you followed?
  • What files have you downloaded and unpacked?
  • What commands did you use to unpack?
  • Did you run the commands in normal user or super-user/root?
  • Have you checked if those files that it says "No such file or directory" do really exist? And what permissions do they have? Try running:
    Code:

    ls -l /home/vishal/OpenFOAM/OpenFOAM-1.6/etc/
    ls -l /home/vishal/OpenFOAM/OpenFOAM-1.6/bin/

Best regards,
Bruno

alberto May 2, 2010 21:41

I would suggest to get the sources from git repository, after deleting the OpenFOAM-1.6 directory. In this way you get a clean and updated source tree.

It would be better also to read some introductory guide to UNIX and Linux, so to become familiar with the environment. If you use openSUSE, there are introductory guides here:

http://www.novell.com/documentation/opensuse112/

No idea about ubuntu, since I don't use it (maybe when they stop forcing wrong practices on users like sudo...:mad:)

Good luck

vishal May 3, 2010 00:37

Hi everyone,

Finally i got the software installed the ./foamInstellationTest ran successfully for me.

THanks for all your help.

vishal May 3, 2010 05:05

Hi,

I have just followed the instructions in README and did everything from the begining.

This time i have used the OpenFOAM compiler for compilation.

The road block i was having was, i did not know how to open ".bashrc" file and thes i was trying very sutpid attempts.

finally i tried this :

vishal@linux-tle1:~> sudo kate .bashrc
(asked for password)
kate: cannot connect to X server (This messege i got)

again i put
vishal@linux-tle1:~> kate .bashrc

this worked and i got the file open.


after this i set the environmental variables by following commend

vishal@linux-tle1:~> . ~/.bashrc

and filally compiled the program using
vishal@linux-tle1/OpenFOAM:~> ./Allwmake

OpenFOAM is working fine for me

Thanks for your help....... :D:D:D


All times are GMT -4. The time now is 22:39.