CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM-1.5 for large scale compute server

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   May 16, 2010, 07:05
Default OpenFOAM-1.5 for large scale compute server
  #1
New Member
 
SATORU ESASHI
Join Date: Dec 2009
Posts: 4
Rep Power: 7
SARU is on a distinguished road
Hi!!

Now, I try to install OpenFOAM-1.5 on large scale computer server.
but, I have one problem when I carried out ./Allwmake. It is occured such as below.

SOURCE=autoHexMesh/autoHexMeshDriver/autoRefineDriver.C ; g++ -m64 -
Dlinux64 -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-style-cast -march=opteron -O3 -DNoRepository -ftemplate- depth-40 -I/work/esashi/OpenFOAM/OpenFOAM-1.5/src/
decompositionAgglomeration/decompositionMethods/lnInclude -I/work/ esashi/OpenFOAM/OpenFOAM-1.5/src/dynamicMesh/lnInclude -I/work/esashi/ OpenFOAM/OpenFOAM-1.5/src/finiteVolume/lnInclude -I/work/esashi/ OpenFOAM/OpenFOAM-1.5/src/lagrangian/basic/lnInclude -I/work/esashi/ OpenFOAM/OpenFOAM-1.5/src/meshTools/lnInclude -I/work/esashi/OpenFOAM/ OpenFOAM-1.5/src/edgeMesh/lnInclude -I/work/esashi/OpenFOAM/ OpenFOAM-1.5/src/triSurface/lnInclude -IlnInclude -I. -I/work/esashi/ OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/work/esashi/OpenFOAM/
OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -fPIC -c $SOURCE -o Make/
linux64GccDPOpt/autoRefineDriver.o
/work/esashi/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude/PtrList.C:
In copy constructor Foam::PtrList<T>::PtrList(const
Foam::PtrList<T>&) [with T = Foam::featureEdgeMesh]:
autoHexMesh/autoHexMeshDriver/autoRefineDriver.C:260: instantiated
from here
/work/esashi/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude/PtrList.C:
56: error: invalid conversion from Foam::IOobject* to Foam::featureEdgeMesh*
make: *** [Make/linux64GccDPOpt/autoRefineDriver.o] error 1
+ wmake libso errorEstimation

after that, I carried out foamInstrationTest. The result represented below.

Checking basic setup...
-------------------------------------------------------------------------------
Shell: csh
Host: rsclw13
OS: Linux version 2.6.18-92.1.10.el5_lustre.1.6.6smp
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory
Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /work/esashi/OpenFOAM
yes yes
$WM_PROJECT_USER_DIR .../research/g48012/OpenFOAM/g48012-1.5
yes no
$WM_THIRD_PARTY_DIR /work/esashi/OpenFOAM/ThirdParty
yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid
Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /work/esashi/OpenFOAM/OpenFOAM-1.5 yes
yes yes

$FOAM_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes
yes yes
$FOAM_USER_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes
yes no
$WM_DIR /work/esashi/OpenFOAM/OpenFOAM-1.5/wmake yes
yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid
Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.5/lib/linux64GccDPOpt yes
yes yes
$FOAM_USER_LIBBIN ...nFOAM/g48012-1.5/lib/linux64GccDPOpt yes
yes no
$MPI_ARCH_PATH ...nmpi-1.2.6/platforms/linux64GccDPOpt yes
yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version :
Minimum required: 4.2.0

gcc
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.5 /bin/
gzip
tar 1.15.1 /bin/
tar
icoFoam 1.5 .../OpenFOAM-1.5/applications/bin/linux64GccDPOpt/
icoFoam
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result
Crit
-------------------------------------------------------------------------------
Pinging_rsclw13 Successful
yes
Pinging_localHost Successful
yes
Test_rsh: Unsuccessful_connection_refused*
yes
Test_ssh: Successful
yes
(*) Only one of rsh or ssh is required by the OpenFOAM enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult the installation guide for trouble shooting.

done.

How can I resolve that?
If someone knows this problems, Could you tell me how to install?

Regards!!
SARU is offline   Reply With Quote

Old   May 19, 2010, 06:01
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings SARU,

Can you change from OpenFOAM 1.5 to 1.5.x? Or to 1.6 or even 1.6.x?
If not, you will have to build gcc version 4.2.x (x=1,2,3 or 4 ). There should be one available in the ThirdParty folder.

I say this, because the first error you have is possibly related to changes in gcc coding directives from 4.2.x to 4.3.x .
Nonetheless, OpenFOAM 1.6 and 1.6.x should build well with gcc 4.3.1, which is your system's gcc version.

As for the "Critical error" that foamInstallationTest reports, it's actually a glitch in the script, which doesn't account for the fact that system/user compilers can be placed anywhere... So that error shouldn't be much of a problem

Best regards,
Bruno

PS: I didn't answer earlier, because I was hoping that someone more experienced with OpenFOAM 1.5 would step in before me...
wyldckat is offline   Reply With Quote

Old   May 19, 2010, 22:06
Default
  #3
New Member
 
SATORU ESASHI
Join Date: Dec 2009
Posts: 4
Rep Power: 7
SARU is on a distinguished road
Greetings Mr. Bruno

I appreciate your responce.

Immediately, I try to change gcc version from gcc-4.1.2 to gcc 4.3.1.

Best regards
SARU
SARU is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
k Omega SST SAS for OpenFOAM 1.5??? barath.ezhilan OpenFOAM Running, Solving & CFD 3 June 2, 2010 07:41
OpenFOAM 1.5 dev LVDH OpenFOAM 98 May 5, 2010 17:01
OpenFOAM 1.5 installation on OpenSUSE 11.0 bigphil OpenFOAM Installation 16 April 29, 2009 06:28
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
OpenFOAM Version 1.5 Released OpenFOAM discussion board administrator OpenFOAM Announcements from ESI-OpenCFD 0 July 14, 2008 18:22


All times are GMT -4. The time now is 15:14.