CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Help needed: building 1.5.x on Lucid

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 9, 2010, 18:58
Default Help needed: building 1.5.x on Lucid
  #1
Member
 
Scott Ripplinger
Join Date: Mar 2009
Posts: 30
Rep Power: 8
sripplinger is on a distinguished road
I have been writing a code extension for my thesis using OpenFOAM 1.5.x. With a recent OS upgrade (to Kubuntu 10.04) I am no longer able to compile my code. I have tried recompiling OF 1.5.x and have not been successful. I have been able to successfully compile 1.6.x using the great scripts provided by members of the community here, but unfortunately my solver does not appear to be compatible with the latest version of OF.

I have uploaded a make log of my attempted 1.5.x build at http://smrkal.com/make.log. I would very much like to get this installed again so I can get this troublesome thesis wrapped up. Any help and insights are greatly appreciated.
sripplinger is offline   Reply With Quote

Old   June 10, 2010, 15:10
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Scott,

I was stumped at first too, but I managed to isolate the problem: somewhere in time, the people responsible for the libc6 libraries seem to have made an option to add a new type of definition "__USE_XOPEN2K8" and getdelim got under that very same definition, instead of "__USE_GNU".

So, the fix, which will at least allow building OpenFOAM 1.5 and 1.5.x is this:
  1. Go to the folder "$WM_PROJECT_DIR/wmake/rules/$WM_ARCH$WM_COMPILER"
  2. Edit the files "c" and "c++" and at the end of the line that starts with "cFLAGS" or "c++FLAGS", add " -D__USE_XOPEN2K8", without the quotes and don't forget the space. In other words, it should look something like this in the file "c++":
    Code:
    c++FLAGS    = $(GFLAGS) $(c++WARN) $(c++OPT) $(c++DBUG) $(ptFLAGS) $(LIB_HEADER_DIRS) -fPIC -pthread -D__USE_XOPEN2K8
    And in "c":
    Code:
    cFLAGS      = $(GFLAGS) $(cWARN) $(cOPT) $(cDBUG) $(LIB_HEADER_DIRS) -fPIC -D__USE_XOPEN2K8
It should now build everything properly... although I haven't thoroughly tested it And even if it builds, it might not work afterwards, although I think it should!

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 10, 2010, 19:37
Default
  #3
Member
 
Scott Ripplinger
Join Date: Mar 2009
Posts: 30
Rep Power: 8
sripplinger is on a distinguished road
I am glad there are people in this world with eyes keen enough to catch something like that. I am currently compiling and things appear to be going well. I'll report back after it is done and I have had a chance to try compiling my code and running it.
sripplinger is offline   Reply With Quote

Old   June 10, 2010, 22:01
Default
  #4
Member
 
Scott Ripplinger
Join Date: Mar 2009
Posts: 30
Rep Power: 8
sripplinger is on a distinguished road
Well, it looks like things are working. The compile of the complete 1.5.x package had some errors, but it was only a few and hopefully with packages I don't need. It kind of looks like it doesn't like my installation of Qt (version 4.6.2). My custom code was able to compile, though. So it's back to just debugging that. Thanks for your help! Hopefully I won't be back too soon
sripplinger is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solar Radiation in OpenFOAM plainstyle OpenFOAM Running, Solving & CFD 15 July 8, 2014 04:43
New building machine for OpenFoam gerbervdgraaf OpenFOAM Installation 23 December 9, 2009 03:39
OpenFOAM 1.5.x package - CentOS 5.3 x86_64 linnemann OpenFOAM Installation 7 July 30, 2009 03:14
Compilation error OF1.5-dev on Suse10.3 darenyang OpenFOAM Installation 0 April 29, 2009 04:55
Urgent help needed for meshing in GAMBIT John FLUENT 3 September 4, 2002 09:08


All times are GMT -4. The time now is 05:15.