CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Openfoam installation on OpenSuse 11.1 (http://www.cfd-online.com/Forums/openfoam-installation/77172-openfoam-installation-opensuse-11-1-a.html)

Bufacchi June 15, 2010 15:54

Openfoam installation on OpenSuse 11.1
 
Howdy y'all

I'm trying to compile OpenFOAM 1.6.x on OpenSuse 11.1 64bits. It's been a tough job so far, but reading the threads I managed to struggle with a single error. Although it seems to be an error already reported, I could not find my way through it.

Comments are welcome. Thanks. :)

Paulo


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: linux-nkui
OS: Linux version 2.6.27.45-0.1-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/paulo/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/paulo/OpenFOAM/paulo-1.6.x yes no
$WM_THIRD_PARTY_DIR /home/paulo/OpenFOAM/ThirdParty-1.6.x yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/paulo/OpenFOAM/OpenFOAM-1.6.x yes yes yes

$FOAM_APPBIN ...6.x/applications/bin/linux64GccDPOpt yes yes yes
$FOAM_SITE_APPBIN ...nFOAM/site/1.6.x/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...6.x/applications/bin/linux64GccDPOpt no no
$WM_DIR .../paulo/OpenFOAM/OpenFOAM-1.6.x/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.6.x/lib/linux64GccDPOpt yes yes yes
$FOAM_SITE_LIBBIN ...nFOAM/site/1.6.x/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...FOAM/paulo-1.6.x/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH ...nmpi-1.3.3/platforms/linux64GccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.3.3 ...M/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux64/bin/gcc
gzip 1.3.12 /usr/bin/gzip
tar 1.20 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/paulo/OpenFOAM/OpenFOAM-1.6.x/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.

Bufacchi June 15, 2010 19:55

I made it
 
I installed flex, copied Allwmake from OpenFOAM-1.6/applications to OpenFOAM-1.6.x/applications and it ran ok.

Thanks!



Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: linux-nkui
OS: Linux version 2.6.27.45-0.1-default
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/paulo/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/paulo/OpenFOAM/paulo-1.6.x yes no
$WM_THIRD_PARTY_DIR /home/paulo/OpenFOAM/ThirdParty-1.6.x yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/paulo/OpenFOAM/OpenFOAM-1.6.x yes yes yes

$FOAM_APPBIN ...6.x/applications/bin/linux64GccDPOpt yes yes yes
$FOAM_SITE_APPBIN ...nFOAM/site/1.6.x/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...6.x/applications/bin/linux64GccDPOpt no no
$WM_DIR .../paulo/OpenFOAM/OpenFOAM-1.6.x/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.6.x/lib/linux64GccDPOpt yes yes yes
$FOAM_SITE_LIBBIN ...nFOAM/site/1.6.x/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...FOAM/paulo-1.6.x/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH ...nmpi-1.3.3/platforms/linux64GccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.3.3 ...M/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux64/bin/gcc
gzip 1.3.12 /usr/bin/gzip
tar 1.20 /bin/tar
icoFoam 1.6.x ...penFOAM-1.6.x/applications/bin/linux64GccDPOpt/icoFoam
-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

Critical systems ok.


done.


All times are GMT -4. The time now is 18:00.