CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   unable to install openfoam 1.7 using apt-get (http://www.cfd-online.com/Forums/openfoam-installation/78476-unable-install-openfoam-1-7-using-apt-get.html)

maazhmd July 22, 2010 13:53

unable to install openfoam 1.7 using apt-get
 
Hi,

I am a complete newbie to openfoam and am trying to install it,

I get the following message on the screen

root@maaz-laptop:/home/maaz/OpenFoam# apt-get install openfoam170
Reading package lists... Done
Building dependency tree
Reading state information... Done
openfoam170 is already the newest version.
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
openfoam170: Depends: libc6 (>= 2.11) but 2.9-4ubuntu6.2 is to be installed
Depends: libopenmpi1.3 but it is not installable
Depends: libqt4-help (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-network (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-sql (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-webkit (>= 4:4.5.3) but it is not going to be installed
Depends: libqt4-xml (>= 4:4.5.3) but it is not going to be installed
Depends: libqtcore4 (>= 4:4.6.1) but it is not going to be installed
Depends: libqtgui4 (>= 4:4.5.3) but it is not going to be installed
Depends: libscotch-5.1 but it is not installable
Depends: libstdc++6 (>= 4.4.0) but 4.3.3-5ubuntu4 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


this gives a clearer picture I guess

root@maaz-laptop:/home/maaz/OpenFoam# dpkg -i openfoam170_0-1_i386.deb
Selecting previously deselected package openfoam170.
(Reading database ... 110089 files and directories currently installed.)
Unpacking openfoam170 (from openfoam170_0-1_i386.deb) ...
dpkg: dependency problems prevent configuration of openfoam170:
openfoam170 depends on libc6 (>= 2.11); however:
Version of libc6 on system is 2.9-4ubuntu6.2.
openfoam170 depends on libopenmpi1.3; however:
Package libopenmpi1.3 is not installed.
openfoam170 depends on libqt4-help (>= 4:4.5.3); however:
Package libqt4-help is not installed.
openfoam170 depends on libqt4-network (>= 4:4.5.3); however:
Version of libqt4-network on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqt4-sql (>= 4:4.5.3); however:
Version of libqt4-sql on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqt4-webkit (>= 4:4.5.3); however:
Version of libqt4-webkit on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqt4-xml (>= 4:4.5.3); however:
Version of libqt4-xml on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqtcore4 (>= 4:4.6.1); however:
Version of libqtcore4 on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libqtgui4 (>= 4:4.5.3); however:
Version of libqtgui4 on system is 4.5.0-0ubuntu4.3.
openfoam170 depends on libscotch-5.1; however:
Package libscotch-5.1 is not installed.
openfoam170 depends on libstdc++6 (>= 4.4.0); however:
Version of libstdc++6 on system is 4.3.3-5ubuntu4.
dpkg: error processing openfoam170 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
openfoam170

I have a .deb package of openfoam download which was available on the site for a few days.


and when i do a apt-get -f install,

root@maaz-laptop:/home/maaz/OpenFoam# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
libstdc++6-4.3-dev libsm-dev libice-dev x11proto-kb-dev libscotch-dev libgfortran3 g++-4.3 m4 libxdmcp-dev g++ xtrans-dev x11proto-core-dev csh binutils-dev
libxt-dev zlib1g-dev x11proto-input-dev libpthread-stubs0-dev flex libxau-dev libpthread-stubs0 openmpi-bin libscotch-5.0.6 libibverbs1 openmpi-common libx11-dev
libopenmpi-dev libxcb1-dev libopenmpi1
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
openfoam170
0 upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
1 not fully installed or removed.
After this operation, 352MB disk space will be freed.
Do you want to continue [Y/n]?

I gave a no and tried installing the dependencies one by one. For this I built a dependency tree amongst the pakages not installed as

libc6
libstdc++6
libscotch-5.1
libopenmpi1.3
libqtcore4
Depends: libc6 (>= 2.4)
Depends: libstdc++6 (>= 4.1.1)
libqtgui4
Depends: libc6 (>= 2.4)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)
libqt4-webkit
Depends: libc6 (>= 2.3.6-6~)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libqtgui4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)
libqt4-xml
Depends: libc6 (>= 2.4)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)
libqt4-sql
Depends: libc6 (>= 2.1.3)
Depends: libqtcore4 (= 4.5.0-0ubuntu4)
Depends: libstdc++6 (>= 4.1.1)


and started with libc6 and got the following message

root@maaz-laptop:/home/maaz/OpenFoam# apt-get install libc6 -t '4.4*'
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
The following packages were automatically installed and are no longer required:
libstdc++6-4.3-dev libsm-dev libice-dev x11proto-kb-dev libscotch-dev libgfortran3 g++-4.3 m4 libxdmcp-dev g++ xtrans-dev x11proto-core-dev csh binutils-dev
libxt-dev zlib1g-dev x11proto-input-dev libpthread-stubs0-dev flex libxau-dev libpthread-stubs0 openmpi-bin libscotch-5.0.6 libibverbs1 openmpi-common libx11-dev
libopenmpi-dev libxcb1-dev libopenmpi1
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

so I believe I need a source where I can get these libraries but I see quiet a few successful instalation done here need help for the same.

wyldckat July 23, 2010 05:57

Greetings Maaz and welcome to the forum!

Wow! By what I can see in your post, you know your way around apt-get and dpkg! But I've got a strange feeling you didn't check one thing - right at the beginning of the page with the instructions for installing in Ubuntu, it has this information:
Quote:

Originally Posted by http://www.openfoam.com/download/ubuntu.php
OpenFOAM and Paraview are currently available for the following versions of Ubuntu:
  • 10.04 LTS, codename lucid

And by what I've can deduce from your post, you either have installed Ubuntu 9.04 or 9.10! To confirm what version you are using, run:
Code:

lsb_release -a
Sooo... you must either upgrade Ubuntu up to 10.04, or you will have to follow the instructions in "install from source" page: http://www.openfoam.com/download/source.php

Best regards,
Bruno

gdisalvo July 23, 2010 09:02

I experienced this same issue with a new install of Lucid Lynx (Ubuntu 10.04). I think the default install does not enable the "Universe" repositories. These are required to satisfy these dependencies. You can enable these by editing /etc/apt/sources.list and running "apt-get update".

I hope this helps!

maazhmd July 24, 2010 00:32

Thanks wyldckat
And thanks again for a spot on diagnosis, ya I have been using 9.04 and how could I have overlooked the first line :-(.
Trying to build from the source now.

That reminds me.... I am using a ubuntu 9.04 installation on a virtualBox. Anybody has any idea if the virtual box can handle the graphics.

wyldckat July 25, 2010 14:08

Greetings Maaz,

Quote:

Originally Posted by maazhmd (Post 268758)
That reminds me.... I am using a ubuntu 9.04 installation on a virtualBox. Anybody has any idea if the virtual box can handle the graphics.

I haven't got any experience with Virtual Box, but do I have experience with VMPlayer. So, I can only infer that Virtual Box behaves like VMPlayer: they have virtual graphics drivers for the guest OS (in your case, Ubuntu 9.04), that rely on the CPU. Usually 3D hardware acceleration isn't transparent to the guest machine, so you will only have as much power as the CPU on your real machine can handle, with no accelerated GPU assistance :( So, it should work, but waaaay slower than you are use to ;)

Hopefully this will stop being an issue in the next few months, since Intel has been injecting their own brand of GPU into the new processors, so hopefully they will start providing a VT bit/flag for hardware graphics acceleration in virtual machines! :D

Best regards,
Bruno

Basy July 24, 2011 00:44

Quote:

Originally Posted by gdisalvo (Post 268687)
I experienced this same issue with a new install of Lucid Lynx (Ubuntu 10.04). I think the default install does not enable the "Universe" repositories. These are required to satisfy these dependencies. You can enable these by editing /etc/apt/sources.list and running "apt-get update".

I hope this helps!

yes you are right, in case of "maazhmd" maybe it was because of his Linux version but as you said i have just installed a 10.04 lucid on virtual box and same error shows up:
"the following packages have unmet dependencies.."
you suggested editing the "etc/apt/source.lict" but i dont really get you. how should i edit it?

have any one else faced or solved this problem??

thanks to all

wyldckat July 24, 2011 06:38

Greetings Basy,

Quote:

Originally Posted by Basy (Post 317238)
have any one else faced or solved this problem??

Just a week ago someone else also got this problem: http://www.cfd-online.com/Forums/ope...lgeria-dz.html
Read that thread and you should find the solutions for your questions ;)

Best regards,
Bruno

Basy July 24, 2011 11:18

Quote:

Originally Posted by wyldckat (Post 317263)
Greetings Basy,


Just a week ago someone else also got this problem: http://www.cfd-online.com/Forums/ope...lgeria-dz.html
Read that thread and you should find the solutions for your questions ;)

Best regards,
Bruno

thank you so much wyldkat for your attention, after I posted my question here I tried once more and this time every thing was ok!! I'm not sure why. the only thing I changed was in ubuntu software center> software sources> download from, that I choose "Main server".
at the moment I'm not sure if it could be the reason or not, because it is my first day ever in ubuntu. if this was not the reason, the only thing i can think of, is a problem in their website or bad internet connection at first times, that interrupted download procedure and files couldn't transfer completely.

cheers


All times are GMT -4. The time now is 03:11.