CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM 1.7 missing... (http://www.cfd-online.com/Forums/openfoam-installation/78648-openfoam-1-7-missing.html)

tbgan July 28, 2010 23:09

OpenFOAM 1.7 missing...
 
I am new user to Ubuntu 10.4 lucid (32bit). I tried to install OpenFOAM using official website:
http://www.openfoam.com/download/ubuntu.php

but then encounter the following installation problem:
---------------------------------------------------------------------------------------------------------------------------
root@tbgan-desktop:/home/tbgan/OpenFOAM# apt-get install openfoam170
Reading package lists... Done


Building dependency tree


Reading state information... Done


The following extra packages will be installed:


binutils-dev blcr-dkms blcr-util csh flex g++ g++-4.4 libcr0 libgfortran3


libibverbs-dev libibverbs1 libice-dev libmysqlclient16 libnuma1


libopenmpi-dev libopenmpi1.3 libphonon4 libpthread-stubs0


libpthread-stubs0-dev libqt4-designer libqt4-help libqt4-script libqt4-sql


libqt4-sql-mysql libqt4-webkit libqt4-xmlpatterns libscotch-5.1


libscotch-dev libsm-dev libstdc++6-4.4-dev libx11-dev libxau-dev libxcb1-dev


libxdmcp-dev libxt-dev m4 mysql-common openmpi-bin openmpi-checkpoint


openmpi-common x11proto-core-dev x11proto-input-dev x11proto-kb-dev


xtrans-dev zlib1g-dev


Suggested packages:


bison build-essential g++-multilib g++-4.4-multilib gcc-4.4-doc


libstdc++6-4.4-dbg libqt4-dev libstdc++6-4.4-doc gfortran


The following NEW packages will be installed:


binutils-dev blcr-dkms blcr-util csh flex g++ g++-4.4 libcr0 libgfortran3


libibverbs-dev libibverbs1 libice-dev libmysqlclient16 libnuma1


libopenmpi-dev libopenmpi1.3 libphonon4 libpthread-stubs0


libpthread-stubs0-dev libqt4-designer libqt4-help libqt4-script libqt4-sql


libqt4-sql-mysql libqt4-webkit libqt4-xmlpatterns libscotch-5.1


libscotch-dev libsm-dev libstdc++6-4.4-dev libx11-dev libxau-dev libxcb1-dev


libxdmcp-dev libxt-dev m4 mysql-common openfoam170 openmpi-bin


openmpi-checkpoint openmpi-common x11proto-core-dev x11proto-input-dev


x11proto-kb-dev xtrans-dev zlib1g-dev


0 upgraded, 46 newly installed, 0 to remove and 3 not upgraded.


Need to get 83.7MB/118MB of archives.


After this operation, 460MB of additional disk space will be used.


Do you want to continue [Y/n]? y


WARNING: The following packages cannot be authenticated!


openfoam170


Install these packages without verification [y/N]? y


Get:1 http://www.openfoam.com/download/ubuntu/ lucid/main openfoam170 0-1ubuntu1 [83.7MB]


Fetched 1,517B in 2min 10s (12B/s)


Failed to fetch http://www.openfoam.com/download/ubu...0_0-1_i386.deb Size mismatch


E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
-----------------------------------------------------------------------------------------------------------------------------

This is really odd. can anyone help me?
Thanks.

wyldckat July 30, 2010 09:20

Greetings Tian and welcome to the forum!

It looks to me that your apt-get got sourceforge's web page instead of redirecting to the file itself!
So my advice is to download the .deb files by hand from here: http://sourceforge.net/projects/foam/files/foam/1.7.0/
And double clicking on the two of them after being downloaded. Ubuntu's Debian Package GUI will open it and give you the opportunity to install it!

And you only need to download the i386 packages, but I think you already know that :)

Best regards,
Bruno

tbgan August 2, 2010 03:25

thx
 
thank you very much!! problem solve ^^
but one more stupid question..how to start openfoam?i didn't see any "icon" of it..haha:D

wyldckat August 2, 2010 07:28

Hi Tian,

Read the user guide: http://www.openfoam.com/docs/user/ ;)

Best regards,
Bruno


All times are GMT -4. The time now is 08:52.