CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM 1.7 installation on Redhat linux (http://www.cfd-online.com/Forums/openfoam-installation/78807-openfoam-1-7-installation-redhat-linux.html)

maxims August 3, 2010 03:53

OpenFOAM 1.7 installation on Redhat linux
 
Hi, All,
I'm just new to the OpenFOAM. I want to use OpenFOAM on the cluster of our institute. I'm also not so familiar with Linux, I just follow the official website procedure. As I do installation check, I got following message:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: mgmt
OS: Linux version 2.6.18-92.el5
-------------------------------------------------------------------------------

Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home02/qschen/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home02/qschen/OpenFOAM/qschen-1.7.0 no no
$WM_THIRD_PARTY_DIR /home02/qschen/OpenFOAM/ThirdParty-1.7.0 yes yes
-------------------------------------------------------------------------------

Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home02/qschen/OpenFOAM/OpenFOAM-1.7.0 yes yes yes
$FOAM_APPBIN ...7.0/applications/bin/linux64GccDPOpt no yes
$FOAM_SITE_APPBIN ...nFOAM/site/1.7.0/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...7.0/applications/bin/linux64GccDPOpt no no
$WM_DIR ...qschen/OpenFOAM/OpenFOAM-1.7.0/wmake yes yes yes
-------------------------------------------------------------------------------

Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.7.0/lib/linux64GccDPOpt yes yes yes
$FOAM_SITE_LIBBIN ...nFOAM/site/1.7.0/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...OAM/qschen-1.7.0/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH ...0/platforms/linux64Gcc/openmpi-1.4.1 yes yes yes
-------------------------------------------------------------------------------

Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
CRITICAL ERROR: gcc version lower than required
Supplied version: 4.1.2
Minimum required: 4.3.1
gcc 4.1.2 /usr/lib64/ccache/bin/gcc
gzip 1.3.5 /bin/gzip
tar 1.15.1 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home02/qschen/OpenFOAM/OpenFOAM-1.7.0/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR
-------------------------------------------------------------------------------

Summary
-------------------------------------------------------------------------------
Base configuration ok.
*** The foam installation contains 2 critical error(s)
*** Review the output for warning messages and consult
*** the installation guide for trouble shooting.
done.



There seems two errors, one is for lower gcc compiler, what about the other one? Could anyone give me any hint?
Because I use the cluster from institute, the only way to update the gcc is to ask the administrator to do it, right?
I found many no(s) from this checking results, are they important? I really don't know how to deal with it.

Any suggestion will be highly appreciated. Thanks a lot.

Sincerely,
Max

gwierink August 4, 2010 02:18

Hi Max,

Did you compile OpenFOAM or use the binaries?

Quote:

Supplied version: 4.1.2
Minimum required: 4.3.1
gcc 4.1.2 /usr/lib64/ccache/bin/gcc
Do you have a possibility to use or install a newer version of gcc? (perhaps you know, but do you perhaps need to load a gcc module on your cluster?)

j-avdeev November 30, 2012 04:29

Quote:

CRITICAL ERROR: gcc version lower than required
Supplied version: 4.1.2
Minimum required: 4.3.1
I have same error. But I have gcc44 installed. What I have to change in OpenFoam-1.7.1/etc/bashrc ?

$ gcc -v
gcc version 4.1.2 20080704 (Red Hat 4.1.2-52)
$ gcc44 -v
gcc version 4.4.6 20110731 (Red Hat 4.4.6-3) (GCC)

I have tryed to change WM_COMPILER directive in OpenFOAM-1.7.1/etc/bashrc

Quote:

: ${WM_COMPILER:=Gcc44}; export WM_COMPILER

unset WM_COMPILER_ARCH WM_COMPILER_LIB_ARCH
this not helped me.

Also I have OpenFOAM-2.1.1. It works. bashrc in 1.7.1 and 2.1.1 wrote in a bit differ style, but maybe I can use some parts of 2.1.1's bashrc for editing 1.7.1's bashrc?

And, yes, I want 1.7.1 for gdbOF (http://openfoamwiki.net/index.php/Contrib_gdbOF), which works only on 1.7.1.


All times are GMT -4. The time now is 19:37.