CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

ParaView 3.8 in Mac OSX

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   August 8, 2010, 21:42
Default ParaView 3.8 in Mac OSX
  #1
New Member
 
Miguel Suarez
Join Date: Aug 2010
Location: El Paso Texas
Posts: 28
Rep Power: 7
masuarez is on a distinguished road
I'm trying to build paraview following the instructions on the following website:

http://www.paraview.org/Wiki/ParaView:Build_And_Install

I installed Qt 4.6.3 as recommended by the website mentioned above. As I 'make' paraview, the following error appears:

[ 27%] Generating vtkCompositeZPassShader_fs.cxx, vtkCompositeZPassShader_fs.h
[ 27%] Generating vtkSocketCommunicatorHash.h
dyld: Library not loaded: libvtksys.pv3.8.dylib
Referenced from: /paraview-build/VTK/Parallel/../../bin/vtkHashSource
Reason: image not found
/bin/sh: line 1: 74027 Trace/BPT trap ../../bin/vtkHashSource /ParaView-3.8.0/VTK/Parallel/vtkSocketCommunicator.cxx vtkSocketCommunicatorHash vtkSocketCommunicatorHash.h
make[2]: *** [VTK/Parallel/vtkSocketCommunicatorHash.h] Error 133
make[1]: *** [VTK/Parallel/CMakeFiles/vtkParallel.dir/all] Error 2
make: *** [all] Error 2


I'm new to installing programs through source code... usually i just double click and wait for them to be installed. As of two weeks ago I didn't know how to use the "Terminal"... so please, if you know what i should do, be as detailed as possible.

Thanks.
masuarez is offline   Reply With Quote

Old   August 9, 2010, 05:43
Default
  #2
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,915
Rep Power: 40
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by masuarez View Post
I'm trying to build paraview following the instructions on the following website:

http://www.paraview.org/Wiki/ParaView:Build_And_Install

I installed Qt 4.6.3 as recommended by the website mentioned above. As I 'make' paraview, the following error appears:

[ 27%] Generating vtkCompositeZPassShader_fs.cxx, vtkCompositeZPassShader_fs.h
[ 27%] Generating vtkSocketCommunicatorHash.h
dyld: Library not loaded: libvtksys.pv3.8.dylib
Referenced from: /paraview-build/VTK/Parallel/../../bin/vtkHashSource
Reason: image not found
/bin/sh: line 1: 74027 Trace/BPT trap ../../bin/vtkHashSource /ParaView-3.8.0/VTK/Parallel/vtkSocketCommunicator.cxx vtkSocketCommunicatorHash vtkSocketCommunicatorHash.h
make[2]: *** [VTK/Parallel/vtkSocketCommunicatorHash.h] Error 133
make[1]: *** [VTK/Parallel/CMakeFiles/vtkParallel.dir/all] Error 2
make: *** [all] Error 2


I'm new to installing programs through source code... usually i just double click and wait for them to be installed. As of two weeks ago I didn't know how to use the "Terminal"... so please, if you know what i should do, be as detailed as possible.

Thanks.
The problem is that the DYLD_LIBRARY_PATH-variable has to point to the directory where the paraview-libraries (to be concrete libvtksys.pv3.8.dylib) are located. The patches that I provided for the Mac (and others, too) should do that.

So some additional information from your side is required: which version of OF are you using? Which set of patches to make it work on OS X? Have you sourced the appropriate file in etc to "activate" OF?

(if you're compiling Paraview ouside of OF then I would consider your problem to be a pure ParaView-problem and you'd be better off to ask there)

Bernhard
gschaider is offline   Reply With Quote

Old   August 9, 2010, 10:22
Default
  #3
Member
 
Andrew Ryan
Join Date: Mar 2009
Posts: 47
Rep Power: 8
andrewryan is on a distinguished road
@masuarez Did you get the paraview sources from paraview.org? I compiled it myself about two weeks ago and it worked with little trouble. Did you check 64bit / 32bit? As far as I remember I compiled everything for 32 bit.. (but forgot why)
andrewryan is offline   Reply With Quote

Old   August 9, 2010, 14:05
Default
  #4
New Member
 
Miguel Suarez
Join Date: Aug 2010
Location: El Paso Texas
Posts: 28
Rep Power: 7
masuarez is on a distinguished road
@ gschaider One of the problems I have is that I already compiled and installed FreeFoam (not OpenFoam; per my Professor's instructions). Does it matter if I installed FreeFoam first?

I will try to use your patches and see if it works. I'm using the latest version of FreeFoam (0.1.0rc4). Since I'm using FreeFoam, do I have to "activate" it in the etc file?


@ andrewryan I did get paraview sources from paraview.org. However, i do not know how to check the 64bit/32bit?

I think Bernhard is right, this seems to be a Paraview issue more than an OpenFoam issue, I just didn't know where to start. Sorry.
masuarez is offline   Reply With Quote

Old   August 9, 2010, 20:27
Default
  #5
Super Moderator
 
Takuya OSHIMA
Join Date: Mar 2009
Location: Niigata City, Japan
Posts: 518
Blog Entries: 1
Rep Power: 11
7islands is on a distinguished road
Is simply downloading the PV 3.8 binary from paraview.org and using the builtin OF reader not enough? (create an empty stub file with .foam extension under your case directory and open the file from PV)

T
7islands is offline   Reply With Quote

Old   August 9, 2010, 20:35
Default
  #6
New Member
 
Miguel Suarez
Join Date: Aug 2010
Location: El Paso Texas
Posts: 28
Rep Power: 7
masuarez is on a distinguished road
All,

Thank you for your help. I found the solution in the following website:

http://www.paraview.org/pipermail/paraview/2010-June/017725.html


all I had to do was set
VTK_USE_VIEWS ON
during ccmake.

Once again, thank you for your help.

Miguel
masuarez is offline   Reply With Quote

Old   September 12, 2010, 10:07
Default
  #7
Member
 
Josť Rodrigues
Join Date: Jun 2010
Location: IN+/IST Lisbon
Posts: 53
Rep Power: 7
jose_rodrig is on a distinguished road
Quote:
Originally Posted by masuarez View Post
All,

Thank you for your help. I found the solution in the following website:

http://www.paraview.org/pipermail/paraview/2010-June/017725.html


all I had to do was set
VTK_USE_VIEWS ON
during ccmake.

Once again, thank you for your help.

Miguel
Hi,

I am having the same problem as Miguel did but I am installing it with ./makeParaView provided in OF-1.7.1

I have patched the source package with the patches provided by Gschaider and posted here.
I am using Qt 4.6.3 and ccmake 2.8.1

Miguel,
What do you mean by
Quote:
all I had to do was set
VTK_USE_VIEWS ON
during ccmake.
How do you do that?

Thx
jose_rodrig is offline   Reply With Quote

Old   September 12, 2010, 10:12
Default
  #8
Member
 
Josť Rodrigues
Join Date: Jun 2010
Location: IN+/IST Lisbon
Posts: 53
Rep Power: 7
jose_rodrig is on a distinguished road
Hi,

I am having the same problem as Miguel did but I am installing it with ./makeParaView provided in OF-1.7.1

I have patched the source package with the patches provided by Gschaider and posted here.
I am using Qt 4.6.3 and ccmake 2.8.1

Miguel,
What do you mean by
Quote:
Originally Posted by masuarez View Post
all I had to do was set
VTK_USE_VIEWS ON
during ccmake.
How do you do that?

Thx
jose_rodrig is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
ParaView 3.8 -- missing `update GUI option' mirko OpenFOAM Installation 7 August 12, 2011 11:32
ParaView and Qt 4.3.5 on Mac OS X 10.6 Adrian OpenFOAM 3 August 8, 2010 03:16
problem with ParaView 3.8 Chrisi1984 OpenFOAM Paraview & paraFoam 6 July 15, 2010 06:47
OpenFOAM 1.7 ParaView 3.8 installation problems shangzung OpenFOAM Installation 1 July 11, 2010 06:38
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41


All times are GMT -4. The time now is 17:19.