CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   new user wants to get 1.6.x git problem (http://www.cfd-online.com/Forums/openfoam-installation/79480-new-user-wants-get-1-6-x-git-problem.html)

af631717 August 25, 2010 05:27

new user wants to get 1.6.x git problem
 
as a new user I write in the OpenFOAM directory:

git clone http://github.com/OpenFOAM-1.6.x.git (http because of firewall)

and i get the answer:

Initialized empty Git reposity in /hein/OpenFOAM/OpenFOAM-1.6.x/.git
fatal http://github..../info/refs not found: did you run git update-server-info on the server?

Why is it not possible to download OpenFOAM-1.6.x??

1.7.x works still

Achim

wyldckat August 25, 2010 05:41

Greetings Achim,

In GitHub they only have 1.7.x. I've just checked 1.6.x and 1.5.x are still in repo.or.cz.
If you want to do a new git clone of 1.6.x, try this:
Code:

git clone http://repo.or.cz/r/OpenFOAM-1.6.x.git
In case it still doesn't work, try downloading straight from the webpage:
Quote:

Originally Posted by http://repo.or.cz/w/OpenFOAM-1.6.x.git/tree
snapshot (tar.gz zip)

Because 1.6.x is no longer updated, so I think you can get the snapshot without any more worries.

Good luck,
Bruno

af631717 August 27, 2010 10:50

Thank you very much Bruno

a little problem i have with the gcc version. When i run the foamInstallationTest he gives me the warning:

WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.3
User version : 4.3.2
Minimum required: 4.3.1

but in settings.sh there is the 4.3.3. which is in the ThirdParty Package

# Select compiler installation
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# compilerInstall = OpenFOAM | System
compilerInstall=OpenFOAM

case "${compilerInstall:-OpenFOAM}" in
OpenFOAM)
case "$WM_COMPILER" in
---------------------------------------------------

When i want to compile may Foamreader he gave me:


-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
Warning: CMake is forcing CMAKE_CXX_COMPILER to "/home/hans/OpenFOAM/ThirdParty-1.6.x/gcc-4.3.3/platforms/linux64/bin/c++" to match that imported from VTK. This is required because C++ projects must use the same compiler. If this message appears for more than one imported project, you have conflicting C++ compilers and will have to re-build one of those projects. Was set to /usr/bin/c++
-- Loading ParaView CMake commands
-- Loading ParaView CMake commands - done
CMake Error at /home/hans/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/CMake/ParaViewPlugins.cmake:762 (QT4_WRAP_CPP):
Unknown CMake command "QT4_WRAP_CPP".
Call Stack (most recent call first):
/home/hans/OpenFOAM/ThirdParty-1.6.x/paraview-3.6.1/CMake/ParaViewPlugins.cmake:878 (ADD_PARAVIEW_GUI_EXTENSION)
CMakeLists.txt:44 (ADD_PARAVIEW_PLUGIN)


-- Configuring incomplete, errors occurred!

It is strange because i changed nothing an now he wants my system compiler.
Regards
Achim

wyldckat August 27, 2010 11:09

Greetings Achim,

I think you only got the source package for ThirdParty-1.6... and you have yet to build gcc that comes with it and ParaView too.
In the link in my signature you can find links to threads that explain how to build gcc and paraview for OpenFOAM 1.6/1.6.x:

But if you are running Ubuntu (8.10 to 10.04), you might want to use the openfoam-ubuntu script: http://code.google.com/p/openfoam-ubuntu/

Best regards,
Bruno

af631717 August 27, 2010 11:17

last question
 
Thanks again Bruno,

i will do so but i have one question

until 2 days my system (OF1.6.x) went well until something went wrong with git.
I have two identical computers. On the other OF1.6.x is running fine.
I tried to tar both directories (OF1.6.x and the Thirdparty Package) an copied to the broken installation.
It should work or am i wrong? But it does not work. Why?

Before the mess happened i installed 1.7.x but this should not be the reason?
Regards
Achim

wyldckat August 27, 2010 11:55

Hi Achim,

I can only assume that your "~/.bashrc" file is misconfigured on the broken machine. Remove the lines you have in it that refer to each OpenFOAM bashrc file, and put these in it:
Code:

alias of16x='. $HOME/OpenFOAM/OpenFOAM-1.6.x/etc/bashrc'
alias of17x='. $HOME/OpenFOAM/OpenFOAM-1.7.x/etc/bashrc'

Now, every time you start a new terminal, either type of16x or of17x, but never both in the same terminal! This way you can use either version with the minimum effort :)

Best regards,
Bruno

af631717 August 27, 2010 12:39

nice weekend
 
Hi Bruno

many thanks.

I deinstalled gcc !! (with yast) and everything works now. Now my Linux has no system compiler any more !! but everthing works. Copied the OF from the old machine to the broken one.
Now i can enjoy my weekend.

Thanks again - hope i will meet you somewhere to invite you for a beer :)

Achim


All times are GMT -4. The time now is 20:33.