CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

missing vtf3.h BPatch.h papi.h

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 24, 2012, 05:28
Default
  #41
Senior Member
 
Illya Shevchuk
Join Date: Aug 2009
Location: Darmstadt, Germany
Posts: 174
Rep Power: 7
linch is on a distinguished road
Hi Bruno,

mpi-default-bin & mpi-default-dev did the job. I've got lots of warnings
Quote:
UOPwrite.C: warning: use of old-style cast
but no erors and mpirun works,

Thank you very much!
Illya

P.S. I've just compiled OF 2.1.x on another WS with the same Debian. There were no problems this time with the compilation of the OF-internal openmpi, but there were also a lot of "old-style cast" warnings.

Last edited by linch; July 24, 2012 at 06:36.
linch is offline   Reply With Quote

Old   July 24, 2012, 14:45
Default
  #42
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Illya,

Quote:
Originally Posted by linch View Post
mpi-default-bin & mpi-default-dev did the job.
Finally!

Quote:
Originally Posted by linch View Post
I've got lots of warnings but no erors and mpirun works,
Don't worry, those are normal. It's only a matter of coding elegance vs time necessary to remove those warnings...

Quote:
Originally Posted by linch View Post
P.S. I've just compiled OF 2.1.x on another WS with the same Debian. There were no problems this time with the compilation of the OF-internal openmpi, but there were also a lot of "old-style cast" warnings.
WS: work space? Maybe workstation? Mmmm... then my guess is it's either due to one of two reasons:
  1. Your first work space/station is contaminated somehow; for example, the Intel compiler and the custom MPI might not be directly visible on the new one.
  2. The system/default MPI clears any doubts that OpenFOAM might have
Either way, a clean Debian installation in a virtual machine had already revealed itself to be as simple as following the same instructions as for Ubuntu

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://www.cfd-online.com/Forums/openfoam-installation/80787-missing-vtf3-h-bpatch-h-papi-h.html
Posted By For Type Date
Albert's Useful Computer Tips: gcc and OpenFOAM This thread Refback October 16, 2013 05:46

Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing Term in RAS-Models ngj OpenFOAM Bugs 17 February 29, 2012 08:05
UDF: DEFINE_CG_MOTION for vertical jump motion of an electrode! alban Fluent UDF and Scheme Programming 2 June 8, 2010 18:54
Problem with paraFoam ata OpenFOAM 14 November 30, 2009 05:23
Missing output files stefanke OpenFOAM Running, Solving & CFD 4 September 8, 2006 04:51
Missing tets along line when meshing with ICEM CFD Georges P. Côté CFX 6 March 23, 2006 01:34


All times are GMT -4. The time now is 23:13.