CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   difficulty with paraview compiling (http://www.cfd-online.com/Forums/openfoam-installation/80816-difficulty-paraview-compiling.html)

linch October 7, 2010 08:36

difficulty with paraview compiling
 
me again with yet another installation problem

Paraview compilation with ./makeParaView returns me a bunch of errors:
Quote:

-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - not found.
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
CMake Error at CMakeLists.txt:96 (MESSAGE):
Qt 4.5.0 or greater not found. Please check the QT_QMAKE_EXECUTABLE
variable.
Quote:

Qt QTGUI library not found.
Qt QTSQL library not found.
Qt QTNETWORK library not found.
Qt QTCORE library not found.
CMake Error at VTK/GUISupport/Qt/Chart/CMakeLists.txt:11 (MESSAGE):
Qt 4.2.2 or greater not found. Please check the QT_QMAKE_EXECUTABLE
variable.
etc.

QT version 4.6.3 is installed in /usr/lib with qmake version 2.01a in /usr/bin
Libraries libQtGui.so.4.6.3 libQtSql.so.4.6.3 libQtNetwork.so.4.6.3 and libQtCore.so.4.6.3 are present.

linch October 7, 2010 11:27

Finally I gave up compiling the paraview and installed the precompiled version. It works.

msuho October 12, 2010 12:19

I am getting this same error while building paraview on RHEL5 with OpenFoam 1.7.1.
I have QT 4.6.2 in my PATH & LD_LIBRARY_PATH. The odd thing is that the make does not abort- it will build paraview, which will run- but if it's called via paraFoam,
it dies immediately, sqawking about VTK errrors.

gwierink October 13, 2010 02:44

Did you also have the "Please check the QT_QMAKE_EXECUTABLE variable" error? If so, have you set it? I actually don't know where you should set it; I guess in the cmake file or even in your bashrc ...

msuho October 13, 2010 09:02

Gijs-

After some consideration, I set it in the makeParaView script, and that seems to
work.

On a similar note, I noticed that Paraview's default settings do not build paraview with MPI. If I turn that on, there are a bunch of MPI variables that Paraview expects as well.
The Paraview build instructions set these with some cmake gui tool I've never heard of-
I guess I'll try setting these in the MakeParaview file, too- or just leave it without MPI did get the thing working :)

Thanks,

Mark

gwierink October 13, 2010 10:24

Hi Mark,

Good to hear you got it working!

Do you mean the cmake gui or CL interface? I guess you can set the MPI related paths there (MPI_INCLUDE_PATH, MPI_LIBRARY etc) to the openmpi paths in ThirdParty (?) ...

Ingenierias2003 October 13, 2010 14:50

Paraview problems
 
Dear's

I have the same problem when try to compile the paraview please let me know what variable have to change.

My deep regards.

Respectfully
Javier

msuho October 13, 2010 15:07

Javier-

I set the QT_QMAKE_EXECUTABLE to point to my qmake executable in the
makeParaView file that's in the top directory of the third party tar, then ran it.
If it works you should see it find your QT executable when you run makeParaView

Mark

Ingenierias2003 October 13, 2010 17:54

Paraview problems
 
Dear Mark,

Sorry but really i can't find QT_QMAKE_EXECUTABLE and makeparaview. I found -qmake in the makeparaview executable. I don't know is i am right but you try to say that modified the
QMAKE_PATH="~/OpenFOAM/ThirdParty-1.7.x/paraview-3.8.0/Qt"

Sometime like that?

Please help me!!!!!!:confused:

Respectfully
Javier

I set the QT_QMAKE_EXECUTABLE to point to my qmake executable in the
makeParaView file that's in the top directory of the third party tar, then ran it.
If it works you should see it find your QT executable when you run makeParaView

Mark

gwierink October 14, 2010 03:32

Hi Javier,

Shouldn't the QMAKE_PATH point to the path where the actual qmake executable lives? Can you find that out by
Code:

which qmake
and plug that into the QMAKE_PATH variable? I'm sorry, I haven't used paraFoam for ages, usually use VTK (for Lagrangian particles). Besides, ParaView-3.8.x+ also works with OpenFOAM files (as Anton Kidess mentioned in some other post, forgot which one). Just do
Code:

touch caseName.foam
where caseName is the name of your case, and open the .foam file with paraview.

wyldckat October 14, 2010 07:28

Greetings to all!

Here are the solutions that I've been using for a while, for some of your questions:
  • For building ParaView with your custom Qt, run:
    Code:

    ./makeParaView -qmake $QT_PLATFORM_PATH/bin/qmake
    Where QT_PLATFORM_PATH has the path to where you installed your custom Qt. If you don't know where it's installed, but you know it should be in your ThirdParty folder, then run this:
    Code:

    find $WM_THIRD_PARTY_DIR/ -name qmake
    This should give you the complete path to where qmake is installed.
  • For building ParaView with MPI, it should work by simply running with the "-mpi" option:
    Code:

    ./makeParaView -mpi
  • For doing both, I assume you figure out how to do both in one go, but just in case, here it is:
    Code:

    ./makeParaView -mpi -qmake $QT_PLATFORM_PATH/bin/qmake
    By the way, if you want Python to be added in the mix, run with the additional option "-python"... although you might want to confirm which version of Python it expects to find, by editing the makeParaView script and update the Python related line if necessary.
  • Like Gijsbert said, as of ParaView 3.8.0 the internal reader for OpenFOAM works as intended. If after you follow Gijsbert's instructions you find out that it works very well, then you can follow these instructions:
    Quote:

    Originally Posted by http://www.cfd-online.com/Forums/blogs/wyldckat/317-using-official-pre-built-paraview-3-8-0-version-openfoam.html
    Now open the file "$HOME/OpenFOAM/OpenFOAM-1.7.0/bin/paraFoam" in your favorite simple text editor and replace every entry ".OpenFOAM" with ".foam". Now save and close the file.

    (Mmmm.. a bit outdated, I gotta update those instructions...)
Best regards,
Bruno


All times are GMT -4. The time now is 07:08.