CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenFOAM repository cannot be authenticated ... (

Xwang October 23, 2010 14:42

OpenFOAM repository cannot be authenticated ...
Hi to all,
I would like to install the OpenFOAM ubuntu package as explained in but synaptic warns me that the software cannot be authenticated and so I wonder if it is safe and if and how to ask OpenCFD for a better level of security for this repo.
Any idea?
Thank you,

wyldckat October 24, 2010 17:09

Greetings Xwang,

If you don't trust the hidden download links via Synaptic, you can always download the Debian files from here:
That is from where the system implemented by OpenCFD will get the files from.
The files you'll be wanting are:
  • openfoam171_0-1_amd64.deb or openfoam171_0-1_i386.deb
  • paraviewopenfoam380_0-1_amd64.deb or paraviewopenfoam380_0-1_i386.deb
It depends on your installed Ubuntu architecture. If you don't know, run:

uname -m
NOTE: x86_64 is pretty much the same as amd64.

After downloading, simply double-click on each downloaded file and let gdebi-gtk help you install each the package :)

If you feel strongly about them not having a secure/validated system to work with Synaptic, you can always "complain" about it here: ;)

Best regards,

elvis October 27, 2010 14:49


there is also the "not official" ubuntu repository made by Oliver Borm for those interested in OF1.5-dev it has nice features (GGI) you do not find in OF1.7.x! =>take a look what is located

sudo add-apt-repository ppa:cae-team/ppa
sudo apt-get update
sudo apt-get install openfoam-dev-1.5

All times are GMT -4. The time now is 12:09.