CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM 1.7.1 installation on LINUX UBUNTU 10.10 (http://www.cfd-online.com/Forums/openfoam-installation/81569-openfoam-1-7-1-installation-linux-ubuntu-10-10-a.html)

electrosin October 30, 2010 21:34

OpenFOAM 1.7.1 installation on LINUX UBUNTU 10.10
 
Hi everyone
I'm just installed UBUNTU 10.10 and downloaded the OpenFOAM 1.7.1
I'm new in linux and I'm trying to install the OpenFOAM.

I've followed the installation instruction from OpenFOAM website but I
can't get it installed on my computer. It seems like the command they
show in their site (which has to be typed in terminal) is different from the UBUNTU 10.10 version that I'm actually use (or maybe not, since I'm newbie:p)

can you tell me how to install it on LINUX UBUNTU 10.10 ?
or maybe there's already a thread for this problem...
if it so, then I'm sorry for making this thread:(
(and please tell me show me the thread if it exist)

Thx

gwierink October 31, 2010 08:25

Hi Jonathan,

There are indeed more threads on these things, e.g. here, here, and here. But it is probably useful to see what's exactly the problem. Where do you get stuck in the standard installation instructions? What error messages do you get etc?

electrosin November 1, 2010 07:34

I'm actually get stuck in environment variable settings where the instruction tell me to run a file named bashrc. when I try to run it, it gave me comment like 'no such directory or file exist'

And by the way can I install it on LINUX MINT 9? I mean it's just the same with Ubuntu isn't it

Thx for your help

gwierink November 1, 2010 09:51

Hi Jonathan,

Quote:

I'm actually get stuck in environment variable settings where the instruction tell me to run a file named bashrc. when I try to run it, it gave me comment like 'no such directory or file exist'
Ok, good, this is something concrete :). What you need to do is add a line to a file called $HOME/.bashrc (note the dot before "bashrc"). This file is sourced every time you open a terminal or tell it to be sourced. Sourcing simply means that the environment variables (simply put, rules with names for paths and some programs etc) are updated. The dot before "bashrc" (that is ".bashrc") makes the file normally not visible in your home directory, so it looks less messy. So, the thing is that you need to make bashrc update OpenFOAM's rules together with the rules (environment variables) of your system. You do this as follows:

Open a terminal and type (don't forget the dot!)
Code:

gedit $HOME/.bashrc
This opens the file .bashrc in your home directory. Then, in that file, add a line that makes .bashrc source OpenFOAM's own bashrc. So, add this line:

(dont't forget the dot at the start and note there's a space between the dot and /opt/....)
Code:

. /opt/openfoam171/etc/bashrc
That is, if you used the Ubuntu method as described here. Then, save and close the file. After that you need to source .bashrc by typing in the terminal:

(note, two dots this time and also a space between the first dot and $HOME/.bashrc)
Code:

. $HOME/.bashrc
Quote:

can I install it on LINUX MINT 9?
Yes, no problem. Although I am not sure whether you can use the "sudo apt-get" method as described on the OpenFOAM website. Mint is, like Ubuntu, a Debian derivative and very similar to Ubuntu. You might be able to use the same method, but I am not sure. If not, you can either download the OpenFOAM binaries or compile it yourself. Both no problem.

emix101 November 9, 2010 10:00

Hi evrybody; I'm new here.
done searching all over the internet for answer on how to install openfoam on my ubuntu 10.10,my problem is also the same with electrosin:confused:..

I tried to follow gwirink guide but when i run
. $HOME/.bashrc

the output was like this
Quote:

bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamEtcFile: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamCleanPath: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamCleanPath: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamCleanPath: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/etc/settings.sh: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/etc/aliases.sh: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/etc/apps/paraview3/bashrc: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/etc/apps/ensight/bashrc: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamCleanPath: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamCleanPath: No such file or directory
bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamCleanPath: No such file or directory
I install this using source pack and under root command.

Anyone couls help me??:confused:

gwierink November 9, 2010 12:04

Hi Faiez,

Quote:

I install this using source pack and under root command.
Why? I think this is a bad idea. It's better to do it as a normal user.

Quote:

bash: /root/OpenFOAM/OpenFOAM-1.7.1/bin/foamEtcFile: No such file or directory
Well, it looks like you may have compiled as root, but not in the root directory, but e.g. in your user home. So, when you then source bashrc you're sourcing root's bashrc, but have the OpenFOAM line in your user's bashrc.
I suggest you install/compile as normal user. But if you explicitely want to install as root, you need to source OpenFOAM in root's bashrc, i.e.

Code:

su
gedit /root/.bashrc &

Then add
Code:

. /opt/openfoam171/etc/bashrc
(or whatever version you have ...), save and close the file.
And finally source root's bashrc by typing as root
Code:

. $HOME/.bashrc
But again, I really think it's better to install as user ...

prof_eng_abdelsalam December 24, 2010 15:40

Urgent
 
Please Iím new in this field of OpenFOAM and I need your help .How I can

install this Programme on my computer . I need the details such as what

operating system I should use, and all other instruction

(I donít know anything).


Iíll use it in my doctorial studies so I need help quickly as possible.

Thanks.

gwierink December 25, 2010 03:27

Dear Abdelsalam,

Probably the easiest to start with would be Ubuntu, since it is a quite easy system to use, lots of documentation, and OpenCFD has released a Debian package of OpenFOAM (i.e. works on Ubuntu out of the box). Just follow the links and have a go.

morard January 6, 2011 09:07

Hello all,
I am trying to install OpenFOAM 1.7.1 on my UBUNTU 10.10, but there is a problem:

/usr/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status

Do you know how to solve this?

akidess January 6, 2011 09:22

Dejan, this question has been asked and answered numerous times, eg. http://www.cfd-online.com/Forums/ope...compiling.html.

morard January 6, 2011 10:14

Sorry....

Thanks for the liberty, it works now.
But, I have problems with Paraview. When I execute ./Allclean, this happens:

++ rm -rf 'platforms/build-*'
++ cd openmpi-1.4.1
++ make distclean
make: *** No rule to make target `distclean'. Stop.
.....
.....

/bin/sh: gmake: not found

This is probably again something trivial, but I have very little experience with ubuntu.

morard January 6, 2011 10:18

I solved problems. :)

rlobosco January 19, 2011 12:29

gmake not found
 
Hi morard,
How did you solve the problem of gmake not found?
I have the same problem.
With best regards,
rlobosco

morard January 19, 2011 13:30

Hi rlobosco,

if I remember correctly, I've done the following:

sudo aptitude install Qt

I found this somewhere on the forum. inform me if this works.

Best

wyldckat January 19, 2011 18:30

Greetings to all!

@rlobosco: About gmake, I've already mentioned this before in another thread:
Quote:

Originally Posted by wyldckat (Post 288946)
The error associated to gmake is an ironic error: gmake stands for GNU make, which is the version usually packed with Linux distributions and always named as make. So, the simplest fix is to make a symbolic link of gmake to make; a simple non-root way to do this is:
Code:

ln -s `which make`  $WM_PROJECT_DIR/bin/gmake
This should create a symbolic link of make to the link gmake in OpenFOAM's bin folder.

Best regards,
Bruno

blubberino January 26, 2011 07:41

Hi everyone,

i want to install openFOAM on Ubuntu 10.10. All systemupdates are installed.
When I type the command "sudo apt-get install openfoam171" I get the following error:

openfoam171: Hšngt ab: libncurses5 (>= 5.7+20100313) aber 5.7+20090803-2ubuntu3 soll installiert werden
E: Kaputte Pakete

akidess January 26, 2011 07:49

To put your problem into more human readable form: The openfoam deb package specifies a dependency of libncurses that comes with ubuntu 10.10, but then asks the package manager to install the package from ubuntu 10.04 (20090803).

A solution might be that you manually install libncurses from your package manager, after which the dependency will be satisfied before the installer can trip over it.

chichovet February 6, 2011 11:32

Problem with First Code on Open Foam
 
I'm getting started with the ubuntu and open foam.
I already got a problem with the first step for installing the OpenFoam. When I introduce the code in the terminal. it gives me this answer.
sh: cannot open maverick: No such file
I got Ubuntu 10.10 and i have looked everywhere for answers, but hadn't find anything.
Can someone tell me what to do
Thanx
Rogelio

gwierink February 7, 2011 04:33

Hi Rogelio,

Quote:

When I introduce the code in the terminal. it gives me this answer.
sh: cannot open maverick: No such file
Can you explain in detail what you have done and what command you give that results in the error?

chichovet February 7, 2011 10:09

Quote:

Originally Posted by gwierink (Post 293925)
Hi Rogelio,


Can you explain in detail what you have done and what command you give that results in the error?

Hi,
As it says at the openfoam page i introduced in the terminal this code:

sudo sh -c "echo deb http://www.openfoam.com/download/ubuntu <maverick> main >> /etc/apt/sources.list"

after that the terminals gives me the error tha i writed above.
Thanks for the help


All times are GMT -4. The time now is 12:34.