CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OF 1.7.1 on Fedora 13 (http://www.cfd-online.com/Forums/openfoam-installation/81732-1-7-1-fedora-13-a.html)

tonyuprm November 4, 2010 21:21

OF 1.7.1 on Fedora 13
 
1 Attachment(s)
Hi,

Im trying to install OpenFOAM on a Fedora 13 machine but the installer stops after running for 2 hours with the following error:

make: Target `application' not remade because of errors.

Attached is the log file.

Attachment 5275

Thanks

wyldckat November 5, 2010 11:12

Hi Tony,

The solution is pretty simple: run Allwmake again :)

There is a bug in Allwmake in the ThirdParty folder, which doesn't create the necessary folder for libscotch to be copied to. But the second time it's executed, the folder already exists from the previous run.

Best regards,
Bruno

Achin November 6, 2010 02:21

Error in making the target 'application'
 
Hi

I had the same problem i.e

make: *** [thermophysical] Error 2
make: Target `application' not remade because of errors.

This continued to occur even on 3rd run of ./Allwmake. I am trying to install OF in Fedora 13. Kindly Help.

l_r_mcglashan November 6, 2010 05:58

Let's see, in your make log you have:

/usr/bin/ld: cannot find -liberty

Can you 'locate libiberty'?

I think you need to install binutils. If you're using fedora then 'yum install binutils-devel' as root.

I just installed Fedora 14, I'll be installing OF on that when I have time.

Achin November 6, 2010 11:52

Hi Laurance

I installed binutils also but still application couldn't be made.

Abhinav

wyldckat November 6, 2010 16:06

Greetings Abhinav,

Could you post the new make.log file?

Just in case you don't know what I'm talking about, run Allwmake like so:
Code:

./Allwmake > make.log 2>&1
tar -czf make.log.tar.gz make.log

Then attach the file "make.log.tar.gz" to your next post.

Best regards,
Bruno

Achin November 6, 2010 16:20

1 Attachment(s)
Hi Bruno

Here is the log file.

Abhinav

wyldckat November 6, 2010 16:26

Hi Abhinav,

:eek: You don't even gcc nor g++ installed? Here are the packages you need to install in Fedora before you start building OpenFOAM:
Quote:

Originally Posted by http://www.idurun.com/?p=544
Before compiling the packages, you must prepare some necessary packages on your system:
  • binutils-static # it provides libiberty.a and others
  • python-devel # if you want the python support in paraview
  • qt-devel # I suppose you like it. Yes, it provides qmake-qt4
  • cmake # it is mandatory for compiling paraview
  • flex
Please use yum to install them:
Code:

sudo yum install -y binutils-static python-devel qt-devel cmake flex

Edit: I reviewed the file and noticed you are installing OpenFOAM 1.7.1 (in Fedora 13, I guess). You'll need to do a little modification before starting to build it:
Quote:

Originally Posted by http://www.openfoam.com/mantisbt/view.php?id=15
In $WM_DIR/rules/linux64Gcc/c++, change LINKEXE to this:
Code:

LINKEXE = $(CC) $(c++FLAGS) -Xlinker --add-needed

Edit2: Sorry, forgot to mention that you also need to install gcc and g++ :( I thought that blog I quoted had the whole list :( Here is another yum command line form an old post of mine for Fedora 12:
Quote:

Originally Posted by wyldckat (Post 254189)
Code:

yum install gcc gcc-c++ binutils-devel flex git-core wget cmake qt4-devel python-devel readline-devel bison

Good luck!
Bruno

Achin November 6, 2010 16:36

Hi Bruno

I checked and found that I dont have g++ installed although gcc is there and working. Any ways I'll install other packages first. Should I do "yum install gcc-c++".

Abhinav

wyldckat November 6, 2010 16:41

Hi Abhinav,

Yep :) review my previous post... I've been editing it... twice I've had to review it... this is really the end of my week, I'm just running on fumes :D

A final note (or so I hope ;)): check if you have the file /lib/gcc. If not, run this in superuser/root:
Code:

ln -s `which gcc` /lib/gcc
Best regards,
Bruno

l_r_mcglashan November 6, 2010 18:08

Wow, no g++? Welcome to the wonderful world of Fedora!

vnpenguin November 7, 2010 14:14

Quote:

Originally Posted by l_r_mcglashan (Post 282473)
Wow, no g++? Welcome to the wonderful world of Fedora!

No problem. Just "yum install gcc\*" ;)

tonyuprm November 9, 2010 01:08

Thanks,

I tried running the Allwmake script again but it didnt work. I installed some dependencies which i was missing and changed the LINKEXE line that Bruno suggested. Now the installation is working fine.

Thanks,

Tony

vnpenguin November 11, 2010 11:59

With the patch of $WM_DIR/rules/linux64Gcc/c++ suggested by Bruno, I can build OpenFOAM 1.7.1 on Fedora 14 too :)

Achin November 12, 2010 13:44

Here is a log file.
I installed the all the dependencies.
I changed the LINEXE file as
LINKEXE = $(CC) $(c++FLAGS) -Xlinker --add-needed
I tried installing as root since I observed "Permission Denied" for some files in log file.
But still there is the problem.
any ideas?
I am trying to install OpenFoam 1.7 on Fedora 13.


Sorry no logfile could be uploaded as it's size was more than allowed.
Abhinav

wyldckat November 12, 2010 14:03

Hi Abhinav,

Compress the log like this:
Code:

tar -czf make_log.tar.gz make.log
Best regards,
Bruno

Achin November 12, 2010 15:28

2 Attachment(s)
Hi Bruno

It was the compressed file I was talking about which couln't be uploaded as it was 126 kb while the allowed size is of 97kb for one attachment. Any way I made the whole log in two parts and now I have attached two compressed files. I was trying to install as root.

Regards
Abhinav

wyldckat November 12, 2010 18:36

Hi Abhinav,

Mmm, this week was longer than I thought... I didn't even remember about telling you how to compress the file in a previous post :(

OK, the only thing that pops into my head is this: you have Fedora i686 and not x86_64, therefore the correct file to change would be "$WM_DIR/rules/linuxGcc/c++". But to be really sure of which rule version you are using, try this:
Code:

echo $WM_DIR/rules/$WM_ARCH$WM_COMPILER/c++
Because the errors you are getting are associated to that LINKEXE line, namely the missing two options for Fedora!

Best regards,
Bruno

l_r_mcglashan November 13, 2010 07:26

Also, why not use the Git repository. It's up to date with all those fixes and will compile on Fedora 13/14 no problem.

vnpenguin November 13, 2010 10:26

Quote:

Originally Posted by l_r_mcglashan (Post 283315)
Also, why not use the Git repository. It's up to date with all those fixes and will compile on Fedora 13/14 no problem.

Yes, you're right. With Git repo I just build no problem on Fedora 14 :)

Thanks,


All times are GMT -4. The time now is 09:20.