CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OF 1.6 critical errors on Ubuntu 10.04 32bit (http://www.cfd-online.com/Forums/openfoam-installation/82405-1-6-critical-errors-ubuntu-10-04-32bit.html)

ecto November 25, 2010 06:27

OF 1.6 critical errors on Ubuntu 10.04 32bit
 
Hi everybody!
This is what foamInstallationtest says to me:

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: acer
OS: Linux version 2.6.32-26-generic
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/ecto/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/ecto/OpenFOAM/root-1.6.x no no
$WM_THIRD_PARTY_DIR /home/ecto/OpenFOAM/ThirdParty-1.6.x yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/ecto/OpenFOAM/OpenFOAM-1.6.x yes yes yes

$FOAM_APPBIN ...1.6.x/applications/bin/linuxGccDPOpt yes yes yes
$FOAM_SITE_APPBIN ...penFOAM/site/1.6.x/bin/linuxGccDPOpt no no
$FOAM_USER_APPBIN ...1.6.x/applications/bin/linuxGccDPOpt no no
$WM_DIR /home/ecto/OpenFOAM/OpenFOAM-1.6.x/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.6.x/lib/linuxGccDPOpt yes yes yes
$FOAM_SITE_LIBBIN ...penFOAM/site/1.6.x/lib/linuxGccDPOpt no no
$FOAM_USER_LIBBIN ...penFOAM/root-1.6.x/lib/linuxGccDPOpt no no
$MPI_ARCH_PATH ...penmpi-1.3.3/platforms/linuxGccDPOpt no yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.3.3
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/local/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.22 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/ecto/OpenFOAM/OpenFOAM-1.6.x/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.


Could anyone help me?
Regards

ecto November 25, 2010 09:07

I've been searching on google for a day, but no solution... Please

wyldckat November 25, 2010 10:56

Greetings Ecto and welcome to the forum!

You're not giving us much information to go on.
The output from foamInstallationtest tells us only that gcc is not where it expects it and that you have not successfully built OpenFOAM.

You also haven't told us which instructions you've followed and for example, if you've already tried building OpenFOAM 1.7.1 or 1.7.x from source, which are the latest stable and bug fix versions of OpenFOAM.
So I can only assume that you really need the 1.6 version due to some dependency on other applications/utilities made to work with OpenFOAM 1.6, that haven't been updated to 1.7.

So, first of all, the packages needed to build OpenFOAM in recent Ubuntus are listed here: Building OpenFOAM1.7.0 from source post #4 and onward

Secondly, following the official instructions will still apply for OpenFOAM 1.6 (adapt where needed): Source Pack Installation


If you could use OpenFOAM 1.6.x instead of 1.6, then you could use the script available here: OpenFOAM 1.6.x Installer for Ubuntu

Good luck! Best regards,
Bruno


All times are GMT -4. The time now is 05:56.