CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFoam is broken

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 2, 2010, 16:13
Default OpenFoam is broken
  #1
Member
 
Pierre
Join Date: Sep 2010
Posts: 57
Rep Power: 6
Leech is on a distinguished road
Hi,

i was using Openfoam every day the last weeks. But i got strange problems. First my paraview was broken. So i just tiped in again sudo apt-get install paraview. It got installed new and then was working again. But paraview now always gives an output windows with some errors. But it worked at least.
Since today Openfoam quiited completely. Paraview works.
I cant use blockMesh oder simpleFoam or anything.
E.g. when using simpleFoam he returns:
Code:
/*---------------------------------------------------------------------------*\
| =========                 |                                                 |
| \\      /  F ield         | OpenFOAM: The Open Source CFD Toolbox           |
|  \\    /   O peration     | Version:  1.7.x                                 |
|   \\  /    A nd           | Web:      www.OpenFOAM.com                      |
|    \\/     M anipulation  |                                                 |
\*---------------------------------------------------------------------------*/
Build  : 1.7.x-3776603e4c6c
Exec   : simpleFoam
Date   : Dec 02 2010
Time   : 21:02:41
Host   : pierre-desktop
PID    : 3318
fileName::stripInvalid() called for invalid fileName /home/pierre/Run/HA1-Pierre/Kanal_Re1000000
    For debug level (= 2) > 1 this is considered fatal
Aborted
tipind sudo apt-get install openfoam171 says that everything is up to date. apt-get update did something but still isn't working. Pc restart didn't help.

Ubuntu 10.04 with Openfoam171 64bit.

Thanks for your help
Leech
Leech is offline   Reply With Quote

Old   December 2, 2010, 17:04
Default
  #2
Member
 
Pierre
Join Date: Sep 2010
Posts: 57
Rep Power: 6
Leech is on a distinguished road
Hi,

i just found the following thread:
paraFoam crash
There is described, that i have to look for inconsistent file names. But i didn't changed any file name. I also tried to simpleFoam old cases that were working. And also there Foam didn't wanted to start.

So, any suggestions for this problem?
Thanks anyone!
Leech
Leech is offline   Reply With Quote

Old   December 4, 2010, 09:55
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Leech,

Yeah, there were some problems with OpenCFD's update for OpenFOAM 1.7.1 Debian/Ubuntu packages And you are not alone in this issue, so there is already a solution for this: After Update Ubuntu "/opt/openfoam171/bin/paraFoam: 142: paraview: not found"

Edit: oops, I had to read your posts again. This is odd... where do you indicate the reference to use the file "/home/pierre/Run/HA1-Pierre/Kanal_Re1000000"?

Best regards and good luck!
Bruno

Last edited by wyldckat; December 4, 2010 at 10:01. Reason: see "Edit:"
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cross-compiling OpenFOAM 1.7.0 on Linux for Windows 32 and 64bits with Mingw-w64 wyldckat OpenFOAM Announcements from Other Sources 3 September 8, 2010 06:25
Modified OpenFOAM Forum Structure and New Mailing-List pete Site News & Announcements 0 June 29, 2009 05:56
Subscriptions of OpenFOAM forum broken jola Site News & Announcements 1 April 2, 2009 14:51
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
OpenFOAM Debian packaging current status problems and TODOs oseen OpenFOAM Installation 9 August 26, 2007 13:50


All times are GMT -4. The time now is 00:50.