CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Building ThirdParty from OpenFOAM-1.6-ext (http://www.cfd-online.com/Forums/openfoam-installation/83639-building-thirdparty-openfoam-1-6-ext.html)

cnsidero January 5, 2011 23:47

Building ThirdParty from OpenFOAM-1.6-ext
 
I was attempting to build the ThirdParty stuff in 1.6-ext on my Ubuntu 10.10 workstation last night and stages 0-3 went fine but it skipped over stage 4 stating "Using system installed QT".

So I looked in Allmake.stage4 - lines 60-66 are the following:

Code:

if [ ! -z $QT_THIRD_PARTY ]
then
    ( rpm_make qt-everywhere-opensource-src-4.7.0 http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.7.0.tar.gz )
else
    echo "Using system installed QT"
    echo ""
fi

Which says if QT_THIRD_PARTY is non-zero then get and build QT. For me the QT_THIRD_PARTY variable is empty and I couldn't find where/what script would set this variable to trigger the installation of QT. Is this something we're supposed to set manually with a dumby value (e.g. export QT_THIRD_PARTY=1)?

Or am I way off base?

cnsidero January 6, 2011 00:32

I hate replying to my own threads but sure enough right after I posted I found an answer to my question.

In the $WM_PROJECT_DIR/etc directory is a file called prefs.sh-EXAMPLE. In there is where one tells the build what to do about QT (use system or build third party version).

I just copied prefs.sh-EXAMPLE to prefs.sh, uncommented 'export QT_THIRD_PARTY=1' and then re-sourced the OpenFOAM bashrc file (the easiest way is just to close your terminal window and open a new one - assuming you have the OpenFOAM bashrc file sourced in a start up script like $HOME/.bashrc)

SD@TUB February 23, 2011 05:29

Building ThirdParty without connections to the internet
 
Dear FOAMers:

I'm glad about integrate the ThirdParty-stuff within the OpenFOAM-<version> directory like in 1.6-ext. But my central problem is, that the linux machine that running OF don't have a connection to the www! Now i'm stucking with building the ThirdParty-environment.
Is there only the possibility to download the needed tools hand by hand? Maybe there exist a ThirdParty-collection in the mannar of 1.6.x, 1.7.x, etc.? The ThirdParty-1.6.x doesn't worked for me as well as compiling 1.6-ext with my system settings.


/Stefan

BTW: OS is Debian Lenny 64-bit, additionally REHL DT 5.3 in future.


All times are GMT -4. The time now is 18:28.