CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   openfoam-1.6-ext on Ubuntu 10.10 Maverick (http://www.cfd-online.com/Forums/openfoam-installation/83771-openfoam-1-6-ext-ubuntu-10-10-maverick.html)

rassilon January 11, 2011 02:38

openfoam-1.6-ext on Ubuntu 10.10 Maverick
 
I am trying to install the 1.6-ext version on a Ubuntu 10.10 system. I have followed the instructions provided here for lucid, simply replacing the lucid references with maverick ones, however, I am unable to get the software to install.

My repository entires look like this:

However, when I run

Quote:

sudo apt-get install openfoam-1.6-ext
I get the following error:

Quote:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openfoam-1.6-ext
E: Couldn't find any package by regex 'openfoam-1.6-ext'
Does anybody have any suggestions? I already have 1.7.1 installe, but could really do with 1.6-ext up and running as well.

Cheers,


R

elvis January 11, 2011 16:32

http://ppa.launchpad.net/cae-team/pp...nfoam-1.6-ext/
=> openfoam-1.6-ext-dev_1.6.0-1ppa1~lucid1_amd64.deb
Oliver Borm did not compile for Maverick
so a sources list with maverick will not work
deb http://ppa.launchpad.net/cae-team/ppa/ubuntu/ lucid main
deb-src http://ppa.launchpad.net/cae-team/ppa/ubuntu/ lucid main
do not forget to add non-free for libparmetis3.1

rassilon January 12, 2011 00:45

Quote:

Originally Posted by elvis (Post 290045)
http://ppa.launchpad.net/cae-team/pp...nfoam-1.6-ext/
=> openfoam-1.6-ext-dev_1.6.0-1ppa1~lucid1_amd64.deb
Oliver Borm did not compile for Maverick
so a sources list with maverick will not work
deb http://ppa.launchpad.net/cae-team/ppa/ubuntu/ lucid main
deb-src http://ppa.launchpad.net/cae-team/ppa/ubuntu/ lucid main
do not forget to add non-free for libparmetis3.1


Sorry Elvis,

I have tried a number of combinations of the above, but am struggling - I keep getting the same "unable to find a source package for openfoam-1.6-ext" error each time.

What do I need to put into my sources list? Or should I just download the Lucid .DEB file and try running that? and what do I need to enter to start it building?

Again, I followed the guide on the Wiki, and just ended up with a load of errors. I've wasted nearly 3 days on this now, and am very tempted to just write off 1.6-ext, and just concentrate on the OpenCFD 1.7.1 version.

Grrrr :)


R

elvis January 12, 2011 14:51

Hello rassilon,

source package!? not binary package?
So you tried s.th. like
sudo apt-get source openfoam-1.6-ext openfoam-1.6-ext-dev
=>to get a working OpenFoam installation I just used apt-get install and edited the .bashrc

if you download the sourcepackage i think you have to use dpkg-buildpackage and dpkg-deb i guess.
sourcepackage has no big advantage in comparison of the original GIT-repository and compiling that git from scratch.
Should be s.th. like:
mkdir ~/OpenFOAM
cd ~/OpenFOAM
git clone git://openfoam-extend.git.sourceforge.net/gitroot/openfoam-extend/OpenFOAM-1.6-ext

greets

elvis

elvis January 12, 2011 14:52

Hello rassilon,

why do you want to use OF1.6-extend?
if you need GGI or have a viscoelatic Fluid (Giesekus or so) you depend on extend-Version or Dev-Version.
Otherwise you can use vanilla-Version from OpenCFD.

greets

elvis

rassilon January 12, 2011 18:29

Quote:

Originally Posted by elvis (Post 290180)
Hello rassilon,

why do you want to use OF1.6-extend?
if you need GGI or have a viscoelatic Fluid (Giesekus or so) you depend on extend-Version or Dev-Version.
Otherwise you can use vanilla-Version from OpenCFD.

greets

elvis


Hi Elvis,

There is a bug in the 1.7 version with using interDyMFoam and meshes created in snappyHexMesh leading to a segmentation fault if tried to run in parallel. I wanted to test to see if the same issue were present in the 1.6-ext variant, as I see that they have done some work on the OpenMPI implementation.

I am happy to download and install binaries by hand, but where are they, and how do I do it? I am frustrated by the lack of clear and concise instructions.

Cheers,


R

wyldckat January 13, 2011 18:41

Greetings to all!

@rassilon: OK, I've got Ubuntu 10.10 as well and here is what I did:
  1. Added the repository as indicated in the wiki:
    Code:

    sudo add-apt-repository ppa:cae-team/ppa
  2. Then went to the "Synaptic Package Manager", menu "Settings->Repositories".
  3. In the tab "Other Software", edited the entries for cae-team and changed from maverick to lucid.
  4. Closed the "Repositories" dialog.
  5. Pressed the "Reload" button on the top left in Synaptic.
  6. Wrote "openfoam" on the "Quick search" edit box and voilá, the versions provided by the CAE Team appeared.
  7. I chose the desired packages and installed without any problems!
Best regards and good luck!
Bruno

rassilon January 13, 2011 23:30

Quote:

Originally Posted by wyldckat (Post 290344)
Greetings to all!

@rassilon: OK, I've got Ubuntu 10.10 as well and here is what I did:
  1. Added the repository as indicated in the wiki:
    Code:

    sudo add-apt-repository ppa:cae-team/ppa
  2. Then went to the "Synaptic Package Manager", menu "Settings->Repositories".
  3. In the tab "Other Software", edited the entries for cae-team and changed from maverick to lucid.
  4. Closed the "Repositories" dialog.
  5. Pressed the "Reload" button on the top left in Synaptic.
  6. Wrote "openfoam" on the "Quick search" edit box and voilá, the versions provided by the CAE Team appeared.
  7. I chose the desired packages and installed without any problems!
Best regards and good luck!
Bruno


Cheers Bruno,

That's exactly what I needed! It's all installed and running now, so I can continue with my development.

Thanks.


R

lrunber April 28, 2011 04:37

Thanks wyldckat, your procedure helped me as well.

Please if someone can bare with a newbie, I am having trouble proceeding from here.

*Firstly, installing openfoam-1.6-extend, in this way, I take it, it has already been compiled and therefore no further compilation is necessary?

I have openfoam 1.7.1 installed as well, and when I run wmake on e.g. icoLagrangianFoam, I get the following error

/usr/bin/ld: cannot find -llduSolvers
collect2: ld returned 1 exit status

*Upon inspection, wmake uses the enviromental variables for openfoam 1.7.1 and therefore I am not accessing the extend version libraries. How do I run wmake pointed to the new libraries, located in /usr/lib/OpenFoam-1.6-extend/ ?

Please pity this fool...

wyldckat April 28, 2011 14:20

Greetings lrunber,

Quoting the original instructions:
Quote:

Originally Posted by http://openfoamwiki.net/index.php/Installation#OpenFOAM-dev-1.5_or_OpenFOAM-1.6-ext_under_Ubuntu_Lucid_10.04_LTS
In order to get OpenFOAM running, add the following line to your ~/.bashrc
Code:

alias startOF16ext="source /usr/lib/OpenFOAM-1.6-ext/etc/bashrc"
And each time you want to use OpenFOAM just type startOF16ext in the active terminal.

So, you you add that line to your ~/.bashrc file and edit your current line for 1.7.1 to something like that. For example:
Code:

alias of171='source /opt/openfoam171/etc/bashrc'
Save and close the file ~/.bashrc and start a new terminal window and you're ready to go... after running startOF16ext or of171 ;)

Good luck!
Bruno

lrunber April 28, 2011 15:26

Sincere thanks Bruno, working 100% now. In my frustration I never found that very helpful wiki. Thanks for aiding :)

PeterII April 28, 2011 17:48

problem starting openfoam16ext
 
I am trying to install OpenFOAM-1.5-dev an OpenFOAM-1.6-ext on ubuntu 10.04 Following the instructions at http://openfoamwiki.net/index.php/In...ucid_10.04_LTS. but when I want to start openfoam-1.6-ext I recive
bash: /opt/OpenFOAM-1.6-ext/bin/foamEtcFile: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/bin/foamCleanPath: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/bin/foamCleanPath: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/bin/foamCleanPath: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/etc/settings.sh: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/bin/foamCleanPath: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/bin/foamCleanPath: Aucun fichier ou dossier de ce type
bash: /opt/OpenFOAM-1.6-ext/bin/foamCleanPath: Aucun fichier ou dossier de ce type


can any one help me


wyldckat April 30, 2011 01:28

Greetings Khaled,

OK, it seems to me that you didn't read the previous posts. Anyway, here's what you should do:
  1. Edit your file "~/.bashrc" and remove any lines you have there that have something like this:
    Code:

    . /opt/openfoam171/etc/bashrc
    In other words, remove the lines that are sourcing OpenFOAM environments.
  2. Now, lets set short-cut commands for when you want a particular version/variant of OpenFOAM, by adding the following lines to your file "~/.bashrc":
    Code:

    alias of171='source /opt/openfoam171/etc/bashrc'
    alias startOF16ext="source /usr/lib/OpenFOAM-1.6-ext/etc/bashrc"
    alias startOF15dev="source /usr/lib/OpenFOAM-1.5-dev/etc/bashrc"

  3. Save and close the file "~/.bashrc".
  4. Finally, start a new terminal window/tab. Activate the environment for the respective version you want to start with. For example, run the following command to start the environment for OpenFOAM 1.7.1:
    Code:

    of171
Keep in mind that you cannot have various environments running on the same terminal window/tab. Whenever you need another OpenFOAM version/variant, you must start a new terminal window or tab.

Best regards,
Bruno

PeterII May 3, 2011 14:35

Dear wyldckat
thanks a lot for your reply; I do the proposed correction on the bashrc but the error yet and I recive the response ??
can you help me

theory37 May 5, 2011 15:27

I too am attempting to run 1.7.1 and 1.6-ext on the same (Suse 11.4) machine. My .bashrc is clean (free of FOAM references) and yet if I execute the 1.6-ext bashrc "by hand" from the etc/ folder I get the same problem.

It seems to be that there are certain environment variables that were set by my previous 1.7.1 install that are not being unset / overwritten when I source the 1.6-ext bashrc. I will try to unset these by hand and re-execute the 1.6-ext bashrc. I'll post an update if that works.

Any suggestions? Thanks.

theory37 May 5, 2011 15:41

Fixed it, at least for me
 
Everyone,

It turns out that the offending variable was $FOAM_INST_DIR. For me, unsetting this variable just before I source my bashrc of choice works. Now I can quickly edit my ~/.bashrc to reflect the install I want.

This of course would also work with the shortcut method described above.

A snippet from the relevant section of my ~/.bashrc file:

Code:

unset FOAM_INST_DIR
source /opt/openfoam171/etc/bashrc
#source /home/mmartell/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc

Cheers,

Mike

wyldckat May 6, 2011 14:42

Greetings Khaled and Michael,

Why do I get the feeling that my post #13 is too complicated :( I tried to keep it simple and easy to understand :(

@Khaled: Have you managed to fix the problem yet? If not, does Michael's solution, or the one I'm writing below, work for you?


@Michael: Instead of sourcing your "~/.bashrc" file every time you need to change OpenFOAM version, you can change your lines:
Code:

unset FOAM_INST_DIR
source /opt/openfoam171/etc/bashrc
#source /home/mmartell/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc

To these:
Code:

alias of171='unset FOAM_INST_DIR; source /opt/openfoam171/etc/bashrc'
alias of16ext='unset FOAM_INST_DIR; source /home/mmartell/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'

After closing the file, start a new terminal.

Then you can simply run of171 or of16ext on the command line, depending on the OpenFOAM version/variant you want to use, without having to change "~/.bashrc" whenever you want to change versions! Although I advise you to use different terminal windows whenever you need to use the other OpenFOAM version/variant!


Best regards,
Bruno

theory37 May 6, 2011 14:58

Bruno,

Thanks for the explication. I was aware of and understood your previous post, and have since implemented the idea. I was more interested in the cause behind the problem, i.e. the FOAM_INST_DIR variable and how to fix it.

The proper way to fix it would be to edit the 1.6-ext bashrc, but this is a quick workaround.

Regards,

Mike

PeterII May 11, 2011 09:42

openfoam-1.5-dev
 
I Thank you Bruno, I am attempting to run 1.7.1 and 1.6-ext on Ububtu 10.04 (My .bashrc is clean from openfoam (free of FOAM references)).
I tried Michael's solution and the your solution (adding to my ~/.bashrc file):


alias of171="unset FOAM_IST_DIR; source /opt/openfoam171/etc/bashrc"
alias of15dev="unset FOAM_IST_DIR; source /usr/lib/OpenFOAM-1.5-dev/etc/bashrc"


but I get the same problem only when I use the of15dev alias.

theory37 May 11, 2011 10:42

Khaled,

Did you make sure to re-source your .bashrc after making these changes? If so, would you please copy the error messages you get when you run 'of15dev'?

Thanks,

Mike


All times are GMT -4. The time now is 13:18.