CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

wierd libtool dependency in *.la file

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 26, 2011, 18:35
Default weird libtool dependency in *.la file
  #1
Senior Member
 
Mirko Vukovic
Join Date: Mar 2009
Posts: 159
Rep Power: 7
mirko is on a distinguished road
Hi,

This is on RedHat Enterprise 5 with a Centos OpenFoam 1.7.1.

I was having some problems compiling field patches, and thought that maybe my installation is not quite right. I decided to try and install OF from scratch.

That first required installing gcc, gmp, mpfr, and mpc. The problem is related to building mpfr and mpc:

During the make part of the build, I was getting an error related to /nini/OpenFOAM/THirdParty-1.7.0/platforms/linux64/gmp-5.0.1.lib/libgmp.la.

Looking into the local libmpc.la file, I found an entry related to nini/OpenFOAM/... Deleting this entry allowed make to complete.

In the several *.la files I looked, I found similar entries for 1.7.0 and 1.7.1

I checked my environment variables, and I don't see any traces of OpenFoam there. How else would libtool know about /nini/.../OpenFoam...?

Is it possible that the CentosFOAM installation modified something somewhere (since it is done as root)? What?

In the end, I was able to make and check mpc and mpfr by modifying the *.la files. But still, I would like to know what is causing that problem.

Thanks,

Mirko

Last edited by mirko; January 26, 2011 at 19:18. Reason: spelling error
mirko is offline   Reply With Quote

Old   January 28, 2011, 11:07
Default
  #2
Senior Member
 
Mirko Vukovic
Join Date: Mar 2009
Posts: 159
Rep Power: 7
mirko is on a distinguished road
Quote:
Originally Posted by mirko View Post
Hi,

This is on RedHat Enterprise 5 with a Centos OpenFoam 1.7.1.

I was having some problems compiling field patches, and thought that maybe my installation is not quite right. I decided to try and install OF from scratch.

That first required installing gcc, gmp, mpfr, and mpc. The problem is related to building mpfr and mpc:

During the make part of the build, I was getting an error related to /nini/OpenFOAM/THirdParty-1.7.0/platforms/linux64/gmp-5.0.1.lib/libgmp.la.

Looking into the local libmpc.la file, I found an entry related to nini/OpenFOAM/... Deleting this entry allowed make to complete.

In the several *.la files I looked, I found similar entries for 1.7.0 and 1.7.1

I checked my environment variables, and I don't see any traces of OpenFoam there. How else would libtool know about /nini/.../OpenFoam...?

Is it possible that the CentosFOAM installation modified something somewhere (since it is done as root)? What?

In the end, I was able to make and check mpc and mpfr by modifying the *.la files. But still, I would like to know what is causing that problem.

Thanks,

Mirko
Just to report that the problem went away when I moved the OpenFOAM directories from that user's account.

I looked into the CentosFOAM installation script and nothing sinister jumped out.

Mirko
mirko is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELPInstallation on RedHat90 booosix OpenFOAM Installation 8 July 17, 2007 07:40
DecomposePar links against liblamso0 with OpenMPI jens_klostermann OpenFOAM Bugs 11 June 28, 2007 18:51
gcc and executable file from Mac to Linux simone Marras Main CFD Forum 0 April 8, 2007 16:49
Results saving in CFD hawk Main CFD Forum 16 July 21, 2005 21:51
error while compiling the USER Sub routine CFD user CFX 3 November 25, 2002 16:16


All times are GMT -4. The time now is 14:42.