CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFoam 2.0.0 installation

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   July 9, 2011, 14:12
Default
  #41
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Indeed, I'm stumped as well here. I just ran with the latest OpenFOAM-1.7.x and ThirdParty-1.7.x, both from the git repository on an old Ubuntu 8.04 64 bit inside a virtual machine and there were no problems! It uses by default flex 2.5.34!

By the way, the "git clone" I had posted a while back, namely post #22, was pointing to the OpenFOAM repo when it should have been pointed as now it is, to ThirdParty-1.7.x:
Code:
git clone git://github.com/OpenCFD/ThirdParty-2.0.x.git
I did the following steps after cloning both repositories:
  1. I used my getter scripts to get Gcc et al, as well as Scotch and OpenMPI. Those were from here (also see post #22), namely:
  1. I added those two aliases wmSC and wmMC to etc/config/aliases.sh (see post #26).
  2. I edited etc/config/settings.sh, on the Gcc45 entry and changed 4.5.2 to 4.5.1. This way the default Gcc option is left unchanged.
  3. Then I used a non intrusive way of initializing the environment, namely I use the following alias command:
    Code:
    alias of20x-linux64='. $HOME/OpenFOAM/OpenFOAM-2.0.x/etc/bashrc foamCompiler=ThirdParty WM_COMPILER=Gcc45'
    It will use the custom compiler and the Gcc45 option I mentioned in the previous point. So whenever I needed the OpenFOAM environment or a refreshed environment, I ran of20x-linux64 (instead of wmSET).
  4. Ran the commands of20x-linux64 and wmMC to start the environment.
  5. I ran makeGcc to build gcc et al.
  6. Then of20x-linux64 and wmMC again, just to be certain.
  7. And finally I ran Allwmake.
Honestly, my only guess left is to try to start over once more, along with the steps I just took This way we will all be certain that there wasn't anything left from the previous installations that might hinder the build process!

Best regards and good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   July 13, 2011, 07:37
Default
  #42
Senior Member
 
Anne Gerdes
Join Date: Aug 2010
Location: Hamburg
Posts: 152
Rep Power: 6
Anne Lincke is on a distinguished road
Dear Bruno.
I did the steps that you suggested now 3 or 4 times, always starting from the beginning.
Nevertheless the compilation failed.

HTML Code:
/usr/bin/ld: cannot find -lEulerianInterfacialModels
collect2: ld gab 1 als Ende-Status zurück
make[2]: *** [/home/lincke/OpenFOAM/OpenFOAM-2.0.x/platforms/linux64Gcc45DPOpt/bin/twoPhaseEulerFoam] Fehler 1
make[1]: *** [twoPhaseEulerFoam] Fehler 2
make[1]: Das Target »application« wurde wegen Fehlern nicht aktualisiert.
make: *** [multiphase] Fehler 2
make: Das Target »application« wurde wegen Fehlern nicht aktualisiert.
I will attach the whole log file, too.
Attached Files
File Type: gz log13072011.tar.gz (185 Bytes, 3 views)
Anne Lincke is offline   Reply With Quote

Old   July 13, 2011, 15:41
Default
  #43
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Anne,

Hold on... I think with all of going back and forth, the system's gcc got in the way! Check which gcc and g++ is visible:
Code:
which gcc
which g++
gcc -v
g++ -v
If it's the version 4.1.2 or 4.2.1, then the gcc version you built isn't getting picked up properly. You might have missed one of the steps... possibly this step:
Quote:
I edited etc/config/settings.sh, on the Gcc45 entry and changed 4.5.2 to 4.5.1. This way the default Gcc option is left unchanged.
Or the other possibility is that you ran wmSET somewhere along the way. The problem with wmSET is that it will not refresh those options I wrote about in the previous post, namely:
Code:
alias of20x-linux64='. $HOME/OpenFOAM/OpenFOAM-2.0.x/etc/bashrc foamCompiler=ThirdParty WM_COMPILER=Gcc45'
If this was the case, then it's better to put these options on yet another file, namely etc/prefs.sh and put inside the following code:
Code:
foamCompiler=ThirdParty
WM_COMPILER=Gcc45
With this file, wmSET will always refresh with the proper variables. And this means that the previous alias command can now simply be:
Code:
alias of20x-linux64='. $HOME/OpenFOAM/OpenFOAM-2.0.x/etc/bashrc'
OK, once you've finally gotten the right gcc 4.5.1 to be visible again, you'll have to run the following commands:
Code:
foam
wcleanAll
wcleanLnIncludeAll
./Allwmake > make.log 2>&1
Hopefully, this will finally get you OpenFOAM 2.0.x properly compiled! It will take a while, since the *clean* commands will make sure that there haven't been any contamination left made by gcc 4.1.2...

Best regards and good luck!
Bruno
wyldckat is offline   Reply With Quote

Old   July 14, 2011, 04:02
Default
  #44
Senior Member
 
Anne Gerdes
Join Date: Aug 2010
Location: Hamburg
Posts: 152
Rep Power: 6
Anne Lincke is on a distinguished road
Good morning Bruno!
I checked for the gcc, and found out that the right gcc - version was already visible.

HTML Code:
lincke@master:~/OpenFOAM/OpenFOAM-2.0.x> which gcc
/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1/bin/gcc
lincke@master:~/OpenFOAM/OpenFOAM-2.0.x> which g++
/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1/bin/g++
lincke@master:~/OpenFOAM/OpenFOAM-2.0.x> gcc -v
Es werden eingebaute Spezifikationen verwendet.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1/libexec/gcc/x86_64-unknown-linux-gnu/4.5.1/lto-wrapper
Ziel: x86_64-unknown-linux-gnu
Konfiguriert mit: /home/lincke/OpenFOAM/ThirdParty-2.0.x/gcc-4.5.1/configure --prefix=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1 --with-gmp=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gmp-5.0.1 --with-mpfr=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/mpfr-2.4.2 --with-mpc=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/mpc-0.8.1 --with-pkgversion=OpenFOAM --enable-languages=c,c++ --enable-__cxa_atexit --enable-libstdcxx-allocator=new --with-system-zlib
Thread-Modell: posix
gcc-Version 4.5.1 (OpenFOAM) 
lincke@master:~/OpenFOAM/OpenFOAM-2.0.x> g++ -v
Es werden eingebaute Spezifikationen verwendet.
COLLECT_GCC=g++
COLLECT_LTO_WRAPPER=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1/libexec/gcc/x86_64-unknown-linux-gnu/4.5.1/lto-wrapper
Ziel: x86_64-unknown-linux-gnu
Konfiguriert mit: /home/lincke/OpenFOAM/ThirdParty-2.0.x/gcc-4.5.1/configure --prefix=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1 --with-gmp=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gmp-5.0.1 --with-mpfr=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/mpfr-2.4.2 --with-mpc=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/mpc-0.8.1 --with-pkgversion=OpenFOAM --enable-languages=c,c++ --enable-__cxa_atexit --enable-libstdcxx-allocator=new --with-system-zlib
Thread-Modell: posix
gcc-Version 4.5.1 (OpenFOAM) 
So I do not think that this is the problem... Nevertheless I tried the clean-commands you suggested and compiled once again.
The output is attached once again....

Thank you very much for your help. I wish you a nice day!

Regards
Anne
Attached Files
File Type: gz make.log14072011.tar.gz (77.7 KB, 11 views)
Anne Lincke is offline   Reply With Quote

Old   July 14, 2011, 05:05
Default
  #45
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Good morning Anne,

that flex is sure being uncooperative It's the only problem in the whole installation process!!

You're going to have to either demand the latest flex 2.5.35, or install it yourself from here onto your workspace. You can download it from here: http://flex.sourceforge.net/

Building flex should be simple enough:
Code:
./configure --prefix=/home/lincke/OpenFOAM/ThirdParty-2.0.x/platforms/linux64/gcc-4.5.1/
make
make install
This way you'll get the latest flex right next to the custom gcc

Then try running Allwmake straight away. If it still won't work, try cleaning up again...
If after that it still won't work... it's going to have to be some other crazy problem

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 14, 2011, 11:17
Default
  #46
Senior Member
 
Anne Gerdes
Join Date: Aug 2010
Location: Hamburg
Posts: 152
Rep Power: 6
Anne Lincke is on a distinguished road


I installed the latest flex version, and now everything is fine.
It compiled for hours and there was no error (as far as I can see)!!

I can't believe it. For the future I definitely learned that I should always check for gcc and flex.

THANK YOU VERY MUCH!!!
Anne Lincke is offline   Reply With Quote

Old   July 25, 2011, 05:19
Default
  #47
New Member
 
Join Date: Jul 2011
Posts: 6
Rep Power: 5
Homer is on a distinguished road
Hi there,

I'm also trying to install OpenFOAM 2.0.x on my computer (clean OpenSUSE 11.4 installation).
When checking the installation with foamInstallationTest I get:

PHP Code:
Checking the OpenFOAM env variables set on the PATH...                                            
-------------------------------------------------------------------------------                   
Environment_variable Set_to_file_or_directory                Valid Path Crit                      
-------------------------------------------------------------------------------                   
$WM_PROJECT_DIR      /home/simulation/OpenFOAM/OpenFOAM-2.0.x  yes  yes  yes                      
                                                                                                  
$FOAM_APPBIN         
....0.x/platforms/linux64Gcc45DPOpt/bin  no        yes                       
$FOAM_SITE_APPBIN    
....0.x/platforms/linux64Gcc45DPOpt/bin  no        no                        
$FOAM_USER_APPBIN    
....0.x/platforms/linux64Gcc45DPOpt/bin  no        no                        
$WM_DIR              
...lation/OpenFOAM/OpenFOAM-2.0.x/wmake  yes  yes  yes                       
------------------------------------------------------------------------------- 
So there is a problem with $FOAM_APPBIN. Is there a config file I have to edit?

Kind regards Homer
Homer is offline   Reply With Quote

Old   July 25, 2011, 05:54
Default
  #48
Senior Member
 
Aurelien Thinat
Join Date: Jul 2010
Posts: 154
Rep Power: 7
Aurelien Thinat is on a distinguished road
Hi everybody,

I'm trying to install paraFoam (OF-2.0.0). The OS is an OpenSuse11.2 64 bits.

I have put the librairies qt-everywhere-opensource-src-4.6.4 and gmp-5.0.1 in the ThirdParty-2.0.0 folder. Then I have compiled both creating a folder "./build/linux64Gcc".

Finally, I have modified the path of the qmake in the makeParaFoam file and launched the compilation.

There was no error message but when I try to launch paraFoam (or paraview) after sourcing OF-2.0.0, I get :
"/home/trap/OpenFOAM/ThirdParty-2.0.0/platforms/linux64Gcc/paraview-3.10.1/lib/paraview-3.10.1/paraview: symbol look up error: /home/trap/OpenFOAM/ThirdParty-2.0.0/platforms/linux64Gcc/paraview-3.10.1/lib/paraview-3.10.1/lib/paraview-3.10/libpqWidgets.so: undefined symbol: _ZNK16QAbstractSpinBox16inputMethodQueryEN2Qt16Inp utMethodQueryE"

I don't understand the meaning of this error. I tried to find the .so file mentionned but unsuccessfully. All I found was paraFoam .rpm files...

Does anyone of you have an idea to solve this problem ?

Thank you.

Aurelien

Last edited by Aurelien Thinat; July 25, 2011 at 06:35.
Aurelien Thinat is offline   Reply With Quote

Old   July 25, 2011, 06:47
Default
  #49
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
OK, I'm going to post in a two for one...
______________


Greetings Homer and welcome to the forum!

Try following these instructions: OpenFOAM 2.0.x and openSUSE 11.4


______________

Hi Aurelien,

Unfortunately I haven't yet built ParaView 3.10.1 in OpenFOAM 2.0. The only clues I can provide right now are these:
I'll try to create another blog post at the end of the day, with updated instructions.


Best regards,
Bruno

Last edited by wyldckat; July 26, 2011 at 03:34. Reason: by reading half asleep, I confused Aurelien with Anne... Sorry Aurelien!
wyldckat is offline   Reply With Quote

Old   July 25, 2011, 11:47
Default
  #50
New Member
 
Join Date: Jul 2011
Posts: 6
Rep Power: 5
Homer is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
OK, I'm going to post in a two for one...
______________


Greetings Homer and welcome to the forum!

Try following these instructions: OpenFOAM 2.0.x and openSUSE 11.4

Best regards,
Bruno
Thanks for the quick reply. I already saw this web page, but unfortunatly there is still a problem:
Code:
Checking basic setup...
-------------------------------------------------------------------------------
Shell:              bash
Host:               dhcppc3
OS:                 Linux version 2.6.37.1-1.2-desktop
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid      Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/simulation/OpenFOAM                yes       yes
$WM_PROJECT_USER_DIR ...simulation/OpenFOAM/simulation-2.0.x  no        no
$WM_THIRD_PARTY_DIR  ...simulation/OpenFOAM/ThirdParty-2.0.x  yes       yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR      /home/simulation/OpenFOAM/OpenFOAM-2.0.x  yes  yes  yes

$FOAM_APPBIN         ....0.x/platforms/linux64Gcc45DPOpt/bin  no        yes
$FOAM_SITE_APPBIN    ....0.x/platforms/linux64Gcc45DPOpt/bin  no        no
$FOAM_USER_APPBIN    ....0.x/platforms/linux64Gcc45DPOpt/bin  no        no
$WM_DIR              ...lation/OpenFOAM/OpenFOAM-2.0.x/wmake  yes  yes  yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN         ....0.x/platforms/linux64Gcc45DPOpt/lib  no        yes
$FOAM_SITE_LIBBIN    ....0.x/platforms/linux64Gcc45DPOpt/lib  no        no
$FOAM_USER_LIBBIN    ....0.x/platforms/linux64Gcc45DPOpt/lib  no        no
$MPI_ARCH_PATH       /usr/lib64/mpi/gcc/openmpi               yes   no  yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version   Location 
-------------------------------------------------------------------------------
flex     2.5.35    /usr/bin/flex                                            
gcc      4.5.1     /usr/bin/gcc                                             
gzip     1.4       /usr/bin/gzip                                            
tar      1.25      /bin/tar                                                 
icoFoam           
WARNING:  Conflicting installations:
          OpenFOAM settings        : /home/simulation/OpenFOAM/OpenFOAM-2.0.x/platforms/linux64Gcc45DPOpt/bin/icoFoam
          current path             : 
          CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.
The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for troubleshooting.

Done

simulation@dhcppc3:~/OpenFOAM/OpenFOAM-2.0.x/bin>
Homer is offline   Reply With Quote

Old   July 25, 2011, 19:44
Default
  #51
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
@Anne: I haven't had time to fully verify these instructions: http://www.cfd-online.com/Forums/blo...-qt-4-6-4.html
At the time of writing this post, ParaView was still building
edit: OK, it's now somewhat confirmed that the instructions work, after I made some changes to them. Keep in mind that for now they only work with bash; csh is going to have to wait...

@Homer: What do you have at the end of the file "~/.bashrc"? Is it something like this :
Code:
source $HOME/OpenFOAM/OpenFOAM-2.0.x/etc/bashrc
If so, is it the only line related to OpenFOAM that you have in "~/.bashrc"?

Best regards,
Bruno

Last edited by wyldckat; July 25, 2011 at 20:39. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Old   July 26, 2011, 03:03
Default
  #52
New Member
 
Join Date: Jul 2011
Posts: 6
Rep Power: 5
Homer is on a distinguished road
My bash-File is:

Code:
# Sample .bashrc for SuSE Linux
# Copyright (c) SuSE GmbH Nuernberg

# There are 3 different types of shells in bash: the login shell, normal shell
# and interactive shell. Login shells read ~/.profile and interactive shells
# read ~/.bashrc; in our setup, /etc/profile sources ~/.bashrc - thus all
# settings made here will also take effect in a login shell.
#
# NOTE: It is recommended to make language settings in ~/.profile rather than
# here, since multilingual X sessions would not work properly if LANG is over-
# ridden in every subshell.

# Some applications read the EDITOR variable to determine your favourite text
# editor. So uncomment the line below and enter the editor of your choice :-)
#export EDITOR=/usr/bin/vim
#export EDITOR=/usr/bin/mcedit

# For some news readers it makes sense to specify the NEWSSERVER variable here
#export NEWSSERVER=your.news.server

# If you want to use a Palm device with Linux, uncomment the two lines below.
# For some (older) Palm Pilots, you might need to set a lower baud rate
# e.g. 57600 or 38400; lowest is 9600 (very slow!)
#
#export PILOTPORT=/dev/pilot
#export PILOTRATE=115200

#.$HOME/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc
#$HOME/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc
test -s ~/.alias && . ~/.alias || true
#. /opt/openfoam171/etc/bashrc
export WM_NCOMPPROCS=2
source $HOME/OpenFOAM/OpenFOAM-2.0.x/etc/bashrc
Homer is offline   Reply With Quote

Old   July 26, 2011, 03:08
Default
  #53
New Member
 
Join Date: Jul 2011
Posts: 6
Rep Power: 5
Homer is on a distinguished road
I also saved the makelog-File. Maybe this helps?
Attached Files
File Type: gz make.log.gz (82.1 KB, 1 views)
Homer is offline   Reply With Quote

Old   July 26, 2011, 03:43
Default
  #54
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Homer,

Good thing you posted the log file. Apparently OpenMPI isn't being seen by OpenFOAM's build system. Did you install all of the necessary packages for OpenMPI?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 26, 2011, 05:06
Default
  #55
New Member
 
Join Date: Jul 2011
Posts: 6
Rep Power: 5
Homer is on a distinguished road
Hi Bruno,

as I am no Linux-Specialist, I'm sometimes not sure, if I do it right. But I followed precisely the ToDo here: http://albertopassalacqua.com/?p=973

But I checked it once again:

Code:
simulation@dhcppc3:~/OpenFOAM/OpenFOAM-2.0.x> sudo zypper install openmpi
Daten des Repositorys laden ...
Installierte Pakete lesen ...
'openmpi' ist bereits installiert.
No update candidate for 'openmpi-1.2.8-17.4.x86_64'. The highest available version is already installed.
Paketabhängigkeiten auflösen ...

Keine auszuführenden Aktionen.
simulation@dhcppc3:~/OpenFOAM/OpenFOAM-2.0.x> mpi-selector --list
openmpi-1.2.8
simulation@dhcppc3:~/OpenFOAM/OpenFOAM-2.0.x>
Are there any additional packages concerning openmpi necessary?
Homer is offline   Reply With Quote

Old   July 26, 2011, 16:55
Default
  #56
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Homer,

Well this is a bit surreal... I usually fix these kinds of things by starting a new terminal. In this case, we have actually have to log out and log back in!!
I only figured this out after reading this post at forums.opensuse.org: http://forums.opensuse.org/english/o...ml#post1977744

But before that, I already had used the command mpi-selector-menu as root to set it as "system wide" and then as "user based", with no change in the outcome. Logging out and logging back in fixed the missing link...

----
Now where's my shotgun... I've gotta blow a hole or two on a certain Linux distro... (walks out the door raging mad with a shotgun...)

(Now looking at openSUSE) What's the big idea of acting like Windows? (Bam Bam...) Did you learn your lesson now?
Y'ain't no stinking Windows, now ar'ya?
----


Anyway, interlude aside... Another package you are going to need is openmpi-devel. This provides the much needed mpi.h file and respective company .

I hope this will fix the problem

Best regards,
Bruno

Last edited by wyldckat; July 26, 2011 at 16:56. Reason: typos...
wyldckat is offline   Reply With Quote

Old   July 27, 2011, 04:02
Default
  #57
New Member
 
Join Date: Jul 2011
Posts: 6
Rep Power: 5
Homer is on a distinguished road
Quote:
Originally Posted by wyldckat View Post
I hope this will fix the problem

Best regards,
Bruno
Yes, it did the trick! I installed openmpi-devel and foamInstallationTest shows now:

Code:
Summary
-------------------------------------------------------------------------------
Base configuration ok.
Critical systems ok.
I think openmpi-devel should be mentioned as necessary package.

Thank you very much for your assistance.

Kind regards Homer
Homer is offline   Reply With Quote

Old   August 6, 2011, 15:32
Default Revised HowTo online
  #58
Senior Member
 
Bernhard Linseisen
Join Date: May 2010
Location: Magdeburg/Geneva
Posts: 176
Blog Entries: 1
Rep Power: 7
Linse is on a distinguished road
Dear Foamers,

somewhere up this thread (Post #25) I posted a HowTo on installing OF2 on SLC 5.6.
A slightly more extensive Howto by now is available at http://cern.ch/blinseis in the section about OpenFOAM.

In case anybody else tried it (and succeeded), could you please send me a message, particularly stating on what version you built?
I would like to know, how far down-gradable that HowTo would be, but I don't have any experience concerning virtual machines and setting up older systems within them, so trials would mean completely setting up a new system for me...
Linse is offline   Reply With Quote

Old   August 23, 2011, 05:32
Default hii brunosir,
  #59
Member
 
Jignesh
Join Date: Aug 2011
Location: India
Posts: 68
Rep Power: 5
jignesh_thaker2007 is on a distinguished road
Send a message via Yahoo to jignesh_thaker2007
plz tel me installation about openfoam2.0.0

i m new user of openfoam

Actually i install openfoam2.0.0 ubuntu pack on my ubuntu11.04.

i started to solved the tutorials.

but plz tel me after installing the openfoam ubuntu pack is it require to install any source pack?
and also tel me is it necessary to install git repository?

because when i install it i found error like
apt-get install git-core
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

so plz solve my problem

i m waiting for ur reply
jignesh_thaker2007 is offline   Reply With Quote

Old   August 23, 2011, 05:37
Default
  #60
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,258
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings jignesh_thaker2007,

Quote:
Originally Posted by jignesh_thaker2007 View Post
Actually i install openfoam2.0.0 ubuntu pack on my ubuntu11.04.

i started to solved the tutorials.

but plz tel me after installing the openfoam ubuntu pack is it require to install any source pack?
and also tel me is it necessary to install git repository?
If it is already working, why do you think it's necessary to install more stuff?

Quote:
Originally Posted by jignesh_thaker2007 View Post
because when i install it i found error like
apt-get install git-core
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
Try using sudo:
Code:
sudo apt-get install git-core
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Critical errors during OpenFoam installation in OpenSuse 11.0 amscosta OpenFOAM 5 May 1, 2009 14:06
OpenFOAM 1.5 installation on OpenSUSE 11.0 bigphil OpenFOAM Installation 16 April 29, 2009 06:28
Problem installing OpenFOAM 1.5 installation on RHEL 4. vwsj84 OpenFOAM Installation 4 April 23, 2009 04:48
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 22:11.